summaryrefslogtreecommitdiffstats
path: root/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb')
-rw-r--r--meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
new file mode 100644
index 0000000000..1438ad84d6
--- /dev/null
+++ b/meta-skeleton/recipes-kernel/linux/linux-yocto-custom.bb
@@ -0,0 +1,46 @@
1# linux-yocto-custom.bb:
2#
3# Provides an example/minimal kernel recipe that uses the linux-yocto
4# and oe-core kernel classes to apply a subset of yocto kernel
5# management to git managed kernel repositories.
6#
7# Notes:
8#
9# kconfig(s): the kernel must be configured with a defconfig, or via
10# configuration fragment(s). Either of these can be added
11# via bbappend.
12# patches: patches can be merged into to the source git tree itself, added
13# using standard bbappend syntax or controlled via .scc feature
14# descriptions (also via bbappends)
15#
16# example configuration addition:
17# SRC_URI += "file://smp.cfg"
18# example patch addition (for kernel v3.4 only):
19# SRC_URI += "file://0001-linux-version-tweak.patch
20# example feature addition (for kernel v3.4 only):
21# SRC_URI += "file://feature.scc"
22#
23# Warning:
24#
25# Building the sample kernel tree (kernel.org) without providing any
26# configuration will result in build or boot errors. This is not a bug
27# it is a required element for creating a valid kernel.
28#
29
30inherit kernel
31require recipes-kernel/linux/linux-yocto.inc
32
33SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git;protocol=git;nocheckout=1"
34
35LINUX_VERSION ?= "3.4"
36LINUX_VERSION_EXTENSION ?= "-custom"
37
38# tag: v3.4 76e10d158efb6d4516018846f60c2ab5501900bc
39SRCREV="76e10d158efb6d4516018846f60c2ab5501900bc"
40
41PR = "r0"
42PV = "${LINUX_VERSION}+git${SRCPV}"
43
44COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
45
46require recipes-kernel/linux/linux-tools.inc