summaryrefslogtreecommitdiffstats
path: root/meta-selftest/recipes-test
diff options
context:
space:
mode:
Diffstat (limited to 'meta-selftest/recipes-test')
-rw-r--r--meta-selftest/recipes-test/cpp/cpp-example.inc3
-rw-r--r--meta-selftest/recipes-test/devtool/devtool-test-localonly.bb3
-rw-r--r--meta-selftest/recipes-test/fortran/fortran-helloworld.bb2
-rw-r--r--meta-selftest/recipes-test/recipetool/selftest-recipetool-appendfile.bb16
-rw-r--r--meta-selftest/recipes-test/recipeutils/recipeutils-test_1.2.bb5
-rw-r--r--meta-selftest/recipes-test/selftest-chown/selftest-chown.bb3
-rw-r--r--meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb5
-rw-r--r--meta-selftest/recipes-test/selftest-hello/selftest-hello_1.0.bb5
-rw-r--r--meta-selftest/recipes-test/selftest-users/acreategroup.bb3
-rw-r--r--meta-selftest/recipes-test/selftest-users/bcreategroup.bb3
-rw-r--r--meta-selftest/recipes-test/selftest-users/ccreategroup.bb3
-rw-r--r--meta-selftest/recipes-test/selftest-users/creategroup1.bb3
-rw-r--r--meta-selftest/recipes-test/selftest-users/creategroup2.bb3
-rw-r--r--meta-selftest/recipes-test/selftest-users/dcreategroup.bb3
-rw-r--r--meta-selftest/recipes-test/selftest-users/useraddbadtask.bb3
-rw-r--r--meta-selftest/recipes-test/testrpm/testrpm_0.0.1.bb3
-rw-r--r--meta-selftest/recipes-test/wrapper/cmdline-shebang-wrapper-test.bb2
17 files changed, 44 insertions, 24 deletions
diff --git a/meta-selftest/recipes-test/cpp/cpp-example.inc b/meta-selftest/recipes-test/cpp/cpp-example.inc
index ad374be9d0..41aaa7219a 100644
--- a/meta-selftest/recipes-test/cpp/cpp-example.inc
+++ b/meta-selftest/recipes-test/cpp/cpp-example.inc
@@ -19,6 +19,7 @@ SRC_URI = "\
19 file://run-ptest \ 19 file://run-ptest \
20" 20"
21 21
22S = "${WORKDIR}" 22S = "${WORKDIR}/sources"
23UNPACKDIR = "${S}"
23 24
24inherit ptest 25inherit ptest
diff --git a/meta-selftest/recipes-test/devtool/devtool-test-localonly.bb b/meta-selftest/recipes-test/devtool/devtool-test-localonly.bb
index e767619879..446c51f09b 100644
--- a/meta-selftest/recipes-test/devtool/devtool-test-localonly.bb
+++ b/meta-selftest/recipes-test/devtool/devtool-test-localonly.bb
@@ -6,5 +6,8 @@ SRC_URI = "file://file1 \
6 6
7SRC_URI:append:class-native = " file://file3" 7SRC_URI:append:class-native = " file://file3"
8 8
9S = "${WORKDIR}/sources"
10UNPACKDIR = "${S}"
11
9EXCLUDE_FROM_WORLD = "1" 12EXCLUDE_FROM_WORLD = "1"
10BBCLASSEXTEND = "native" 13BBCLASSEXTEND = "native"
diff --git a/meta-selftest/recipes-test/fortran/fortran-helloworld.bb b/meta-selftest/recipes-test/fortran/fortran-helloworld.bb
index 3a46404477..a897966608 100644
--- a/meta-selftest/recipes-test/fortran/fortran-helloworld.bb
+++ b/meta-selftest/recipes-test/fortran/fortran-helloworld.bb
@@ -11,7 +11,7 @@ SECURITY_CFLAGS = ""
11SECURITY_LDFLAGS = "" 11SECURITY_LDFLAGS = ""
12 12
13do_compile() { 13do_compile() {
14 ${FC} ${LDFLAGS} ${WORKDIR}/hello.f95 -o ${B}/fortran-hello 14 ${FC} ${LDFLAGS} ${UNPACKDIR}/hello.f95 -o ${B}/fortran-hello
15} 15}
16 16
17do_install() { 17do_install() {
diff --git a/meta-selftest/recipes-test/recipetool/selftest-recipetool-appendfile.bb b/meta-selftest/recipes-test/recipetool/selftest-recipetool-appendfile.bb
index e127b48b15..7698413d4d 100644
--- a/meta-selftest/recipes-test/recipetool/selftest-recipetool-appendfile.bb
+++ b/meta-selftest/recipes-test/recipetool/selftest-recipetool-appendfile.bb
@@ -17,20 +17,20 @@ SRC_URI = "file://installscript.sh \
17EXCLUDE_FROM_WORLD = "1" 17EXCLUDE_FROM_WORLD = "1"
18 18
19install_extrafunc() { 19install_extrafunc() {
20 install -m 0644 ${WORKDIR}/selftest-replaceme-inst-func ${D}${datadir}/selftest-replaceme-inst-func 20 install -m 0644 ${UNPACKDIR}/selftest-replaceme-inst-func ${D}${datadir}/selftest-replaceme-inst-func
21} 21}
22 22
23do_install() { 23do_install() {
24 install -d ${D}${datadir}/ 24 install -d ${D}${datadir}/
25 install -m 0644 ${WORKDIR}/selftest-replaceme-orig ${D}${datadir}/selftest-replaceme-orig 25 install -m 0644 ${UNPACKDIR}/selftest-replaceme-orig ${D}${datadir}/selftest-replaceme-orig
26 install -m 0644 ${WORKDIR}/selftest-replaceme-todir ${D}${datadir} 26 install -m 0644 ${UNPACKDIR}/selftest-replaceme-todir ${D}${datadir}
27 install -m 0644 ${WORKDIR}/file1 ${D}${datadir}/selftest-replaceme-renamed 27 install -m 0644 ${UNPACKDIR}/file1 ${D}${datadir}/selftest-replaceme-renamed
28 install -m 0644 ${WORKDIR}/subdir/fileinsubdir ${D}${datadir}/selftest-replaceme-subdir 28 install -m 0644 ${UNPACKDIR}/subdir/fileinsubdir ${D}${datadir}/selftest-replaceme-subdir
29 cp ${WORKDIR}/selftest-replaceme-inst-glob* ${D}${datadir}/selftest-replaceme-inst-globfile 29 cp ${UNPACKDIR}/selftest-replaceme-inst-glob* ${D}${datadir}/selftest-replaceme-inst-globfile
30 cp ${WORKDIR}/selftest-replaceme-inst-todir-glob* ${D}${datadir} 30 cp ${UNPACKDIR}/selftest-replaceme-inst-todir-glob* ${D}${datadir}
31 install -d ${D}${sysconfdir} 31 install -d ${D}${sysconfdir}
32 install -m 0644 ${S}/file2 ${D}${sysconfdir}/selftest-replaceme-patched 32 install -m 0644 ${S}/file2 ${D}${sysconfdir}/selftest-replaceme-patched
33 sh ${WORKDIR}/installscript.sh ${D}${datadir} 33 sh ${UNPACKDIR}/installscript.sh ${D}${datadir}
34 install_extrafunc 34 install_extrafunc
35} 35}
36 36
diff --git a/meta-selftest/recipes-test/recipeutils/recipeutils-test_1.2.bb b/meta-selftest/recipes-test/recipeutils/recipeutils-test_1.2.bb
index ad9f475d15..8b314d396e 100644
--- a/meta-selftest/recipes-test/recipeutils/recipeutils-test_1.2.bb
+++ b/meta-selftest/recipes-test/recipeutils/recipeutils-test_1.2.bb
@@ -3,9 +3,12 @@ SUMMARY = "Test recipe for recipeutils.patch_recipe()"
3require recipeutils-test.inc 3require recipeutils-test.inc
4 4
5LICENSE = "HPND" 5LICENSE = "HPND"
6LIC_FILES_CHKSUM = "file://${WORKDIR}/somefile;md5=d41d8cd98f00b204e9800998ecf8427e" 6LIC_FILES_CHKSUM = "file://${UNPACKDIR}/somefile;md5=d41d8cd98f00b204e9800998ecf8427e"
7DEPENDS += "zlib" 7DEPENDS += "zlib"
8 8
9S = "${WORKDIR}/sources"
10UNPACKDIR = "${S}"
11
9BBCLASSEXTEND = "native nativesdk" 12BBCLASSEXTEND = "native nativesdk"
10 13
11SRC_URI += "file://somefile" 14SRC_URI += "file://somefile"
diff --git a/meta-selftest/recipes-test/selftest-chown/selftest-chown.bb b/meta-selftest/recipes-test/selftest-chown/selftest-chown.bb
index aa6ce0c2a0..a0eeb4f223 100644
--- a/meta-selftest/recipes-test/selftest-chown/selftest-chown.bb
+++ b/meta-selftest/recipes-test/selftest-chown/selftest-chown.bb
@@ -5,7 +5,8 @@ LICENSE = "MIT"
5 5
6DEPENDS += "coreutils-native" 6DEPENDS += "coreutils-native"
7 7
8S = "${WORKDIR}" 8S = "${WORKDIR}/sources"
9UNPACKDIR = "${S}"
9 10
10inherit useradd allarch 11inherit useradd allarch
11 12
diff --git a/meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb b/meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb
index be346b8a0e..5632bdac7a 100644
--- a/meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb
+++ b/meta-selftest/recipes-test/selftest-hardlink/selftest-hardlink.bb
@@ -6,7 +6,8 @@ SRC_URI = "file://hello.c \
6 file://gdb.sh \ 6 file://gdb.sh \
7" 7"
8 8
9S = "${WORKDIR}" 9S = "${WORKDIR}/sources"
10UNPACKDIR = "${S}"
10 11
11do_compile () { 12do_compile () {
12 ${CC} hello.c -o hello1 ${CFLAGS} ${LDFLAGS} 13 ${CC} hello.c -o hello1 ${CFLAGS} ${LDFLAGS}
@@ -14,7 +15,7 @@ do_compile () {
14 15
15do_install () { 16do_install () {
16 install -d ${D}${bindir} 17 install -d ${D}${bindir}
17 install -m 755 ${WORKDIR}/gdb.sh ${D}${bindir}/ 18 install -m 755 ${S}/gdb.sh ${D}${bindir}/
18 install -m 755 hello1 ${D}${bindir}/hello1 19 install -m 755 hello1 ${D}${bindir}/hello1
19 ln ${D}${bindir}/hello1 ${D}${bindir}/hello2 20 ln ${D}${bindir}/hello1 ${D}${bindir}/hello2
20 21
diff --git a/meta-selftest/recipes-test/selftest-hello/selftest-hello_1.0.bb b/meta-selftest/recipes-test/selftest-hello/selftest-hello_1.0.bb
index 547587bef4..2dc352d479 100644
--- a/meta-selftest/recipes-test/selftest-hello/selftest-hello_1.0.bb
+++ b/meta-selftest/recipes-test/selftest-hello/selftest-hello_1.0.bb
@@ -5,7 +5,8 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
5 5
6SRC_URI = "file://helloworld.c" 6SRC_URI = "file://helloworld.c"
7 7
8S = "${WORKDIR}" 8S = "${WORKDIR}/sources"
9UNPACKDIR = "${S}"
9 10
10do_compile() { 11do_compile() {
11 ${CC} ${CFLAGS} ${LDFLAGS} helloworld.c -o helloworld 12 ${CC} ${CFLAGS} ${LDFLAGS} helloworld.c -o helloworld
@@ -16,4 +17,4 @@ do_install() {
16 install -m 0755 helloworld ${D}${bindir} 17 install -m 0755 helloworld ${D}${bindir}
17} 18}
18 19
19BBCLASSEXTEND = "native nativesdk" \ No newline at end of file 20BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-selftest/recipes-test/selftest-users/acreategroup.bb b/meta-selftest/recipes-test/selftest-users/acreategroup.bb
index 66ed5695a2..7805182d48 100644
--- a/meta-selftest/recipes-test/selftest-users/acreategroup.bb
+++ b/meta-selftest/recipes-test/selftest-users/acreategroup.bb
@@ -3,7 +3,8 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
3 3
4LICENSE = "MIT" 4LICENSE = "MIT"
5 5
6S = "${WORKDIR}" 6S = "${WORKDIR}/sources"
7UNPACKDIR = "${S}"
7 8
8EXCLUDE_FROM_WORLD="1" 9EXCLUDE_FROM_WORLD="1"
9 10
diff --git a/meta-selftest/recipes-test/selftest-users/bcreategroup.bb b/meta-selftest/recipes-test/selftest-users/bcreategroup.bb
index c4844dd0da..b15c07d7b2 100644
--- a/meta-selftest/recipes-test/selftest-users/bcreategroup.bb
+++ b/meta-selftest/recipes-test/selftest-users/bcreategroup.bb
@@ -7,7 +7,8 @@ LICENSE = "MIT"
7 7
8USERADD_DEPENDS = "acreategroup ccreategroup" 8USERADD_DEPENDS = "acreategroup ccreategroup"
9 9
10S = "${WORKDIR}" 10S = "${WORKDIR}/sources"
11UNPACKDIR = "${S}"
11 12
12EXCLUDE_FROM_WORLD="1" 13EXCLUDE_FROM_WORLD="1"
13 14
diff --git a/meta-selftest/recipes-test/selftest-users/ccreategroup.bb b/meta-selftest/recipes-test/selftest-users/ccreategroup.bb
index 021b1ebbf7..ff2da1c039 100644
--- a/meta-selftest/recipes-test/selftest-users/ccreategroup.bb
+++ b/meta-selftest/recipes-test/selftest-users/ccreategroup.bb
@@ -5,7 +5,8 @@ LICENSE = "MIT"
5 5
6USERADD_DEPENDS = "acreategroup" 6USERADD_DEPENDS = "acreategroup"
7 7
8S = "${WORKDIR}" 8S = "${WORKDIR}/sources"
9UNPACKDIR = "${S}"
9 10
10EXCLUDE_FROM_WORLD="1" 11EXCLUDE_FROM_WORLD="1"
11 12
diff --git a/meta-selftest/recipes-test/selftest-users/creategroup1.bb b/meta-selftest/recipes-test/selftest-users/creategroup1.bb
index afd23ed1ee..4ab278f589 100644
--- a/meta-selftest/recipes-test/selftest-users/creategroup1.bb
+++ b/meta-selftest/recipes-test/selftest-users/creategroup1.bb
@@ -3,7 +3,8 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda
3 3
4LICENSE = "MIT" 4LICENSE = "MIT"
5 5
6S = "${WORKDIR}" 6S = "${WORKDIR}/sources"
7UNPACKDIR = "${S}"
7 8
8inherit useradd allarch 9inherit useradd allarch
9 10
diff --git a/meta-selftest/recipes-test/selftest-users/creategroup2.bb b/meta-selftest/recipes-test/selftest-users/creategroup2.bb
index f776f43aed..179aba9bfc 100644
--- a/meta-selftest/recipes-test/selftest-users/creategroup2.bb
+++ b/meta-selftest/recipes-test/selftest-users/creategroup2.bb
@@ -5,7 +5,8 @@ LICENSE = "MIT"
5 5
6USERADD_DEPENDS = "creategroup1" 6USERADD_DEPENDS = "creategroup1"
7 7
8S = "${WORKDIR}" 8S = "${WORKDIR}/sources"
9UNPACKDIR = "${S}"
9 10
10inherit useradd allarch 11inherit useradd allarch
11 12
diff --git a/meta-selftest/recipes-test/selftest-users/dcreategroup.bb b/meta-selftest/recipes-test/selftest-users/dcreategroup.bb
index b96ca92a16..ab0a529669 100644
--- a/meta-selftest/recipes-test/selftest-users/dcreategroup.bb
+++ b/meta-selftest/recipes-test/selftest-users/dcreategroup.bb
@@ -5,7 +5,8 @@ LICENSE = "MIT"
5 5
6USERADD_DEPENDS = "bcreategroup" 6USERADD_DEPENDS = "bcreategroup"
7 7
8S = "${WORKDIR}" 8S = "${WORKDIR}/sources"
9UNPACKDIR = "${S}"
9 10
10EXCLUDE_FROM_WORLD="1" 11EXCLUDE_FROM_WORLD="1"
11 12
diff --git a/meta-selftest/recipes-test/selftest-users/useraddbadtask.bb b/meta-selftest/recipes-test/selftest-users/useraddbadtask.bb
index 99e04a80b3..2863541010 100644
--- a/meta-selftest/recipes-test/selftest-users/useraddbadtask.bb
+++ b/meta-selftest/recipes-test/selftest-users/useraddbadtask.bb
@@ -5,7 +5,8 @@ LICENSE = "MIT"
5 5
6DEPENDS:append = "coreutils-native" 6DEPENDS:append = "coreutils-native"
7 7
8S = "${WORKDIR}" 8S = "${WORKDIR}/sources"
9UNPACKDIR = "${S}"
9 10
10inherit useradd allarch 11inherit useradd allarch
11 12
diff --git a/meta-selftest/recipes-test/testrpm/testrpm_0.0.1.bb b/meta-selftest/recipes-test/testrpm/testrpm_0.0.1.bb
index 5e8761ab55..db674d0efc 100644
--- a/meta-selftest/recipes-test/testrpm/testrpm_0.0.1.bb
+++ b/meta-selftest/recipes-test/testrpm/testrpm_0.0.1.bb
@@ -6,6 +6,9 @@ LICENSE = "MIT"
6SRC_URI = "file://testfile.txt" 6SRC_URI = "file://testfile.txt"
7INHIBIT_DEFAULT_DEPS = "1" 7INHIBIT_DEFAULT_DEPS = "1"
8 8
9S = "${WORKDIR}/sources"
10UNPACKDIR = "${S}"
11
9do_compile(){ 12do_compile(){
10 echo "testdata" > ${B}/"file with [brackets].txt" 13 echo "testdata" > ${B}/"file with [brackets].txt"
11 echo "testdata" > ${B}/"file with (parentheses).txt" 14 echo "testdata" > ${B}/"file with (parentheses).txt"
diff --git a/meta-selftest/recipes-test/wrapper/cmdline-shebang-wrapper-test.bb b/meta-selftest/recipes-test/wrapper/cmdline-shebang-wrapper-test.bb
index c3d3548d4a..c91d00c8d9 100644
--- a/meta-selftest/recipes-test/wrapper/cmdline-shebang-wrapper-test.bb
+++ b/meta-selftest/recipes-test/wrapper/cmdline-shebang-wrapper-test.bb
@@ -9,7 +9,7 @@ EXCLUDE_FROM_WORLD = "1"
9do_install() { 9do_install() {
10 install -d ${D}${bindir} 10 install -d ${D}${bindir}
11 # was not able to make ownership preservation check 11 # was not able to make ownership preservation check
12 install -m 0400 ${WORKDIR}/test.awk ${D}${bindir}/test 12 install -m 0400 ${UNPACKDIR}/test.awk ${D}${bindir}/test
13 13
14 perm_old="$(stat --format='%a' ${D}${bindir}/test)" 14 perm_old="$(stat --format='%a' ${D}${bindir}/test)"
15 sed -i -e 's|@AWK_BIN@|${bindir}/awk|g' ${D}${bindir}/test 15 sed -i -e 's|@AWK_BIN@|${bindir}/awk|g' ${D}${bindir}/test