summaryrefslogtreecommitdiffstats
path: root/meta-selftest/recipes-test/testrpm
diff options
context:
space:
mode:
Diffstat (limited to 'meta-selftest/recipes-test/testrpm')
-rw-r--r--meta-selftest/recipes-test/testrpm/files/testfile.txt1
-rw-r--r--meta-selftest/recipes-test/testrpm/testrpm_0.0.1.bb21
2 files changed, 22 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/testrpm/files/testfile.txt b/meta-selftest/recipes-test/testrpm/files/testfile.txt
new file mode 100644
index 0000000000..c4d7630c1e
--- /dev/null
+++ b/meta-selftest/recipes-test/testrpm/files/testfile.txt
@@ -0,0 +1 @@
== This file serves the purposes of SRC_URI only
diff --git a/meta-selftest/recipes-test/testrpm/testrpm_0.0.1.bb b/meta-selftest/recipes-test/testrpm/testrpm_0.0.1.bb
new file mode 100644
index 0000000000..db674d0efc
--- /dev/null
+++ b/meta-selftest/recipes-test/testrpm/testrpm_0.0.1.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Test recipe for testing rpm generated by oe-core"
2LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
3
4LICENSE = "MIT"
5
6SRC_URI = "file://testfile.txt"
7INHIBIT_DEFAULT_DEPS = "1"
8
9S = "${WORKDIR}/sources"
10UNPACKDIR = "${S}"
11
12do_compile(){
13 echo "testdata" > ${B}/"file with [brackets].txt"
14 echo "testdata" > ${B}/"file with (parentheses).txt"
15}
16
17do_install(){
18 install ${B}/* ${D}/
19}
20
21FILES:${PN} = "*"