summaryrefslogtreecommitdiffstats
path: root/meta-selftest/recipes-test/selftest-hello
diff options
context:
space:
mode:
Diffstat (limited to 'meta-selftest/recipes-test/selftest-hello')
-rw-r--r--meta-selftest/recipes-test/selftest-hello/files/helloworld.c8
-rw-r--r--meta-selftest/recipes-test/selftest-hello/selftest-hello_1.0.bb20
2 files changed, 28 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/selftest-hello/files/helloworld.c b/meta-selftest/recipes-test/selftest-hello/files/helloworld.c
new file mode 100644
index 0000000000..fc7169b7b8
--- /dev/null
+++ b/meta-selftest/recipes-test/selftest-hello/files/helloworld.c
@@ -0,0 +1,8 @@
1#include <stdio.h>
2
3int main(void)
4{
5 printf("Hello world!\n");
6
7 return 0;
8}
diff --git a/meta-selftest/recipes-test/selftest-hello/selftest-hello_1.0.bb b/meta-selftest/recipes-test/selftest-hello/selftest-hello_1.0.bb
new file mode 100644
index 0000000000..2dc352d479
--- /dev/null
+++ b/meta-selftest/recipes-test/selftest-hello/selftest-hello_1.0.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "Simple helloworld application -- selftest variant"
2SECTION = "examples"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
5
6SRC_URI = "file://helloworld.c"
7
8S = "${WORKDIR}/sources"
9UNPACKDIR = "${S}"
10
11do_compile() {
12 ${CC} ${CFLAGS} ${LDFLAGS} helloworld.c -o helloworld
13}
14
15do_install() {
16 install -d ${D}${bindir}
17 install -m 0755 helloworld ${D}${bindir}
18}
19
20BBCLASSEXTEND = "native nativesdk"