summaryrefslogtreecommitdiffstats
path: root/meta-selftest/recipes-test/logging-test/logging-test.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-selftest/recipes-test/logging-test/logging-test.bb')
-rw-r--r--meta-selftest/recipes-test/logging-test/logging-test.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/logging-test/logging-test.bb b/meta-selftest/recipes-test/logging-test/logging-test.bb
new file mode 100644
index 0000000000..ac3fb46f45
--- /dev/null
+++ b/meta-selftest/recipes-test/logging-test/logging-test.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Destined to fail"
2LICENSE = "CLOSED"
3
4deltask do_patch
5INHIBIT_DEFAULT_DEPS = "1"
6
7do_shelltest() {
8 echo "This is shell stdout"
9 echo "This is shell stderr" >&2
10 exit 1
11}
12addtask do_shelltest
13
14python do_pythontest_exec_func_shell() {
15 bb.build.exec_func('do_shelltest', d)
16}
17addtask do_pythontest_exec_func_shell
18
19python do_pythontest_exit () {
20 print("This is python stdout")
21 sys.exit(1)
22}
23addtask do_pythontest_exit
24
25python do_pythontest_exec_func_python() {
26 bb.build.exec_func('do_pythontest_exit', d)
27}
28addtask do_pythontest_exec_func_python
29
30python do_pythontest_fatal () {
31 print("This is python fatal test stdout")
32 bb.fatal("This is a fatal error")
33}
34addtask do_pythontest_fatal