summaryrefslogtreecommitdiffstats
path: root/meta-selftest/recipes-extended/sysdig/sysdig-selftest_0.28.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-selftest/recipes-extended/sysdig/sysdig-selftest_0.28.0.bb')
-rw-r--r--meta-selftest/recipes-extended/sysdig/sysdig-selftest_0.28.0.bb66
1 files changed, 66 insertions, 0 deletions
diff --git a/meta-selftest/recipes-extended/sysdig/sysdig-selftest_0.28.0.bb b/meta-selftest/recipes-extended/sysdig/sysdig-selftest_0.28.0.bb
new file mode 100644
index 0000000000..2ce85fe451
--- /dev/null
+++ b/meta-selftest/recipes-extended/sysdig/sysdig-selftest_0.28.0.bb
@@ -0,0 +1,66 @@
1SUMMARY = "A New System Troubleshooting Tool Built for the Way You Work"
2DESCRIPTION = "Sysdig is open source, system-level exploration: capture \
3system state and activity from a running Linux instance, then save, \
4filter and analyze."
5HOMEPAGE = "http://www.sysdig.org/"
6LICENSE = "Apache-2.0 & (MIT | GPL-2.0-only)"
7LIC_FILES_CHKSUM = "file://COPYING;md5=f8fee3d59797546cffab04f3b88b2d44"
8
9inherit cmake pkgconfig
10
11#OECMAKE_GENERATOR = "Unix Makefiles"
12JIT ?= "jit"
13JIT:mipsarchn32 = ""
14JIT:mipsarchn64 = ""
15JIT:riscv64 = ""
16JIT:riscv32 = ""
17JIT:powerpc = ""
18JIT:powerpc64le = ""
19JIT:powerpc64 = ""
20
21#DEPENDS += "libb64 lua${JIT} zlib c-ares grpc-native grpc curl ncurses jsoncpp \
22# tbb jq openssl elfutils protobuf protobuf-native jq-native valijson"
23RDEPENDS:${PN} = "bash"
24
25SRC_URI = "git://github.com/draios/sysdig.git;branch=dev;protocol=https;name=sysdig \
26 git://github.com/falcosecurity/libs;protocol=https;branch=master;name=falco;subdir=git/falcosecurity-libs \
27 file://0055-Add-cstdint-for-uintXX_t-types.patch;patchdir=./falcosecurity-libs \
28 file://0099-cmake-Pass-PROBE_NAME-via-CFLAGS.patch \
29 "
30SRCREV_sysdig = "4fb6288275f567f63515df0ff0a6518043ecfa9b"
31SRCREV_falco= "caa0e4d0044fdaaebab086592a97f0c7f32aeaa9"
32
33SRCREV_FORMAT = "sysdig_falco"
34
35S = "${WORKDIR}/git"
36
37EXTRA_OECMAKE = "\
38 -DBUILD_DRIVER=OFF \
39 -DMINIMAL_BUILD=ON \
40 -DUSE_BUNDLED_DEPS=OFF \
41 -DCREATE_TEST_TARGETS=OFF \
42 -DDIR_ETC=${sysconfdir} \
43 -DLUA_INCLUDE_DIR=${STAGING_INCDIR}/luajit-2.1 \
44 -DFALCOSECURITY_LIBS_SOURCE_DIR=${S}/falcosecurity-libs \
45 -DVALIJSON_INCLUDE=${STAGING_INCDIR}/valijson \
46"
47
48#CMAKE_VERBOSE = "VERBOSE=1"
49
50FILES:${PN} += " \
51 ${DIR_ETC}/* \
52 ${datadir}/zsh/* \
53 ${prefix}/src/* \
54"
55# Use getaddrinfo_a is a GNU extension in libsinsp
56# It should be fixed in sysdig, until then disable
57# on musl
58# Something like this https://code.videolan.org/ePirat/vlc/-/commit/01fd9fe4c7f6c5558f7345f38abf0152e17853ab is needed to fix it
59COMPATIBLE_HOST:libc-musl = "null"
60COMPATIBLE_HOST:mips = "null"
61COMPATIBLE_HOST:riscv64 = "null"
62COMPATIBLE_HOST:riscv32 = "null"
63COMPATIBLE_HOST:powerpc = "null"
64COMPATIBLE_HOST:powerpc64le = "null"
65
66EXCLUDE_FROM_WORLD = "1"