summaryrefslogtreecommitdiffstats
path: root/meta-selftest/recipes-extended/sysdig/sysdig-selftest
diff options
context:
space:
mode:
Diffstat (limited to 'meta-selftest/recipes-extended/sysdig/sysdig-selftest')
-rw-r--r--meta-selftest/recipes-extended/sysdig/sysdig-selftest/0055-Add-cstdint-for-uintXX_t-types.patch38
-rw-r--r--meta-selftest/recipes-extended/sysdig/sysdig-selftest/0099-cmake-Pass-PROBE_NAME-via-CFLAGS.patch29
2 files changed, 67 insertions, 0 deletions
diff --git a/meta-selftest/recipes-extended/sysdig/sysdig-selftest/0055-Add-cstdint-for-uintXX_t-types.patch b/meta-selftest/recipes-extended/sysdig/sysdig-selftest/0055-Add-cstdint-for-uintXX_t-types.patch
new file mode 100644
index 0000000000..e564958dad
--- /dev/null
+++ b/meta-selftest/recipes-extended/sysdig/sysdig-selftest/0055-Add-cstdint-for-uintXX_t-types.patch
@@ -0,0 +1,38 @@
1From 3d076ea588eb3c7f334133b4c31172a14beadf5b Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 2 Feb 2023 20:18:27 -0800
4Subject: [PATCH] Add <cstdint> for uintXX_t types
5
6gcc 13 moved some includes around and as a result <cstdint> is no
7longer transitively included [1]. Explicitly include it
8for uintXX_t.
9
10[1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
11
12Upstream-Status: Submitted [https://github.com/falcosecurity/libs/pull/862]
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 userspace/libsinsp/filter/parser.h | 1 +
16 userspace/libsinsp/filter_value.h | 1 +
17 2 files changed, 2 insertions(+)
18
19--- a/userspace/libsinsp/filter/parser.h
20+++ b/userspace/libsinsp/filter/parser.h
21@@ -18,6 +18,7 @@ limitations under the License.
22 #pragma once
23
24 #include "ast.h"
25+#include <cstdint>
26
27 //
28 // Context-free Grammar for Sinsp Filters
29--- a/userspace/libsinsp/filter_value.h
30+++ b/userspace/libsinsp/filter_value.h
31@@ -18,6 +18,7 @@ limitations under the License.
32 #pragma once
33
34 #include <string.h>
35+#include <cstdint>
36 #include <utility>
37
38 // Used for CO_IN/CO_PMATCH filterchecks using PT_CHARBUFs to allow
diff --git a/meta-selftest/recipes-extended/sysdig/sysdig-selftest/0099-cmake-Pass-PROBE_NAME-via-CFLAGS.patch b/meta-selftest/recipes-extended/sysdig/sysdig-selftest/0099-cmake-Pass-PROBE_NAME-via-CFLAGS.patch
new file mode 100644
index 0000000000..903ccdf36a
--- /dev/null
+++ b/meta-selftest/recipes-extended/sysdig/sysdig-selftest/0099-cmake-Pass-PROBE_NAME-via-CFLAGS.patch
@@ -0,0 +1,29 @@
1From ed8969a233adb6bf701de96d0fd0570e5ddcc787 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 21 Mar 2022 19:35:48 -0700
4Subject: [PATCH] cmake: Pass PROBE_NAME via CFLAGS
5
6This helps compliation of driver code where its calling modprobe on the
7given kernel module via system() API
8
9Upstream-Status: Pending
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 CMakeLists.txt | 1 +
13 1 file changed, 1 insertion(+)
14
15diff --git a/CMakeLists.txt b/CMakeLists.txt
16index 7dceb7ae..e156c36f 100644
17--- a/CMakeLists.txt
18+++ b/CMakeLists.txt
19@@ -149,6 +149,7 @@ if(CMAKE_SYSTEM_NAME MATCHES "Linux")
20 if(NOT DEFINED PROBE_NAME)
21 set(PROBE_NAME "scap")
22 endif()
23+ add_definitions(-DPROBE_NAME="${PROBE_NAME}")
24
25 set(DRIVERS_REPO "https://download.sysdig.com/scap-drivers")
26
27--
282.35.1
29