summaryrefslogtreecommitdiffstats
path: root/meta-selftest/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-selftest/recipes-devtools')
-rw-r--r--meta-selftest/recipes-devtools/mtd/mtd-utils-selftest/0001-tests-Remove-unused-linux-fs.h-header-from-includes.patch31
-rw-r--r--meta-selftest/recipes-devtools/mtd/mtd-utils-selftest_git.bb77
-rw-r--r--meta-selftest/recipes-devtools/python/python-async-test.inc4
-rw-r--r--meta-selftest/recipes-devtools/rust/rust-c-lib-example-bin_git.bb16
-rw-r--r--meta-selftest/recipes-devtools/rust/rust-c-lib-example-crates.inc79
-rw-r--r--meta-selftest/recipes-devtools/rust/rust-c-lib-example_git.bb15
6 files changed, 220 insertions, 2 deletions
diff --git a/meta-selftest/recipes-devtools/mtd/mtd-utils-selftest/0001-tests-Remove-unused-linux-fs.h-header-from-includes.patch b/meta-selftest/recipes-devtools/mtd/mtd-utils-selftest/0001-tests-Remove-unused-linux-fs.h-header-from-includes.patch
new file mode 100644
index 0000000000..73d4a8475f
--- /dev/null
+++ b/meta-selftest/recipes-devtools/mtd/mtd-utils-selftest/0001-tests-Remove-unused-linux-fs.h-header-from-includes.patch
@@ -0,0 +1,31 @@
1From 6fb10bd18488ed84776675bc1b2982800a51d839 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 6 Aug 2022 20:14:38 -0700
4Subject: [mtd-utils][PATCH] tests: Remove unused linux/fs.h header from includes
5
6This header is not needed, moreover it includes linux/mount.h which is
7now in conflict[1] with glibc provided sys/mount.h from glibc 2.36 onwards
8
9[1] https://sourceware.org/glibc/wiki/Release/2.36
10
11Upstream-Status: Submitted [https://lists.infradead.org/pipermail/linux-mtd/2022-August/094667.html]
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 tests/fs-tests/lib/tests.c | 1 -
15 1 file changed, 1 deletion(-)
16
17diff --git a/tests/fs-tests/lib/tests.c b/tests/fs-tests/lib/tests.c
18index d1a2e0c..3db0426 100644
19--- a/tests/fs-tests/lib/tests.c
20+++ b/tests/fs-tests/lib/tests.c
21@@ -35,7 +35,6 @@
22 #include <sys/vfs.h>
23 #include <sys/mount.h>
24 #include <sys/statvfs.h>
25-#include <linux/fs.h>
26 #include <linux/jffs2.h>
27
28 #include "tests.h"
29--
302.37.1
31
diff --git a/meta-selftest/recipes-devtools/mtd/mtd-utils-selftest_git.bb b/meta-selftest/recipes-devtools/mtd/mtd-utils-selftest_git.bb
new file mode 100644
index 0000000000..ca2141c972
--- /dev/null
+++ b/meta-selftest/recipes-devtools/mtd/mtd-utils-selftest_git.bb
@@ -0,0 +1,77 @@
1SUMMARY = "Tools for managing memory technology devices"
2HOMEPAGE = "http://www.linux-mtd.infradead.org/"
3DESCRIPTION = "mtd-utils tool is a generic Linux subsystem for memory devices, especially Flash devices."
4SECTION = "base"
5LICENSE = "GPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
7 file://include/common.h;beginline=1;endline=17;md5=ba05b07912a44ea2bf81ce409380049c"
8
9inherit autotools pkgconfig update-alternatives
10
11DEPENDS = "zlib e2fsprogs util-linux"
12RDEPENDS:mtd-utils-tests += "bash"
13
14PV = "2.1.4"
15
16SRCREV = "c7f1bfa44a84d02061787e2f6093df5cc40b9f5c"
17SRC_URI = "git://git.infradead.org/mtd-utils.git;branch=master \
18 file://0001-tests-Remove-unused-linux-fs.h-header-from-includes.patch \
19 "
20
21S = "${WORKDIR}/git"
22
23# xattr support creates an additional compile-time dependency on acl because
24# the sys/acl.h header is needed. libacl is not needed and thus enabling xattr
25# regardless whether acl is enabled or disabled in the distro should be okay.
26PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'xattr', d)} lzo jffs ubifs"
27PACKAGECONFIG[lzo] = "--with-lzo,--without-lzo,lzo"
28PACKAGECONFIG[xattr] = "--with-xattr,--without-xattr,acl"
29PACKAGECONFIG[crypto] = "--with-crypto,--without-crypto,openssl"
30PACKAGECONFIG[jffs] = "--with-jffs,--without-jffs"
31PACKAGECONFIG[ubifs] = "--with-ubifs,--without-ubifs"
32PACKAGECONFIG[zstd] = "--with-zstd,--without-zstd,zstd"
33
34CPPFLAGS:append:riscv64 = " -pthread -D_REENTRANT"
35
36EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} ${@bb.utils.contains('PACKAGECONFIG', 'xattr', '', '-DWITHOUT_XATTR', d)} -I${S}/include' 'BUILDDIR=${S}'"
37
38# Use higher priority than corresponding BusyBox-provided applets
39ALTERNATIVE_PRIORITY = "100"
40
41ALTERNATIVE:${PN} = "flashcp flash_eraseall flash_lock flash_unlock nanddump nandwrite"
42ALTERNATIVE:${PN}-ubifs = "ubiattach ubidetach ubimkvol ubirename ubirmvol ubirsvol ubiupdatevol"
43
44ALTERNATIVE_LINK_NAME[nandwrite] = "${sbindir}/nandwrite"
45ALTERNATIVE_LINK_NAME[nanddump] = "${sbindir}/nanddump"
46ALTERNATIVE_LINK_NAME[ubiattach] = "${sbindir}/ubiattach"
47ALTERNATIVE_LINK_NAME[ubidetach] = "${sbindir}/ubidetach"
48ALTERNATIVE_LINK_NAME[ubimkvol] = "${sbindir}/ubimkvol"
49ALTERNATIVE_LINK_NAME[ubirename] = "${sbindir}/ubirename"
50ALTERNATIVE_LINK_NAME[ubirmvol] = "${sbindir}/ubirmvol"
51ALTERNATIVE_LINK_NAME[ubirsvol] = "${sbindir}/ubirsvol"
52ALTERNATIVE_LINK_NAME[ubiupdatevol] = "${sbindir}/ubiupdatevol"
53ALTERNATIVE_LINK_NAME[flash_eraseall] = "${sbindir}/flash_eraseall"
54ALTERNATIVE_LINK_NAME[flash_lock] = "${sbindir}/flash_lock"
55ALTERNATIVE_LINK_NAME[flash_unlock] = "${sbindir}/flash_unlock"
56ALTERNATIVE_LINK_NAME[flashcp] = "${sbindir}/flashcp"
57
58do_install () {
59 oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} INCLUDEDIR=${includedir}
60}
61
62PACKAGES =+ "mtd-utils-misc mtd-utils-tests"
63PACKAGES =+ "${@bb.utils.contains("PACKAGECONFIG", "jffs", "mtd-utils-jffs2", "", d)}"
64PACKAGES =+ "${@bb.utils.contains("PACKAGECONFIG", "ubifs", "mtd-utils-ubifs", "", d)}"
65
66FILES:mtd-utils-jffs2 = "${sbindir}/mkfs.jffs2 ${sbindir}/jffs2dump ${sbindir}/jffs2reader ${sbindir}/sumtool"
67FILES:mtd-utils-ubifs = "${sbindir}/mkfs.ubifs ${sbindir}/ubi*"
68FILES:mtd-utils-misc = "${sbindir}/nftl* ${sbindir}/ftl* ${sbindir}/rfd* ${sbindir}/doc* ${sbindir}/serve_image ${sbindir}/recv_image"
69FILES:mtd-utils-tests = "${libexecdir}/mtd-utils/*"
70
71BBCLASSEXTEND = "native nativesdk"
72
73# git/.compr.c.dep:46: warning: NUL character seen; rest of line ignored
74# git/.compr.c.dep:47: *** missing separator. Stop.
75PARALLEL_MAKE = ""
76
77EXCLUDE_FROM_WORLD = "1"
diff --git a/meta-selftest/recipes-devtools/python/python-async-test.inc b/meta-selftest/recipes-devtools/python/python-async-test.inc
index c9602e8e52..a7dd1744f2 100644
--- a/meta-selftest/recipes-devtools/python/python-async-test.inc
+++ b/meta-selftest/recipes-devtools/python/python-async-test.inc
@@ -1,7 +1,7 @@
1SUMMARY = "Python framework to process interdependent tasks in a pool of workers" 1SUMMARY = "Python framework to process interdependent tasks in a pool of workers"
2HOMEPAGE = "http://github.com/gitpython-developers/async" 2HOMEPAGE = "http://github.com/gitpython-developers/async"
3SECTION = "devel/python" 3SECTION = "devel/python"
4LICENSE = "BSD" 4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=88df8e78b9edfd744953862179f2d14e" 5LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=88df8e78b9edfd744953862179f2d14e"
6 6
7inherit pypi 7inherit pypi
@@ -11,6 +11,6 @@ PYPI_PACKAGE = "async"
11SRC_URI[md5sum] = "9b06b5997de2154f3bc0273f80bcef6b" 11SRC_URI[md5sum] = "9b06b5997de2154f3bc0273f80bcef6b"
12SRC_URI[sha256sum] = "ac6894d876e45878faae493b0cf61d0e28ec417334448ac0a6ea2229d8343051" 12SRC_URI[sha256sum] = "ac6894d876e45878faae493b0cf61d0e28ec417334448ac0a6ea2229d8343051"
13 13
14RDEPENDS_${PN} += "${PYTHON_PN}-threading" 14RDEPENDS:${PN} += "python3-threading"
15 15
16BBCLASSEXTEND = "nativesdk" 16BBCLASSEXTEND = "nativesdk"
diff --git a/meta-selftest/recipes-devtools/rust/rust-c-lib-example-bin_git.bb b/meta-selftest/recipes-devtools/rust/rust-c-lib-example-bin_git.bb
new file mode 100644
index 0000000000..47d878597a
--- /dev/null
+++ b/meta-selftest/recipes-devtools/rust/rust-c-lib-example-bin_git.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "A simple example for C wrapper around a rust library"
2HOMEPAGE = "https://gitlab.com/fmartinsonsHome/rust-c-lib-example"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=cb9c441273ed8a029701a086befbfc63"
5
6SRC_URI = " \
7 git://gitlab.com/fmartinsonsHome/rust-c-lib-example.git;branch=main;protocol=https \
8"
9
10SRCREV = "fc53c457f69aa5221ec1f8619a007e8150db5e60"
11S = "${WORKDIR}/git"
12
13DEPENDS = "rust-c-lib-example"
14
15inherit meson pkgconfig
16
diff --git a/meta-selftest/recipes-devtools/rust/rust-c-lib-example-crates.inc b/meta-selftest/recipes-devtools/rust/rust-c-lib-example-crates.inc
new file mode 100644
index 0000000000..05f5949203
--- /dev/null
+++ b/meta-selftest/recipes-devtools/rust/rust-c-lib-example-crates.inc
@@ -0,0 +1,79 @@
1SRC_URI += " \
2 crate://crates.io/android-tzdata/0.1.1 \
3 crate://crates.io/android_system_properties/0.1.5 \
4 crate://crates.io/autocfg/1.1.0 \
5 crate://crates.io/bumpalo/3.13.0 \
6 crate://crates.io/cc/1.0.82 \
7 crate://crates.io/cfg-if/1.0.0 \
8 crate://crates.io/chrono/0.4.26 \
9 crate://crates.io/core-foundation-sys/0.8.4 \
10 crate://crates.io/iana-time-zone/0.1.57 \
11 crate://crates.io/iana-time-zone-haiku/0.1.2 \
12 crate://crates.io/js-sys/0.3.64 \
13 crate://crates.io/libc/0.2.147 \
14 crate://crates.io/log/0.4.19 \
15 crate://crates.io/num-traits/0.2.16 \
16 crate://crates.io/once_cell/1.18.0 \
17 crate://crates.io/proc-macro2/1.0.66 \
18 crate://crates.io/quote/1.0.32 \
19 crate://crates.io/syn/2.0.28 \
20 crate://crates.io/time/0.1.45 \
21 crate://crates.io/unicode-ident/1.0.11 \
22 crate://crates.io/wasi/0.10.0+wasi-snapshot-preview1 \
23 crate://crates.io/wasm-bindgen/0.2.87 \
24 crate://crates.io/wasm-bindgen-backend/0.2.87 \
25 crate://crates.io/wasm-bindgen-macro/0.2.87 \
26 crate://crates.io/wasm-bindgen-macro-support/0.2.87 \
27 crate://crates.io/wasm-bindgen-shared/0.2.87 \
28 crate://crates.io/winapi/0.3.9 \
29 crate://crates.io/winapi-i686-pc-windows-gnu/0.4.0 \
30 crate://crates.io/winapi-x86_64-pc-windows-gnu/0.4.0 \
31 crate://crates.io/windows/0.48.0 \
32 crate://crates.io/windows-targets/0.48.1 \
33 crate://crates.io/windows_aarch64_gnullvm/0.48.0 \
34 crate://crates.io/windows_aarch64_msvc/0.48.0 \
35 crate://crates.io/windows_i686_gnu/0.48.0 \
36 crate://crates.io/windows_i686_msvc/0.48.0 \
37 crate://crates.io/windows_x86_64_gnu/0.48.0 \
38 crate://crates.io/windows_x86_64_gnullvm/0.48.0 \
39 crate://crates.io/windows_x86_64_msvc/0.48.0 \
40"
41
42SRC_URI[android-tzdata-0.1.1.sha256sum] = "e999941b234f3131b00bc13c22d06e8c5ff726d1b6318ac7eb276997bbb4fef0"
43SRC_URI[android_system_properties-0.1.5.sha256sum] = "819e7219dbd41043ac279b19830f2efc897156490d7fd6ea916720117ee66311"
44SRC_URI[autocfg-1.1.0.sha256sum] = "d468802bab17cbc0cc575e9b053f41e72aa36bfa6b7f55e3529ffa43161b97fa"
45SRC_URI[bumpalo-3.13.0.sha256sum] = "a3e2c3daef883ecc1b5d58c15adae93470a91d425f3532ba1695849656af3fc1"
46SRC_URI[cc-1.0.82.sha256sum] = "305fe645edc1442a0fa8b6726ba61d422798d37a52e12eaecf4b022ebbb88f01"
47SRC_URI[cfg-if-1.0.0.sha256sum] = "baf1de4339761588bc0619e3cbc0120ee582ebb74b53b4efbf79117bd2da40fd"
48SRC_URI[chrono-0.4.26.sha256sum] = "ec837a71355b28f6556dbd569b37b3f363091c0bd4b2e735674521b4c5fd9bc5"
49SRC_URI[core-foundation-sys-0.8.4.sha256sum] = "e496a50fda8aacccc86d7529e2c1e0892dbd0f898a6b5645b5561b89c3210efa"
50SRC_URI[iana-time-zone-0.1.57.sha256sum] = "2fad5b825842d2b38bd206f3e81d6957625fd7f0a361e345c30e01a0ae2dd613"
51SRC_URI[iana-time-zone-haiku-0.1.2.sha256sum] = "f31827a206f56af32e590ba56d5d2d085f558508192593743f16b2306495269f"
52SRC_URI[js-sys-0.3.64.sha256sum] = "c5f195fe497f702db0f318b07fdd68edb16955aed830df8363d837542f8f935a"
53SRC_URI[libc-0.2.147.sha256sum] = "b4668fb0ea861c1df094127ac5f1da3409a82116a4ba74fca2e58ef927159bb3"
54SRC_URI[log-0.4.19.sha256sum] = "b06a4cde4c0f271a446782e3eff8de789548ce57dbc8eca9292c27f4a42004b4"
55SRC_URI[num-traits-0.2.16.sha256sum] = "f30b0abd723be7e2ffca1272140fac1a2f084c77ec3e123c192b66af1ee9e6c2"
56SRC_URI[once_cell-1.18.0.sha256sum] = "dd8b5dd2ae5ed71462c540258bedcb51965123ad7e7ccf4b9a8cafaa4a63576d"
57SRC_URI[proc-macro2-1.0.66.sha256sum] = "18fb31db3f9bddb2ea821cde30a9f70117e3f119938b5ee630b7403aa6e2ead9"
58SRC_URI[quote-1.0.32.sha256sum] = "50f3b39ccfb720540debaa0164757101c08ecb8d326b15358ce76a62c7e85965"
59SRC_URI[syn-2.0.28.sha256sum] = "04361975b3f5e348b2189d8dc55bc942f278b2d482a6a0365de5bdd62d351567"
60SRC_URI[time-0.1.45.sha256sum] = "1b797afad3f312d1c66a56d11d0316f916356d11bd158fbc6ca6389ff6bf805a"
61SRC_URI[unicode-ident-1.0.11.sha256sum] = "301abaae475aa91687eb82514b328ab47a211a533026cb25fc3e519b86adfc3c"
62SRC_URI[wasi-0.10.0+wasi-snapshot-preview1.sha256sum] = "1a143597ca7c7793eff794def352d41792a93c481eb1042423ff7ff72ba2c31f"
63SRC_URI[wasm-bindgen-0.2.87.sha256sum] = "7706a72ab36d8cb1f80ffbf0e071533974a60d0a308d01a5d0375bf60499a342"
64SRC_URI[wasm-bindgen-backend-0.2.87.sha256sum] = "5ef2b6d3c510e9625e5fe6f509ab07d66a760f0885d858736483c32ed7809abd"
65SRC_URI[wasm-bindgen-macro-0.2.87.sha256sum] = "dee495e55982a3bd48105a7b947fd2a9b4a8ae3010041b9e0faab3f9cd028f1d"
66SRC_URI[wasm-bindgen-macro-support-0.2.87.sha256sum] = "54681b18a46765f095758388f2d0cf16eb8d4169b639ab575a8f5693af210c7b"
67SRC_URI[wasm-bindgen-shared-0.2.87.sha256sum] = "ca6ad05a4870b2bf5fe995117d3728437bd27d7cd5f06f13c17443ef369775a1"
68SRC_URI[winapi-0.3.9.sha256sum] = "5c839a674fcd7a98952e593242ea400abe93992746761e38641405d28b00f419"
69SRC_URI[winapi-i686-pc-windows-gnu-0.4.0.sha256sum] = "ac3b87c63620426dd9b991e5ce0329eff545bccbbb34f3be09ff6fb6ab51b7b6"
70SRC_URI[winapi-x86_64-pc-windows-gnu-0.4.0.sha256sum] = "712e227841d057c1ee1cd2fb22fa7e5a5461ae8e48fa2ca79ec42cfc1931183f"
71SRC_URI[windows-0.48.0.sha256sum] = "e686886bc078bc1b0b600cac0147aadb815089b6e4da64016cbd754b6342700f"
72SRC_URI[windows-targets-0.48.1.sha256sum] = "05d4b17490f70499f20b9e791dcf6a299785ce8af4d709018206dc5b4953e95f"
73SRC_URI[windows_aarch64_gnullvm-0.48.0.sha256sum] = "91ae572e1b79dba883e0d315474df7305d12f569b400fcf90581b06062f7e1bc"
74SRC_URI[windows_aarch64_msvc-0.48.0.sha256sum] = "b2ef27e0d7bdfcfc7b868b317c1d32c641a6fe4629c171b8928c7b08d98d7cf3"
75SRC_URI[windows_i686_gnu-0.48.0.sha256sum] = "622a1962a7db830d6fd0a69683c80a18fda201879f0f447f065a3b7467daa241"
76SRC_URI[windows_i686_msvc-0.48.0.sha256sum] = "4542c6e364ce21bf45d69fdd2a8e455fa38d316158cfd43b3ac1c5b1b19f8e00"
77SRC_URI[windows_x86_64_gnu-0.48.0.sha256sum] = "ca2b8a661f7628cbd23440e50b05d705db3686f894fc9580820623656af974b1"
78SRC_URI[windows_x86_64_gnullvm-0.48.0.sha256sum] = "7896dbc1f41e08872e9d5e8f8baa8fdd2677f29468c4e156210174edc7f7b953"
79SRC_URI[windows_x86_64_msvc-0.48.0.sha256sum] = "1a515f5799fe4961cb532f983ce2b23082366b898e52ffbce459c86f67c8378a"
diff --git a/meta-selftest/recipes-devtools/rust/rust-c-lib-example_git.bb b/meta-selftest/recipes-devtools/rust/rust-c-lib-example_git.bb
new file mode 100644
index 0000000000..6e7c250b92
--- /dev/null
+++ b/meta-selftest/recipes-devtools/rust/rust-c-lib-example_git.bb
@@ -0,0 +1,15 @@
1DESCRIPTION = "A simple example for rust C library"
2HOMEPAGE = "https://gitlab.com/fmartinsonsHome/rust-c-lib-example"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=cb9c441273ed8a029701a086befbfc63"
5
6SRC_URI = " \
7 git://gitlab.com/fmartinsonsHome/rust-c-lib-example.git;branch=main;protocol=https \
8"
9
10SRCREV = "fc53c457f69aa5221ec1f8619a007e8150db5e60"
11S = "${WORKDIR}/git"
12
13inherit cargo_c
14
15require ${BPN}-crates.inc