summaryrefslogtreecommitdiffstats
path: root/meta-poky/conf/templates
diff options
context:
space:
mode:
Diffstat (limited to 'meta-poky/conf/templates')
-rw-r--r--meta-poky/conf/templates/default/bblayers.conf.sample12
-rw-r--r--meta-poky/conf/templates/default/conf-notes.txt19
-rw-r--r--meta-poky/conf/templates/default/conf-summary.txt1
-rw-r--r--meta-poky/conf/templates/default/local.conf.sample288
-rw-r--r--meta-poky/conf/templates/default/local.conf.sample.extended388
-rw-r--r--meta-poky/conf/templates/default/site.conf.sample33
6 files changed, 741 insertions, 0 deletions
diff --git a/meta-poky/conf/templates/default/bblayers.conf.sample b/meta-poky/conf/templates/default/bblayers.conf.sample
new file mode 100644
index 0000000000..8b1cbdfc5c
--- /dev/null
+++ b/meta-poky/conf/templates/default/bblayers.conf.sample
@@ -0,0 +1,12 @@
1# POKY_BBLAYERS_CONF_VERSION is increased each time build/conf/bblayers.conf
2# changes incompatibly
3POKY_BBLAYERS_CONF_VERSION = "2"
4
5BBPATH = "${TOPDIR}"
6BBFILES ?= ""
7
8BBLAYERS ?= " \
9 ##OEROOT##/meta \
10 ##OEROOT##/meta-poky \
11 ##OEROOT##/meta-yocto-bsp \
12 "
diff --git a/meta-poky/conf/templates/default/conf-notes.txt b/meta-poky/conf/templates/default/conf-notes.txt
new file mode 100644
index 0000000000..cfd1f1977b
--- /dev/null
+++ b/meta-poky/conf/templates/default/conf-notes.txt
@@ -0,0 +1,19 @@
1
2### Shell environment set up for builds. ###
3
4You can now run 'bitbake <target>'
5
6Common targets are:
7 core-image-minimal
8 core-image-full-cmdline
9 core-image-sato
10 core-image-weston
11 meta-toolchain
12 meta-ide-support
13
14You can also run generated qemu images with a command like 'runqemu qemux86-64'.
15
16Other commonly useful commands are:
17 - 'devtool' and 'recipetool' handle common recipe tasks
18 - 'bitbake-layers' handles common layer tasks
19 - 'oe-pkgdata-util' handles common target package tasks
diff --git a/meta-poky/conf/templates/default/conf-summary.txt b/meta-poky/conf/templates/default/conf-summary.txt
new file mode 100644
index 0000000000..8fc03030c7
--- /dev/null
+++ b/meta-poky/conf/templates/default/conf-summary.txt
@@ -0,0 +1 @@
This is the default build configuration for the Poky reference distribution.
diff --git a/meta-poky/conf/templates/default/local.conf.sample b/meta-poky/conf/templates/default/local.conf.sample
new file mode 100644
index 0000000000..72d3566294
--- /dev/null
+++ b/meta-poky/conf/templates/default/local.conf.sample
@@ -0,0 +1,288 @@
1#
2# This file is your local configuration file and is where all local user settings
3# are placed. The comments in this file give some guide to the options a new user
4# to the system might want to change but pretty much any configuration option can
5# be set in this file. More adventurous users can look at
6# local.conf.sample.extended which contains other examples of configuration which
7# can be placed in this file but new users likely won't need any of them
8# initially. There's also site.conf.sample which contains examples of site specific
9# information such as proxy server addresses.
10#
11# Lines starting with the '#' character are commented out and in some cases the
12# default values are provided as comments to show people example syntax. Enabling
13# the option is a question of removing the # character and making any change to the
14# variable as required.
15
16#
17# Machine Selection
18#
19# You need to select a specific machine to target the build with. There are a selection
20# of emulated machines available which can boot and run in the QEMU emulator:
21#
22#MACHINE ?= "qemuarm"
23#MACHINE ?= "qemuarm64"
24#MACHINE ?= "qemumips"
25#MACHINE ?= "qemumips64"
26#MACHINE ?= "qemuppc"
27#MACHINE ?= "qemux86"
28#MACHINE ?= "qemux86-64"
29#
30# There are also the following hardware board target machines included for
31# demonstration purposes:
32#
33#MACHINE ?= "beaglebone-yocto"
34#MACHINE ?= "genericarm64"
35#MACHINE ?= "genericx86"
36#MACHINE ?= "genericx86-64"
37#
38# This sets the default machine to be qemux86-64 if no other machine is selected:
39MACHINE ??= "qemux86-64"
40
41# These are some of the more commonly used values. Looking at the files in the
42# meta/conf/machine directory, or the conf/machine directory of any additional layers
43# you add in will show all the available machines.
44
45#
46# Where to place downloads
47#
48# During a first build the system will download many different source code tarballs
49# from various upstream projects. This can take a while, particularly if your network
50# connection is slow. These are all stored in DL_DIR. When wiping and rebuilding you
51# can preserve this directory to speed up this part of subsequent builds. This directory
52# is safe to share between multiple builds on the same machine too.
53#
54# The default is a downloads directory under TOPDIR which is the build directory.
55#
56#DL_DIR ?= "${TOPDIR}/downloads"
57
58#
59# Where to place shared-state files
60#
61# BitBake has the capability to accelerate builds based on previously built output.
62# This is done using "shared state" files which can be thought of as cache objects
63# and this option determines where those files are placed.
64#
65# You can wipe out TMPDIR leaving this directory intact and the build would regenerate
66# from these files if no changes were made to the configuration. If changes were made
67# to the configuration, only shared state files where the state was still valid would
68# be used (done using checksums).
69#
70# The default is a sstate-cache directory under TOPDIR.
71#
72#SSTATE_DIR ?= "${TOPDIR}/sstate-cache"
73
74#
75# Where to place the build output
76#
77# This option specifies where the bulk of the building work should be done and
78# where BitBake should place its temporary files and output. Keep in mind that
79# this includes the extraction and compilation of many applications and the toolchain
80# which can use Gigabytes of hard disk space.
81#
82# The default is a tmp directory under TOPDIR.
83#
84#TMPDIR = "${TOPDIR}/tmp"
85
86#
87# Default policy config
88#
89# The distribution setting controls which policy settings are used as defaults.
90# The default value is fine for general Yocto project use, at least initially.
91# Ultimately when creating custom policy, people will likely end up subclassing
92# these defaults.
93#
94DISTRO ?= "poky"
95# As an example of a subclass there is a "bleeding" edge policy configuration
96# where many versions are set to the absolute latest code from the upstream
97# source control systems. This is just mentioned here as an example, its not
98# useful to most new users.
99# DISTRO ?= "poky-bleeding"
100
101#
102# Package Management configuration
103#
104# This variable lists which packaging formats to enable. Multiple package backends
105# can be enabled at once and the first item listed in the variable will be used
106# to generate the root filesystems.
107# Options are:
108# - 'package_deb' for debian style deb files
109# - 'package_ipk' for ipk files are used by opkg (a debian style embedded package manager)
110# - 'package_rpm' for rpm style packages
111# E.g.: PACKAGE_CLASSES ?= "package_rpm package_deb package_ipk"
112# OE-Core defaults to ipkg, whilst Poky defaults to rpm:
113# PACKAGE_CLASSES ?= "package_rpm"
114
115#
116# SDK target architecture
117#
118# This variable specifies the architecture to build SDK items for and means
119# you can build the SDK packages for architectures other than the machine you are
120# running the build on (i.e. building i686 packages on an x86_64 host).
121# Supported values are i686, x86_64, aarch64
122#SDKMACHINE ?= "i686"
123
124#
125# Extra image configuration defaults
126#
127# The EXTRA_IMAGE_FEATURES variable allows extra packages to be added to the generated
128# images. Some of these options are added to certain image types automatically. The
129# variable can contain the following options:
130# "dbg-pkgs" - add -dbg packages for all installed packages
131# (adds symbol information for debugging/profiling)
132# "src-pkgs" - add -src packages for all installed packages
133# (adds source code for debugging)
134# "dev-pkgs" - add -dev packages for all installed packages
135# (useful if you want to develop against libs in the image)
136# "ptest-pkgs" - add -ptest packages for all ptest-enabled packages
137# (useful if you want to run the package test suites)
138# "tools-sdk" - add development tools (gcc, make, pkgconfig etc.)
139# "tools-debug" - add debugging tools (gdb, strace)
140# "eclipse-debug" - add Eclipse remote debugging support
141# "tools-profile" - add profiling tools (oprofile, lttng, valgrind)
142# "tools-testapps" - add useful testing tools (ts_print, aplay, arecord etc.)
143# "debug-tweaks" - make an image suitable for development
144# e.g. ssh root access has a blank password
145# There are other application targets that can be used here too, see
146# meta/classes-recipe/image.bbclass and
147# meta/classes-recipe/core-image.bbclass for more details.
148# We default to enabling the debugging tweaks.
149EXTRA_IMAGE_FEATURES ?= "debug-tweaks"
150
151#
152# Additional image features
153#
154# The following is a list of additional classes to use when building images which
155# enable extra features. Some available options which can be included in this variable
156# are:
157# - 'buildstats' collect build statistics
158USER_CLASSES ?= "buildstats"
159
160#
161# Runtime testing of images
162#
163# The build system can test booting virtual machine images under qemu (an emulator)
164# after any root filesystems are created and run tests against those images. It can also
165# run tests against any SDK that are built. To enable this uncomment these lines.
166# See meta/classes-recipe/test{image,sdk}.bbclass for further details.
167#IMAGE_CLASSES += "testimage testsdk"
168#TESTIMAGE_AUTO:qemuall = "1"
169
170#
171# Interactive shell configuration
172#
173# Under certain circumstances the system may need input from you and to do this it
174# can launch an interactive shell. It needs to do this since the build is
175# multithreaded and needs to be able to handle the case where more than one parallel
176# process may require the user's attention. The default is iterate over the available
177# terminal types to find one that works.
178#
179# Examples of the occasions this may happen are when resolving patches which cannot
180# be applied, to use the devshell or the kernel menuconfig
181#
182# Supported values are auto, gnome, xfce, rxvt, screen, konsole (KDE 3.x only), none
183# Note: currently, Konsole support only works for KDE 3.x due to the way
184# newer Konsole versions behave
185#OE_TERMINAL = "auto"
186# By default disable interactive patch resolution (tasks will just fail instead):
187PATCHRESOLVE = "noop"
188
189#
190# Disk Space Monitoring during the build
191#
192# Monitor the disk space during the build. If there is less that 1GB of space or less
193# than 100K inodes in any key build location (TMPDIR, DL_DIR, SSTATE_DIR), gracefully
194# shutdown the build. If there is less than 100MB or 1K inodes, perform a hard halt
195# of the build. The reason for this is that running completely out of space can corrupt
196# files and damages the build in ways which may not be easily recoverable.
197# It's necessary to monitor /tmp, if there is no space left the build will fail
198# with very exotic errors.
199BB_DISKMON_DIRS ??= "\
200 STOPTASKS,${TMPDIR},1G,100K \
201 STOPTASKS,${DL_DIR},1G,100K \
202 STOPTASKS,${SSTATE_DIR},1G,100K \
203 STOPTASKS,/tmp,100M,100K \
204 HALT,${TMPDIR},100M,1K \
205 HALT,${DL_DIR},100M,1K \
206 HALT,${SSTATE_DIR},100M,1K \
207 HALT,/tmp,10M,1K"
208
209#
210# Shared-state files from other locations
211#
212# As mentioned above, shared state files are prebuilt cache data objects which can be
213# used to accelerate build time. This variable can be used to configure the system
214# to search other mirror locations for these objects before it builds the data itself.
215#
216# This can be a filesystem directory, or a remote url such as https or ftp. These
217# would contain the sstate-cache results from previous builds (possibly from other
218# machines). This variable works like fetcher MIRRORS/PREMIRRORS and points to the
219# cache locations to check for the shared objects.
220# NOTE: if the mirror uses the same structure as SSTATE_DIR, you need to add PATH
221# at the end as shown in the examples below. This will be substituted with the
222# correct path within the directory structure.
223#SSTATE_MIRRORS ?= "\
224#file://.* https://someserver.tld/share/sstate/PATH;downloadfilename=PATH \
225#file://.* file:///some/local/dir/sstate/PATH"
226
227#
228# Yocto Project SState Mirror
229#
230# The Yocto Project has prebuilt artefacts available for its releases, you can enable
231# use of these by uncommenting some of the following lines. This will mean the build uses
232# the network to check for artefacts at the start of builds, which does slow it down
233# initially but it will then speed up the builds by not having to build things if they are
234# present in the cache. It assumes you can download something faster than you can build it
235# which will depend on your network.
236# Note: For this to work you also need hash-equivalence passthrough to the matching server
237# There is a choice between our sstate server directly and a faster content delivery network
238# (CDN) kindly provided by JSDelivr, uncomment one of the SSTATE_MIRRORS lines, not both.
239# Using the CDN rather than the yoctoproject.org address is suggested/preferred.
240#
241#BB_HASHSERVE_UPSTREAM = 'wss://hashserv.yoctoproject.org/ws'
242#SSTATE_MIRRORS ?= "file://.* http://cdn.jsdelivr.net/yocto/sstate/all/PATH;downloadfilename=PATH"
243#
244###SSTATE_MIRRORS ?= "file://.* http://sstate.yoctoproject.org/all/PATH;downloadfilename=PATH"
245
246
247#
248# Qemu configuration
249#
250# By default native qemu will build with a builtin VNC server where graphical output can be
251# seen. The line below enables the SDL UI frontend too.
252PACKAGECONFIG:append:pn-qemu-system-native = " sdl"
253# By default libsdl2-native will be built, if you want to use your host's libSDL instead of
254# the minimal libsdl built by libsdl2-native then uncomment the ASSUME_PROVIDED line below.
255#ASSUME_PROVIDED += "libsdl2-native"
256
257# You can also enable the Gtk UI frontend, which takes somewhat longer to build, but adds
258# a handy set of menus for controlling the emulator.
259#PACKAGECONFIG:append:pn-qemu-system-native = " gtk+"
260
261#
262# Hash Equivalence
263#
264# Enable support for automatically running a local hash equivalence server and
265# instruct bitbake to use a hash equivalence aware signature generator. Hash
266# equivalence improves reuse of sstate by detecting when a given sstate
267# artifact can be reused as equivalent, even if the current task hash doesn't
268# match the one that generated the artifact.
269#
270# A shared hash equivalent server can be set with "<HOSTNAME>:<PORT>" format
271#
272#BB_HASHSERVE = "auto"
273#BB_SIGNATURE_HANDLER = "OEEquivHash"
274
275#
276# Memory Resident Bitbake
277#
278# Bitbake's server component can stay in memory after the UI for the current command
279# has completed. This means subsequent commands can run faster since there is no need
280# for bitbake to reload cache files and so on. Number is in seconds, after which the
281# server will shut down.
282#
283#BB_SERVER_TIMEOUT = "60"
284
285# CONF_VERSION is increased each time build/conf/ changes incompatibly and is used to
286# track the version of this file when it was generated. This can safely be ignored if
287# this doesn't mean anything to you.
288CONF_VERSION = "2"
diff --git a/meta-poky/conf/templates/default/local.conf.sample.extended b/meta-poky/conf/templates/default/local.conf.sample.extended
new file mode 100644
index 0000000000..bc2dec9f52
--- /dev/null
+++ b/meta-poky/conf/templates/default/local.conf.sample.extended
@@ -0,0 +1,388 @@
1# BBMASK contains regular expressions that can be used to tell BitBake to ignore
2# certain recipes.
3#BBMASK = ""
4
5#
6# Parallelism Options
7#
8# These two options control how much parallelism BitBake should use. The first
9# option determines how many tasks bitbake should run in parallel:
10#
11#BB_NUMBER_THREADS ?= "4"
12#
13# Default to setting automatically based on cpu count
14#BB_NUMBER_THREADS ?= "${@oe.utils.cpu_count()}"
15#
16# The second option controls how many processes make should run in parallel when
17# running compile tasks:
18#
19#PARALLEL_MAKE ?= "-j 4"
20#
21# Default to setting automatically based on cpu count
22#PARALLEL_MAKE ?= "-j ${@oe.utils.cpu_count()}"
23#
24# For a quad-core machine, BB_NUMBER_THREADS = "4", PARALLEL_MAKE = "-j 4" would
25# be appropriate for example.
26#
27# Some users are behind firewalls or use servers where the number of parallel connections
28# is limited. In such cases you can limit the number of fetch tasks which run in parallel by
29# setting the option below, in this case limiting to a maximum of 4 fetch tasks in parallel:
30#
31#do_fetch[number_threads] = "4"
32#
33
34# If you want to get an image based on directfb without x11 alter
35# DISTRO_FEATURES:
36DISTRO_FEATURES:append = " directfb"
37DISTRO_FEATURES:remove = "x11"
38
39# ENABLE_BINARY_LOCALE_GENERATION controls the generation of binary locale
40# packages at build time using qemu-native. Disabling it (by setting it to 0)
41# will save some build time at the expense of breaking i18n on devices with
42# less than 128MB RAM.
43#ENABLE_BINARY_LOCALE_GENERATION = "1"
44
45# If GLIBC_SPLIT_LC_PACKAGES is set to a non-zero value, convert
46# glibc-binary-localedata-XX-YY to be a meta package depending on
47# glibc-binary-localedata-XX-YY-lc-address and so on. This enables
48# saving quite some space if someone doesn't need LC_COLLATE for
49# example.
50#GLIBC_SPLIT_LC_PACKAGES = "1"
51
52# Set GLIBC_GENERATE_LOCALES to the locales you wish to generate should you not
53# wish to perform the time-consuming step of generating all LIBC locales.
54# NOTE: If removing en_US.UTF-8 you will also need to uncomment, and set
55# appropriate value for IMAGE_LINGUAS.
56# WARNING: this may break localisation!
57# WARNING: some recipes expect certain localizations to be enabled, e.g.
58# bash-ptest: fr-fr, de-de
59# glib-2.0-ptest: tr-tr, lt-lt, ja-jp.euc-jp, fa-ir, ru-ru, de-de, hr-hr, el-gr, fr-fr, es-es, en-gb
60# if you remove some of these and enable ptest, you'll get QA warning like:
61# ERROR: glib-2.0-1_2.58.0-r0 do_package_qa: QA Issue: glib-2.0-ptest rdepends on locale-base-de-de, but it isn't a build dependency? [build-deps]
62#GLIBC_GENERATE_LOCALES = "en_GB.UTF-8 en_US.UTF-8"
63#IMAGE_LINGUAS ?= "en-gb"
64
65# The following are used to control options related to debugging.
66#
67# Uncomment this to change the optimization to make debugging easer, at the
68# possible cost of performance.
69# DEBUG_BUILD = "1"
70#
71# Uncomment this to disable the stripping of the installed binaries
72# INHIBIT_PACKAGE_STRIP = "1"
73#
74# Uncomment this to disable the split of the debug information into -dbg files
75# INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
76#
77# When splitting debug information, the following controls the results of the
78# file splitting.
79#
80# .debug (default):
81# When splitting the debug information will be placed into
82# a .debug directory in the same dirname of the binary produced:
83# /bin/foo -> /bin/.debug/foo
84#
85# debug-file-directory:
86# When splitting the debug information will be placed into
87# a central debug-file-directory, /usr/lib/debug:
88# /bin/foo -> /usr/lib/debug/bin/foo.debug
89#
90# Any source code referenced in the debug symbols will be copied
91# and made available within the /usr/src/debug directory
92#
93#PACKAGE_DEBUG_SPLIT_STYLE = '.debug'
94# PACKAGE_DEBUG_SPLIT_STYLE = 'debug-file-directory'
95
96# Uncomment these to build a package such that you can use gprof to profile it.
97# NOTE: Don't build glibc itself with these flags, or it'll fail to build.
98#
99# PROFILE_OPTIMIZATION = "-pg"
100# SELECTED_OPTIMIZATION = "${PROFILE_OPTIMIZATION}"
101# LDFLAGS =+ "-pg"
102
103# TCMODE controls the characteristics of the generated packages/images by
104# telling poky which toolchain 'profile' to use.
105#
106# The default is "default" which uses the internal toolchain. With
107# additional layers, it is possible to set this to use a precompiled
108# external toolchain. One example is the Sourcery G++ Toolchain, support
109# for which is now in the separate meta-sourcery layer:
110#
111# http://github.com/MentorEmbedded/meta-sourcery/
112#
113# meta-sourcery can be used as a template for adding support for other
114# external toolchains. See the link above for further details.
115#
116# TCMODE points the system to a file in conf/distro/include/tcmode-${TCMODE}.inc,
117# so for meta-sourcery which has conf/distro/include/tcmode-external-sourcery.inc
118# you would set it as follows:
119#
120# TCMODE ?= "external-sourcery"
121
122# This value is currently used by pseudo to determine if the recipe should
123# build both the 32-bit and 64-bit wrapper libraries on a 64-bit build system.
124#
125# Pseudo will attempt to determine if a 32-bit wrapper is necessary, but
126# it doesn't always guess properly. If you have 32-bit executables on
127# your 64-bit build system, you likely want to set this to "0",
128# otherwise you could end up with incorrect file attributes on the
129# target filesystem.
130#
131# Default is to not build 32 bit libs on 64 bit systems, uncomment this
132# if you need the 32 bits libs
133#NO32LIBS = "0"
134
135# Uncomment the following lines to enable multilib builds
136#require conf/multilib.conf
137#MULTILIBS = "multilib:lib32"
138#DEFAULTTUNE:virtclass-multilib-lib32 = "x86"
139
140# Set RPM_PREFER_ELF_ARCH to configure preferred ABI when using rpm packaging
141# backend to generate a rootfs, choices are:
142# 1: ELF32 wins
143# 2: ELF64 wins
144# 4: ELF64 N32 wins (for mips64 or mips64el only)
145#RPM_PREFER_ELF_ARCH ?= "2"
146
147# The network based PR service host and port
148# Uncomment the following lines to enable PRservice.
149# Set PRSERV_HOST to 'localhost:0' to automatically
150# start local PRService.
151# Set to other values to use remote PRService.
152#PRSERV_HOST = "localhost:0"
153
154# Additional image generation features
155#
156# The following is a list of classes to import to use in the generation of images
157# currently an example class is image_types_uboot
158# IMAGE_CLASSES = " image_types_uboot"
159
160# The following options will build a companion 'debug filesystem' in addition
161# to the normal deployable filesystem. This companion system allows a
162# debugger to know the symbols and related sources. It can be used to
163# debug a remote 'production' system without having to add the debug symbols
164# and sources to remote system. If IMAGE_FSTYPES_DEBUGFS is not defined, it
165# defaults to IMAGE_FSTYPES.
166#IMAGE_GEN_DEBUGFS = "1"
167#IMAGE_FSTYPES_DEBUGFS = "tar.gz"
168
169# Incremental rpm image generation, the rootfs would be totally removed
170# and re-created in the second generation by default, but with
171# INC_RPM_IMAGE_GEN = "1", the rpm based rootfs would be kept, and will
172# do update(remove/add some pkgs) on it. NOTE: This is not suggested
173# when you want to create a productive rootfs
174#INC_RPM_IMAGE_GEN = "1"
175
176# This is a list of packages that require a commercial license to ship
177# product. If shipped as part of an image these packages may have
178# implications so they are disabled by default. To enable them,
179# un-comment the below as appropriate.
180#LICENSE_FLAGS_ACCEPTED = "commercial_gst-fluendo-mp3 \
181# commercial_gst-openmax \
182# commercial_gst-plugins-ugly \
183# commercial_lame \
184# commercial_libmad \
185# commercial_libomxil \
186# commercial_mpeg2dec \
187# commercial_qmmp"
188
189
190#
191# Disk space monitor, take action when the disk space or the amount of
192# inode is running low, it is enabled when BB_DISKMON_DIRS is set.
193#
194# Set the directory for the monitor, the format is:
195# "action,directory,minimum_space,minimum_free_inode"
196#
197# The "action" must be set and should be one of:
198# HALT: Immediately halt
199# STOPTASKS: The new tasks can't be executed any more, will stop the build
200# when the running tasks have been done.
201# WARN: show warnings (see BB_DISKMON_WARNINTERVAL for more information)
202#
203# The "directory" must be set, any directory is OK.
204#
205# Either "minimum_space" or "minimum_free_inode" (or both of them)
206# should be set, otherwise the monitor would not be enabled,
207# the unit can be G, M, K or none, but do NOT use GB, MB or KB
208# (B is not needed).
209#BB_DISKMON_DIRS = "STOPTASKS,${TMPDIR},1G,100K WARN,${SSTATE_DIR},1G,100K"
210#
211# Set disk space and inode interval (only works when the action is "WARN",
212# the unit can be G, M, or K, but do NOT use the GB, MB or KB
213# (B is not needed), the format is:
214# "disk_space_interval,disk_inode_interval", the default value is
215# "50M,5K" which means that it would warn when the free space is
216# lower than the minimum space(or inode), and would repeat the warning
217# when the disk space reduces 50M (or the amount of inode reduces 5k).
218#BB_DISKMON_WARNINTERVAL = "50M,5K"
219
220# Archive the source and put them to ${DEPLOY_DIR}/sources/.
221#
222#INHERIT += "archiver"
223#
224# The tarball for the patched source will be created by default, and you
225# can configure the archiver as follow:
226#
227# Create archive for:
228# 1) original (or unpacked) source:
229#ARCHIVER_MODE[src] = "original"
230# 2) patched source: (default)
231#ARCHIVER_MODE[src] = "patched"
232# 3) configured source:
233#ARCHIVER_MODE[src] = "configured"
234#
235# 4) the patches between do_unpack and do_patch:
236#ARCHIVER_MODE[diff] = "1"
237# set the files that you'd like to exclude from the diff:
238#ARCHIVER_MODE[diff-exclude] ?= ".pc autom4te.cache patches"
239#
240# 5) the environment data, similar to 'bitbake -e recipe':
241#ARCHIVER_MODE[dumpdata] = "1"
242#
243# 6) the recipe (.bb and .inc):
244#ARCHIVER_MODE[recipe] = "1"
245#
246# 7) Whether output the .src.rpm package:
247#ARCHIVER_MODE[srpm] = "1"
248#
249# 8) Filter the license, the recipe whose license in
250# COPYLEFT_LICENSE_INCLUDE will be included, and in
251# COPYLEFT_LICENSE_EXCLUDE will be excluded.
252#COPYLEFT_LICENSE_INCLUDE = 'GPL* LGPL*'
253#COPYLEFT_LICENSE_EXCLUDE = 'CLOSED Proprietary'
254#
255# 9) Config the recipe type that will be archived, the type can be
256# target, native, nativesdk, cross, crosssdk and cross-canadian,
257# you can set one or more types. Archive all types by default.
258#COPYLEFT_RECIPE_TYPES = 'target'
259#
260
261#
262# GCC/LD FLAGS to enable more secure code generation
263#
264# By including the security_flags include file you enable flags
265# to the compiler and linker that cause them to generate more secure
266# code.
267# This does affect compile speed slightly.
268#
269# Use the following line to enable the security compiler and linker flags to your build
270#require conf/distro/include/security_flags.inc
271
272# Image level user/group configuration.
273# Inherit extrausers to make the setting of EXTRA_USERS_PARAMS effective.
274#IMAGE_CLASSES += "extrausers"
275# User / group settings
276# The settings are separated by the ; character.
277# Each setting is actually a command. The supported commands are useradd,
278# groupadd, userdel, groupdel, usermod and groupmod.
279#EXTRA_USERS_PARAMS = "\
280# useradd -p '' tester; \
281# groupadd developers; \
282# userdel nobody; \
283# groupdel video; \
284# groupmod -g 1020 developers; \
285# usermod -s /bin/sh tester; \
286#"
287
288# Various packages dynamically add users and groups to the system at package
289# install time. For programs that do not care what the uid/gid is of the
290# resulting users/groups, the order of the install will determine the final
291# uid/gid. This can lead to non-deterministic uid/gid values from one build
292# to another. Use the following settings to specify that all user/group adds
293# should be created based on a static passwd/group file.
294#
295# Note, if you enable or disable the useradd-staticids in a configured system,
296# the TMPDIR may contain incorrect uid/gid values. Clearing the TMPDIR
297# will correct this condition.
298#
299# By default the system looks in the BBPATH for files/passwd and files/group
300# the default can be overridden by specifying USERADD_UID/GID_TABLES.
301#
302#USERADDEXTENSION = "useradd-staticids"
303#USERADD_UID_TABLES = "files/passwd"
304#USERADD_GID_TABLES = "files/group"
305#
306# In order to prevent generating a system where a dynamicly assigned uid/gid
307# can exist, you should enable the following setting. This will force the
308# system to error out if the user/group name is not defined in the
309# files/passwd or files/group (or specified replacements.)
310#USERADD_ERROR_DYNAMIC = "1"
311
312# Enabling FORTRAN
313# Note this is not officially supported and is just illustrated here to
314# show an example of how it can be done
315# You'll also need your fortran recipe to depend on libgfortran
316#FORTRAN:forcevariable = ",fortran"
317
318#
319# Kernel image features
320#
321# The INITRAMFS_IMAGE image variable will cause an additional recipe to
322# be built as a dependency to the what ever rootfs recipe you might be
323# using such as core-image-sato. The initramfs might be needed for
324# the initial boot of the target system such as to load kernel
325# modules prior to mounting the root file system.
326#
327# INITRAMFS_IMAGE_BUNDLE variable controls if the image recipe
328# specified by the INITRAMFS_IMAGE will be run through an extra pass
329# through the kernel compilation in order to build a single binary
330# which contains both the kernel image and the initramfs. The
331# combined binary will be deposited into the tmp/deploy directory.
332# NOTE: You can set INITRAMFS_IMAGE in an image recipe, but
333# INITRAMFS_IMAGE_BUNDLE can only be set in a conf file.
334#
335#INITRAMFS_IMAGE = "core-image-minimal-initramfs"
336#INITRAMFS_IMAGE_BUNDLE = "1"
337
338#
339# IPK Hierarchical feed
340#
341# In some cases it may be desirable not to have all package files in the same
342# directory. An example would be when package feeds are to be uploaded to a
343# shared webhosting service or transferred to a Windows machine which may have
344# problems with directories containing multiple thousands of files.
345#
346# If the IPK_HIERARCHICAL_FEED variable is set to "1", packages will be split
347# between subdirectories in a similar way to how Debian package feeds are
348# organised. In the hierarchical feed, package files are written to
349# <outdir>/<arch>/<pkg_prefix>/<pkg_subdir>, where pkg_prefix is the first
350# letter of the package file name for non-lib packages or "lib" plus the 4th
351# letter of the package file name for lib packages (eg, 'l' for less, 'libc' for
352# libc6). pkg_subdir is the root of the package file name, discarding the
353# version and architecture parts and the common suffixes '-dbg', '-dev', '-doc',
354# '-staticdev', '-locale' and '-locale-*' which are listed in
355# meta/conf/bitbake.conf.
356#
357# If IPK_HIERARCHICAL_FEED is unset or set to any other value, the traditional
358# feed layout is used where package files are placed in <outdir>/<arch>/.
359#
360#IPK_HIERARCHICAL_FEED = "1"
361#
362
363#
364# System initialization
365#
366#INIT_MANAGER = "none"
367#INIT_MANAGER = "sysvinit"
368#INIT_MANAGER = "systemd"
369#INIT_MANAGER = "mdev-busybox"
370
371#
372# Use a full set of packages instead of busybox for base utils
373#
374#PREFERRED_PROVIDER_base-utils = "packagegroup-core-base-utils"
375#VIRTUAL-RUNTIME_base-utils = "packagegroup-core-base-utils"
376#VIRTUAL-RUNTIME_base-utils-hwclock = "util-linux-hwclock"
377#VIRTUAL-RUNTIME_base-utils-syslog = "syslog"
378
379#
380# Enable LTO system-wide
381#
382#require conf/distro/include/lto.inc
383#DISTRO_FEATURES:append = " lto"
384
385#
386# Set PS1 for SDK
387#
388#SDK_PS1 ?= "${SDK_NAME}${SDK_VENDOR}:\$ "
diff --git a/meta-poky/conf/templates/default/site.conf.sample b/meta-poky/conf/templates/default/site.conf.sample
new file mode 100644
index 0000000000..5164fedf63
--- /dev/null
+++ b/meta-poky/conf/templates/default/site.conf.sample
@@ -0,0 +1,33 @@
1#
2# local.conf covers user settings, site.conf covers site specific information
3# such as proxy server addresses and optionally any shared download location
4#
5# SITE_CONF_VERSION is increased each time build/conf/site.conf
6# changes incompatibly
7SCONF_VERSION = "1"
8
9# Uncomment to cause CVS to use the proxy host specified
10#CVS_PROXY_HOST = "proxy.example.com"
11#CVS_PROXY_PORT = "81"
12
13# For svn, you need to create ~/.subversion/servers containing:
14#[global]
15#http-proxy-host = proxy.example.com
16#http-proxy-port = 81
17#
18
19# To use git with a proxy, you must use an external git proxy command, such as
20# the one provided by scripts/oe-git-proxy. To use this script, copy it to
21# your PATH and uncomment the following:
22#GIT_PROXY_COMMAND ?= "oe-git-proxy"
23#ALL_PROXY ?= "socks://socks.example.com:1080"
24#or
25#ALL_PROXY ?= "https://proxy.example.com:8080"
26# If you wish to use certain hosts without the proxy, specify them in NO_PROXY.
27# See the script for details on syntax. The script oe-git-proxy uses some tools
28# that may not be included on HOSTTOOLS, thus add them manually through
29# HOSTTOOLS += "getent"
30
31# Uncomment this to use a shared download directory
32#DL_DIR = "/some/shared/download/directory/"
33