summaryrefslogtreecommitdiffstats
path: root/meta-gnome/packages/gnome/libbonoboui_2.18.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/packages/gnome/libbonoboui_2.18.0.bb')
-rw-r--r--meta-gnome/packages/gnome/libbonoboui_2.18.0.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/meta-gnome/packages/gnome/libbonoboui_2.18.0.bb b/meta-gnome/packages/gnome/libbonoboui_2.18.0.bb
new file mode 100644
index 0000000000..53380c6fa0
--- /dev/null
+++ b/meta-gnome/packages/gnome/libbonoboui_2.18.0.bb
@@ -0,0 +1,59 @@
1LICENSE = "GPL"
2SECTION = "x11/gnome/libs"
3PR = "r1"
4
5inherit gnome pkgconfig
6
7FILES_${PN} += "${libdir}/libglade/2.0/*.so"
8FILES_${PN}-dev += "${libdir}/libglade/2.0/* ${datadir}/gnome-2.0/ui \
9 ${libdir}/bonobo-2.0/samples"
10FILES_${PN}-dbg += "${libdir}/bonobo-2.0/samples/.debug \
11 ${libdir}/libglade/2.0/.debug"
12
13DEPENDS = "libgnomecanvas libbonobo libgnome glib-2.0 gtk-doc gconf libxml2 libglade"
14
15EXTRA_OECONF = "--disable-gtk-doc"
16
17HEADERS = " \
18bonobo/bonobo-zoomable.h \
19bonobo/bonobo-ui-component.h \
20bonobo/bonobo-dock-layout.h \
21bonobo/bonobo-ui-type-builtins.h \
22bonobo/bonobo-canvas-component.h \
23bonobo/bonobo-widget.h \
24bonobo/bonobo-ui-engine.h \
25bonobo/bonobo-window.h \
26bonobo/bonobo-ui-toolbar.h \
27bonobo/bonobo-dock-band.h \
28bonobo/bonobo-ui-toolbar-item.h \
29bonobo/bonobo-control.h \
30bonobo/bonobo-dock-item.h \
31bonobo/bonobo-ui-config-widget.h \
32bonobo/bonobo-zoomable-frame.h \
33bonobo/bonobo-control-frame.h \
34bonobo/bonobo-dock.h \
35bonobo/bonobo-ui-main.h \
36bonobo/bonobo-canvas-item.h \
37bonobo/bonobo-ui-node.h \
38bonobo/bonobo-socket.h \
39bonobo/bonobo-selector.h \
40bonobo/bonobo-ui-sync.h \
41bonobo/bonobo-ui-util.h \
42bonobo/bonobo-plug.h \
43bonobo/bonobo-ui-toolbar-button-item.h \
44bonobo/bonobo-ui-toolbar-toggle-button-item.h \
45bonobo/bonobo-ui-container.h \
46bonobo/bonobo-file-selector-util.h \
47bonobo/bonobo-property-control.h \
48bonobo/bonobo-selector-widget.h \
49libbonoboui.h \
50bonobo.h \
51"
52
53do_stage() {
54 install -d ${STAGING_INCDIR}/libbonoboui-2.0/bonobo
55 for i in ${HEADERS}; do
56 install -m 0644 $i ${STAGING_INCDIR}/libbonoboui-2.0/$i
57 done
58 oe_libinstall -C bonobo -a -so libbonoboui-2 ${STAGING_LIBDIR}
59}