summaryrefslogtreecommitdiffstats
path: root/meta-extras/packages/python/python-2.5.1/autohell.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-extras/packages/python/python-2.5.1/autohell.patch')
-rw-r--r--meta-extras/packages/python/python-2.5.1/autohell.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-extras/packages/python/python-2.5.1/autohell.patch b/meta-extras/packages/python/python-2.5.1/autohell.patch
new file mode 100644
index 0000000000..e2d63145be
--- /dev/null
+++ b/meta-extras/packages/python/python-2.5.1/autohell.patch
@@ -0,0 +1,49 @@
1#
2# FIXME: Don't simply rip this test out... add getting it from cache
3#
4Index: Python-2.5.1/configure.in
5===================================================================
6--- Python-2.5.1.orig/configure.in
7+++ Python-2.5.1/configure.in
8@@ -3367,41 +3367,6 @@ else
9 AC_MSG_RESULT(no)
10 fi
11
12-AC_MSG_CHECKING(for %zd printf() format support)
13-AC_TRY_RUN([#include <stdio.h>
14-#include <stddef.h>
15-#include <string.h>
16-
17-int main()
18-{
19- char buffer[256];
20-
21-#ifdef HAVE_SSIZE_T
22-typedef ssize_t Py_ssize_t;
23-#elif SIZEOF_VOID_P == SIZEOF_LONG
24-typedef long Py_ssize_t;
25-#else
26-typedef int Py_ssize_t;
27-#endif
28-
29- if(sprintf(buffer, "%zd", (size_t)123) < 0)
30- return 1;
31-
32- if (strcmp(buffer, "123"))
33- return 1;
34-
35- if (sprintf(buffer, "%zd", (Py_ssize_t)-123) < 0)
36- return 1;
37-
38- if (strcmp(buffer, "-123"))
39- return 1;
40-
41- return 0;
42-}],
43-[AC_MSG_RESULT(yes)
44- AC_DEFINE(PY_FORMAT_SIZE_T, "z", [Define to printf format modifier for Py_ssize_t])],
45- AC_MSG_RESULT(no))
46-
47 AC_CHECK_TYPE(socklen_t,,
48 AC_DEFINE(socklen_t,int,
49 Define to `int' if <sys/socket.h> does not define.),[