summaryrefslogtreecommitdiffstats
path: root/meta-extras/packages/nfs-utils/nfs-utils_1.0.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-extras/packages/nfs-utils/nfs-utils_1.0.6.bb')
-rw-r--r--meta-extras/packages/nfs-utils/nfs-utils_1.0.6.bb76
1 files changed, 0 insertions, 76 deletions
diff --git a/meta-extras/packages/nfs-utils/nfs-utils_1.0.6.bb b/meta-extras/packages/nfs-utils/nfs-utils_1.0.6.bb
deleted file mode 100644
index a941843488..0000000000
--- a/meta-extras/packages/nfs-utils/nfs-utils_1.0.6.bb
+++ /dev/null
@@ -1,76 +0,0 @@
1DESCRIPTION = "userspace utilities for kernel nfs"
2PRIORITY = "optional"
3SECTION = "console/network"
4LICENSE = "GPL"
5PR = "r9"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/nfs/nfs-utils-${PV}.tar.gz \
8 file://acinclude-lossage.patch;patch=1 \
9 file://rpcgen-lossage.patch;patch=1 \
10 file://stat-include.patch;patch=1 \
11 file://nfs-utils-1.0.6-uclibc.patch;patch=1 \
12 file://kernel-2.6.18+.patch;patch=1 \
13 file://nfsserver \
14 file://forgotten-defines"
15
16S = "${WORKDIR}/nfs-utils-${PV}/"
17
18PARALLEL_MAKE = ""
19
20# Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will
21# pull in the remainder of the dependencies.
22RDEPENDS = "portmap"
23RRECOMMENDS = "kernel-module-nfsd"
24
25INITSCRIPT_NAME = "nfsserver"
26# The server has no dependencies at the user run levels, so just put
27# it in at the default levels. It must be terminated before the network
28# in the shutdown levels, but that works fine.
29INITSCRIPT_PARAMS = "defaults"
30
31inherit autotools update-rc.d
32
33EXTRA_OECONF = "--with-statduser=nobody \
34 --enable-nfsv3 \
35 --with-statedir=/var/lib/nfs"
36
37do_compile() {
38 # UGLY HACK ALERT
39 cat ${WORKDIR}/forgotten-defines >> ${S}/support/include/config.h
40 oe_runmake 'BUILD=1'
41}
42
43INHIBIT_AUTO_STAGE = "1"
44
45do_install() {
46 install -d ${D}${sysconfdir}/init.d
47 install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
48
49 install -d ${D}${sbindir}
50 install -m 0755 ${S}/utils/exportfs/exportfs ${D}${sbindir}/exportfs
51 install -m 0755 ${S}/utils/lockd/lockd ${D}${sbindir}/lockd
52 install -m 0755 ${S}/utils/mountd/mountd ${D}${sbindir}/mountd
53 install -m 0755 ${S}/utils/nfsd/nfsd ${D}${sbindir}/nfsd
54 install -m 0755 ${S}/utils/nfsstat/nfsstat ${D}${sbindir}/nfsstat
55 install -m 0755 ${S}/utils/nhfsstone/nhfsgraph ${D}${sbindir}/nhfsgraph
56 install -m 0755 ${S}/utils/nhfsstone/nhfsnums ${D}${sbindir}/nhfsnums
57 install -m 0755 ${S}/utils/nhfsstone/nhfsrun ${D}${sbindir}/nhfsrun
58 install -m 0755 ${S}/utils/nhfsstone/nhfsstone ${D}${sbindir}/nhfsstone
59 install -m 0755 ${S}/utils/rquotad/rquotad ${D}${sbindir}/rquotad
60 install -m 0755 ${S}/utils/showmount/showmount ${D}${sbindir}/showmount
61 install -m 0755 ${S}/utils/statd/statd ${D}${sbindir}/statd
62
63 install -d ${D}${mandir}/man8
64 install -m 0644 ${S}/utils/exportfs/exportfs.man ${D}${mandir}/man8/exportfs.8
65 install -m 0644 ${S}/utils/lockd/lockd.man ${D}${mandir}/man8/lockd.8
66 install -m 0644 ${S}/utils/mountd/mountd.man ${D}${mandir}/man8/mountd.8
67 install -m 0644 ${S}/utils/nfsd/nfsd.man ${D}${mandir}/man8/nfsd.8
68 install -m 0644 ${S}/utils/nfsstat/nfsstat.man ${D}${mandir}/man8/nfsstat.8
69 install -m 0644 ${S}/utils/nhfsstone/nhfsgraph.man ${D}${mandir}/man8/nhfsgraph.8
70 install -m 0644 ${S}/utils/nhfsstone/nhfsnums.man ${D}${mandir}/man8/nhfsnums.8
71 install -m 0644 ${S}/utils/nhfsstone/nhfsrun.man ${D}${mandir}/man8/nhfsrun.8
72 install -m 0644 ${S}/utils/nhfsstone/nhfsstone.man ${D}${mandir}/man8/nhfsstone.8
73 install -m 0644 ${S}/utils/rquotad/rquotad.man ${D}${mandir}/man8/rquotad.8
74 install -m 0644 ${S}/utils/showmount/showmount.man ${D}${mandir}/man8/showmount.8
75 install -m 0644 ${S}/utils/statd/statd.man ${D}${mandir}/man8/statd.8
76}