summaryrefslogtreecommitdiffstats
path: root/meta-extras/packages/flumotion/flumotion/no-check-for-python-stuff.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-extras/packages/flumotion/flumotion/no-check-for-python-stuff.patch')
-rw-r--r--meta-extras/packages/flumotion/flumotion/no-check-for-python-stuff.patch68
1 files changed, 68 insertions, 0 deletions
diff --git a/meta-extras/packages/flumotion/flumotion/no-check-for-python-stuff.patch b/meta-extras/packages/flumotion/flumotion/no-check-for-python-stuff.patch
new file mode 100644
index 0000000000..08503c82e0
--- /dev/null
+++ b/meta-extras/packages/flumotion/flumotion/no-check-for-python-stuff.patch
@@ -0,0 +1,68 @@
1Index: flumotion-0.4.1/configure.ac
2===================================================================
3--- flumotion-0.4.1.orig/configure.ac 2007-03-05 17:16:48.121264330 +0100
4+++ flumotion-0.4.1/configure.ac 2007-03-05 17:20:40.343837320 +0100
5@@ -73,13 +73,6 @@
6 AC_MSG_ERROR([PyGTK 2.5.2 contains known bugs, please install other version])
7 fi
8
9-if test "x$DISPLAY" != "x"; then
10- AS_PYTHON_IMPORT([gtk.glade],,
11- AC_MSG_ERROR([You need to have python libglade bindings installed]))
12-else
13- AC_MSG_NOTICE([Not trying to import gtk.glade because DISPLAY is unset])
14-fi
15-
16 if test $GST_010_SUPPORTED = "no"; then
17 AC_MSG_ERROR([No appropriate version of PyGTK installed. Correct the above
18 errors and try again.])
19@@ -94,16 +87,6 @@
20 [AC_MSG_RESULT([$PYGST_010_PKG_ERRORS])
21 GST_010_SUPPORTED=no])
22
23- if test $GST_010_SUPPORTED = "yes"; then
24- saved_PYTHONPATH=$PYTHONPATH
25- export PYTHONPATH=$PYGST_010_DIR:$PYTHONPATH
26- AS_PYTHON_IMPORT([gst],,
27- [AC_MSG_NOTICE([Unable to import gst-python 0.10 -- check your PYTHONPATH?])
28- GST_010_SUPPORTED=no],
29- [import pygst; pygst.require('0.10')],
30- [assert gst.pygst_version[[1]] == 10 or (gst.pygst_version[[1]] == 9 and gst.pygst_version[[2]] >= 7)])
31-
32- fi
33 fi
34
35 if test $GST_010_SUPPORTED = "no"; then
36@@ -158,32 +141,7 @@
37 AC_CHECK_PROG(PYCHECKER, pychecker, yes, no)
38 AM_CONDITIONAL(HAVE_PYCHECKER, test "x$PYCHECKER" = "xyes")
39
40-dnl check for Twisted
41-AS_PYTHON_IMPORT(twisted,
42- [
43- AC_MSG_CHECKING(for Twisted >= 2.0.1)
44- prog="
45-import sys
46-import twisted.copyright
47-minver = '2.0.1'
48-if twisted.copyright.version < minver:
49- sys.exit(1)
50-sys.exit(0)
51-"
52- if $PYTHON -c "$prog" 1>&AC_FD_CC 2>&AC_FD_CC
53- then
54- AC_MSG_RESULT(found)
55- else
56- AC_MSG_RESULT(too old)
57- AC_MSG_ERROR([You need at least version 2.0.1 of Twisted])
58- fi
59- ]
60- ,
61- AC_MSG_ERROR([You need at least version 2.0.1 of Twisted])
62-)
63
64-TWISTED_MODULE([twisted.names])
65-TWISTED_MODULE([twisted.web])
66
67 AC_CONFIG_FILES([env], [chmod +x env])
68 AC_CONFIG_FILES([bin/flumotion], [chmod +x bin/flumotion])