summaryrefslogtreecommitdiffstats
path: root/meta-emenlow/packages/psb-kernel-source/psb-kernel-source_4.42.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-emenlow/packages/psb-kernel-source/psb-kernel-source_4.42.0.bb')
-rw-r--r--meta-emenlow/packages/psb-kernel-source/psb-kernel-source_4.42.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-emenlow/packages/psb-kernel-source/psb-kernel-source_4.42.0.bb b/meta-emenlow/packages/psb-kernel-source/psb-kernel-source_4.42.0.bb
new file mode 100644
index 0000000000..b6a0a3a7a0
--- /dev/null
+++ b/meta-emenlow/packages/psb-kernel-source/psb-kernel-source_4.42.0.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "Kernel module for the Poulsbo (psb) 2D X11 driver"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://GPLv2_License.txt;md5=f5ca3155cfeaa64a6ea228b11ad6916d"
4PR = "r1"
5
6inherit module
7
8SRC_URI = "https://launchpad.net/~gma500/+archive/ppa/+files/psb-kernel-source_4.42.0-0ubuntu2~1004um2.tar.gz \
9 file://build.patch;patch=1"
10
11do_compile () {
12 oe_runmake LINUXDIR=${STAGING_KERNEL_DIR} DRM_MODULES="psb"
13}
14
15do_install () {
16 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/extra
17 cp ${WORKDIR}/${PN}-${PV}/*.ko ${D}/lib/modules/${KERNEL_VERSION}/extra
18}
19
20FILES_${PN} += "${base_libdir}/modules/${KERNEL_VERSION}/extra/*.ko"
21
22DEPENDS += "virtual/kernel"