summaryrefslogtreecommitdiffstats
path: root/meta-emenlow/packages/libva/libva_0.31.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-emenlow/packages/libva/libva_0.31.0.bb')
-rw-r--r--meta-emenlow/packages/libva/libva_0.31.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-emenlow/packages/libva/libva_0.31.0.bb b/meta-emenlow/packages/libva/libva_0.31.0.bb
new file mode 100644
index 0000000000..52cd599957
--- /dev/null
+++ b/meta-emenlow/packages/libva/libva_0.31.0.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "Video Acceleration (VA) API for Linux"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://COPYING;md5=efc13a0998e678466e556756613c582e"
4PR = "r0"
5
6inherit autotools
7
8SRC_URI = "https://launchpad.net/~gma500/+archive/ppa/+files/libva_0.31.0-1+sds9.1ubuntu1.tar.gz \
9 file://033_g45_add_rgba_subpic.patch;patch=1 \
10 file://034_g45_fix_return_for_unimpl.patch;patch=1 \
11 file://035_g45_add_yv12_image_format.patch;patch=1 \
12 file://036_g45_add_vaGetImage.patch;patch=1 \
13 file://037_g45_add_vaPutImage.patch;patch=1 \
14 file://038_g45_vaPutSurface_cliprects.patch;patch=1 \
15 file://102_attribute_visibility.patch;patch=1 \
16 file://103_fix_vainfo_deps.patch;patch=1 \
17 file://104_fix_libva_pkgconfig_deps.patch;patch=1 \
18 file://105_dont_search_LIBGL_DRIVERS_PATH.patch;patch=1 \
19 file://108_drivers_path.patch;patch=1 \
20 file://203_fix_fglrx_detection.patch;patch=1 \
21 file://204_check_ATIFGLEXTENSION.patch;patch=1 \
22 file://300_sds_version.patch;patch=1 \
23 file://301_vdpau_mpeg4.patch;patch=1 \
24 file://320_move_vaPutSurface_flags_def.patch;patch=1 \
25 file://321_libva_glx.base.patch;patch=1 \
26 file://322_libva_glx.patch;patch=1 \
27 file://390_compat.base.patch;patch=1 \
28 file://391_compat.patch;patch=1 \
29 file://392_compat.dso.patch;patch=1"
30
31export LDFLAGS="-Wl,-z,defs"
32
33EXTRA_OECONF = "--disable-i965-driver"
34
35FILES_${PN} += "${libdir}/va/drivers/*"