summaryrefslogtreecommitdiffstats
path: root/meta-demoapps/recipes-gnome/abiword
diff options
context:
space:
mode:
Diffstat (limited to 'meta-demoapps/recipes-gnome/abiword')
-rw-r--r--meta-demoapps/recipes-gnome/abiword/abiword-2.5.inc64
-rw-r--r--meta-demoapps/recipes-gnome/abiword/abiword-embedded_2.5.2.bb12
-rw-r--r--meta-demoapps/recipes-gnome/abiword/abiword.inc64
-rw-r--r--meta-demoapps/recipes-gnome/abiword/abiword_2.5.2.bb5
-rw-r--r--meta-demoapps/recipes-gnome/abiword/abiword_svn.bb10
5 files changed, 0 insertions, 155 deletions
diff --git a/meta-demoapps/recipes-gnome/abiword/abiword-2.5.inc b/meta-demoapps/recipes-gnome/abiword/abiword-2.5.inc
deleted file mode 100644
index 511ae97bef..0000000000
--- a/meta-demoapps/recipes-gnome/abiword/abiword-2.5.inc
+++ /dev/null
@@ -1,64 +0,0 @@
1DESCRIPTION = "AbiWord is free word processing program similar to Microsoft(r) Word"
2HOMEPAGE = "http://www.abiword.org"
3SECTION = "x11/office"
4LICENSE = "GPLv2"
5DEPENDS = "perl-native wv libgsf libglade libfribidi jpeg libpng libxml2"
6RDEPENDS_${PN} = "glibc-gconv-ibm850 glibc-gconv-cp1252 \
7 glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
8
9SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz"
10
11#want 2.x from 2.x.y for the installation directory
12SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
13
14FILES_${PN} += " \
15 ${datadir}/icons/* \
16 ${datadir}/abiword-${SHRT_VER}/glade \
17 ${datadir}/abiword-${SHRT_VER}/scripts \
18 ${datadir}/abiword-${SHRT_VER}/system.profile-en \
19 ${datadir}/abiword-${SHRT_VER}/system.profile-en_GB \
20 ${datadir}/abiword-${SHRT_VER}/templates/normal.awt \
21 ${datadir}/abiword-${SHRT_VER}/templates/normal.awt-en_GB \
22 ${datadir}/abiword-${SHRT_VER}/templates/Employee-Directory.awt \
23 ${datadir}/abiword-${SHRT_VER}/templates/Business-Report.awt \
24 ${datadir}/abiword-${SHRT_VER}/templates/Fax-Coversheet.awt \
25 ${datadir}/abiword-${SHRT_VER}/templates/Resume.awt \
26 ${datadir}/abiword-${SHRT_VER}/templates/Two-Columns.awt \
27 ${datadir}/abiword-${SHRT_VER}/templates/Memo.awt \
28 ${datadir}/abiword-${SHRT_VER}/templates/Press-Release.awt "
29
30# ${datadir}/abiword-${SHRT_VER}/templates/A4.awt \
31# ${datadir}/abiword-${SHRT_VER}/templates/US-Letter.awt \
32
33inherit autotools pkgconfig
34
35PARALLEL_MAKE = ""
36
37EXTRA_OECONF = " --disable-pspell \
38 --disable-spellcheck \
39 --disable-printing \
40 --disable-exports \
41 --with-sys-wv"
42
43# AbiWord configure.ac does not play nicely with autoreconf
44# so use the autogen.sh script that comes with AbiWord
45#
46do_configure() {
47 cd ${S}
48 export NOCONFIGURE="no"; ./autogen.sh
49 oe_runconf
50}
51
52
53do_install_append() {
54 install -d ${D}${datadir}/pixmaps/
55 mv ${D}${datadir}/icons/* ${D}${datadir}/pixmaps/
56}
57
58PACKAGES += " abiword-clipart abiword-icons abiword-strings abiword-systemprofiles abiword-templates "
59
60FILES_abiword-clipart += "${datadir}/abiword-${SHRT_VER}/clipart"
61FILES_abiword-icons += "${datadir}/abiword-${SHRT_VER}/icons"
62FILES_abiword-strings += "${datadir}/abiword-${SHRT_VER}/AbiWord/strings"
63FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/AbiWord/system.profile*"
64FILES_abiword-templates += "${datadir}/abiword-${SHRT_VER}/templates"
diff --git a/meta-demoapps/recipes-gnome/abiword/abiword-embedded_2.5.2.bb b/meta-demoapps/recipes-gnome/abiword/abiword-embedded_2.5.2.bb
deleted file mode 100644
index 7ee0f866a0..0000000000
--- a/meta-demoapps/recipes-gnome/abiword/abiword-embedded_2.5.2.bb
+++ /dev/null
@@ -1,12 +0,0 @@
1require abiword-2.5.inc
2
3PR = "r1"
4
5EXTRA_OECONF += "--enable-embedded"
6
7S = "${WORKDIR}/abiword-${PV}"
8
9RCONFLICTS = "abiword"
10RPROVIDES += "abiword"
11
12
diff --git a/meta-demoapps/recipes-gnome/abiword/abiword.inc b/meta-demoapps/recipes-gnome/abiword/abiword.inc
deleted file mode 100644
index 036f98f348..0000000000
--- a/meta-demoapps/recipes-gnome/abiword/abiword.inc
+++ /dev/null
@@ -1,64 +0,0 @@
1DESCRIPTION = "AbiWord is free word processing program similar to Microsoft(r) Word"
2SECTION = "gnome/office"
3HOMEPAGE = "http://www.abiword.org""
4LICENSE = "GPLv2"
5
6DEPENDS = "libgsf libglade libfribidi libxml2 wv"
7RRECOMMENDS_${PN} = "glibc-gconv-ibm850 glibc-gconv-cp1252 \
8 glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
9
10# Share this file between recipes that use cvs and that pull tarballs
11# (one day change this to differentiate automatically based on PV and set the
12# SRC_URI and S var directly)
13RELURI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz"
14RELSRC = "${WORKDIR}/abiword-${PV}/abi"
15
16SVNURI = "svn://svn.abisource.com/abiword/trunk;module=abiword;proto=http"
17SVNSRC = "${WORKDIR}/abi"
18
19#want 2.x from 2.x.y for the installation directory
20SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
21
22FILES_${PN} += " \
23 ${datadir}/icons/* \
24 ${datadir}/mime-info \
25 ${datadir}/abiword-${SHRT_VER}/glade \
26 ${datadir}/abiword-${SHRT_VER}/system.profile-en \
27 ${datadir}/abiword-${SHRT_VER}/system.profile-en-GB \
28 "
29
30# ${datadir}/abiword-${SHRT_VER}/templates/normal.awt \
31# ${datadir}/abiword-${SHRT_VER}/templates/normal.awt-en_GB \
32
33inherit autotools pkgconfig
34
35PARALLEL_MAKE = ""
36
37# This is a minimalistic AbiWord build
38#
39# if you are planning to build plugins, make sure to comment out the
40# --disable-exports options
41
42EXTRA_OECONF = " --enable-embedded=poky \
43 --disable-printing \
44 --with-sys-wv \
45 --disable-exports \
46 --disable-spellcheck"
47
48# TODO -- refactor this, so that instead of two strings and profiles
49# packages we have lots of locale packages, each with a set of strings and
50# a profile
51#
52PACKAGES += " abiword-strings abiword-systemprofiles"
53
54FILES_abiword-strings += "${datadir}/abiword-${SHRT_VER}/strings"
55FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/system.profile*"
56
57# AbiWord configure.ac does not play nicely with autoreconf
58# so use the autogen.sh script that comes with AbiWord
59#
60do_configure() {
61 cd ${S}
62 export NOCONFIGURE="no"; ./autogen.sh
63 oe_runconf
64}
diff --git a/meta-demoapps/recipes-gnome/abiword/abiword_2.5.2.bb b/meta-demoapps/recipes-gnome/abiword/abiword_2.5.2.bb
deleted file mode 100644
index c10d761b06..0000000000
--- a/meta-demoapps/recipes-gnome/abiword/abiword_2.5.2.bb
+++ /dev/null
@@ -1,5 +0,0 @@
1require abiword-2.5.inc
2
3PR = "r2"
4
5RCONFLICTS_${PN} = "abiword-embedded"
diff --git a/meta-demoapps/recipes-gnome/abiword/abiword_svn.bb b/meta-demoapps/recipes-gnome/abiword/abiword_svn.bb
deleted file mode 100644
index a8946a80ee..0000000000
--- a/meta-demoapps/recipes-gnome/abiword/abiword_svn.bb
+++ /dev/null
@@ -1,10 +0,0 @@
1require abiword.inc
2
3SRCREV = "21818"
4PV="2.5.2+svnr${SRCPV}"
5PR = "r0"
6
7SRC_URI = "${SVNURI}"
8
9S = "${SVNSRC}"
10