summaryrefslogtreecommitdiffstats
path: root/handbook/examples/hello-single/hello.bb
diff options
context:
space:
mode:
Diffstat (limited to 'handbook/examples/hello-single/hello.bb')
-rw-r--r--handbook/examples/hello-single/hello.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/handbook/examples/hello-single/hello.bb b/handbook/examples/hello-single/hello.bb
new file mode 100644
index 0000000000..d815b1ed73
--- /dev/null
+++ b/handbook/examples/hello-single/hello.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "Simple helloworld application"
2SECTION = "examples"
3LICENSE = "MIT"
4
5SRC_URI = "file://helloworld.c"
6
7S = "${WORKDIR}"
8
9do_compile() {
10 ${CC} helloworld.c -o helloworld
11}
12
13do_install() {
14 install -d ${D}${bindir}
15 install -m 0755 helloworld ${D}${bindir}
16}