summaryrefslogtreecommitdiffstats
path: root/scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend
diff options
context:
space:
mode:
authorMariano Lopez <mariano.lopez@linux.intel.com>2016-03-03 15:17:21 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-09 16:58:14 +0000
commita27ca6da59e6939a5bbab641236f7f792c03694f (patch)
treeff925b162f6e620e66f1dd049ff673cb68f66a1a /scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend
parent2d0933ce31619f9dd0c28c5ed3486059442c250b (diff)
downloadpoky-a27ca6da59e6939a5bbab641236f7f792c03694f.tar.gz
yocto-bsp: Update templates to 4.4 kernel
Add kernel 4.4 support. kernel 4.1 was left in the tree for user to choose between 4.1 and 4.4. [YOCTO #9047] (From meta-yocto rev: c04093ec9b3cd151cf857bca9ad35bc9a0d4a4b1) Signed-off-by: Mariano Lopez <mariano.lopez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend')
-rw-r--r--scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend33
1 files changed, 33 insertions, 0 deletions
diff --git a/scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend b/scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend
new file mode 100644
index 0000000000..815c77b813
--- /dev/null
+++ b/scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/linux-yocto-tiny_4.4.bbappend
@@ -0,0 +1,33 @@
1# yocto-bsp-filename {{ if kernel_choice == "linux-yocto-tiny_4.4": }} this
2FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
3
4PR := "${PR}.1"
5
6COMPATIBLE_MACHINE_{{=machine}} = "{{=machine}}"
7
8{{ input type:"boolean" name:"need_new_kbranch" prio:"20" msg:"Do you need a new machine branch for this BSP (the alternative is to re-use an existing branch)? [y/n]" default:"y" }}
9
10{{ if need_new_kbranch == "y": }}
11{{ input type:"choicelist" name:"new_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard/tiny" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/tiny/base" }}
12
13{{ if need_new_kbranch == "n": }}
14{{ input type:"choicelist" name:"existing_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard/tiny" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/tiny/base" }}
15
16{{ if need_new_kbranch == "n": }}
17KBRANCH_{{=machine}} = "{{=existing_kbranch}}"
18
19{{ input type:"boolean" name:"smp" prio:"30" msg:"Do you need SMP support? (y/n)" default:"y"}}
20{{ if smp == "y": }}
21KERNEL_FEATURES_append_{{=machine}} += " cfg/smp.scc"
22
23SRC_URI += "file://{{=machine}}-tiny.scc \
24 file://{{=machine}}-user-config.cfg \
25 file://{{=machine}}-user-patches.scc \
26 file://{{=machine}}-user-features.scc \
27 "
28
29# replace these SRCREVs with the real commit ids once you've had
30# the appropriate changes committed to the upstream linux-yocto repo
31SRCREV_machine_pn-linux-yocto-tiny_{{=machine}} ?= "${AUTOREV}"
32SRCREV_meta_pn-linux-yocto-tiny_{{=machine}} ?= "${AUTOREV}"
33#LINUX_VERSION = "4.4"