summaryrefslogtreecommitdiffstats
path: root/scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.14": }} linux-yocto_3.14.bbappend
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@linux.intel.com>2014-04-08 09:42:56 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-09 09:53:14 +0100
commitbb20d3afbf0ee0319ef067c7ba48998d57f33f64 (patch)
treedbd3992c0e6892815d075f74c50c9be7cefffedb /scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.14": }} linux-yocto_3.14.bbappend
parent9eb52498f8b0aa63422da219d4126d7545745708 (diff)
downloadpoky-bb20d3afbf0ee0319ef067c7ba48998d57f33f64.tar.gz
yocto-bsp: Update templates to 3.14 kernel
Add 3.14 kernel support, and remove support for 3.4. (From meta-yocto rev: 342dce5873a9f1844fd7ce52a1c2656dcfb43053) Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.14": }} linux-yocto_3.14.bbappend')
-rw-r--r--scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.14": }} linux-yocto_3.14.bbappend32
1 files changed, 32 insertions, 0 deletions
diff --git a/scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.14": }} linux-yocto_3.14.bbappend b/scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.14": }} linux-yocto_3.14.bbappend
new file mode 100644
index 0000000000..aebda9b3a5
--- /dev/null
+++ b/scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto_3.14": }} linux-yocto_3.14.bbappend
@@ -0,0 +1,32 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3PR := "${PR}.1"
4
5COMPATIBLE_MACHINE_{{=machine}} = "{{=machine}}"
6
7{{ input type:"boolean" name:"need_new_kbranch" prio:"20" msg:"Do you need a new machine branch for this BSP (the alternative is to re-use an existing branch)? [y/n]" default:"y" }}
8
9{{ if need_new_kbranch == "y": }}
10{{ input type:"choicelist" name:"new_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/base" }}
11
12{{ if need_new_kbranch == "n": }}
13{{ input type:"choicelist" name:"existing_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/base" }}
14
15{{ if need_new_kbranch == "n": }}
16KBRANCH_{{=machine}} = "{{=existing_kbranch}}"
17
18{{ input type:"boolean" name:"smp" prio:"30" msg:"Do you need SMP support? (y/n)" default:"y"}}
19{{ if smp == "y": }}
20KERNEL_FEATURES_append_{{=machine}} += " cfg/smp.scc"
21
22SRC_URI += "file://{{=machine}}-standard.scc \
23 file://{{=machine}}-user-config.cfg \
24 file://{{=machine}}-user-patches.scc \
25 file://{{=machine}}-user-features.scc \
26 "
27
28# uncomment and replace these SRCREVs with the real commit ids once you've had
29# the appropriate changes committed to the upstream linux-yocto repo
30#SRCREV_machine_pn-linux-yocto_{{=machine}} ?= "840bb8c059418c4753415df56c9aff1c0d5354c8"
31#SRCREV_meta_pn-linux-yocto_{{=machine}} ?= "4fd76cc4f33e0afd8f906b1e8f231b6d13b6c993"
32#LINUX_VERSION = "3.14"