summaryrefslogtreecommitdiffstats
path: root/scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-tiny_3.4": }} linux-yocto-tiny_3.4.bbappend
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@linux.intel.com>2013-03-04 10:00:08 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-17 23:10:27 +0000
commitf0f436e0d28605424566bb28ea9171e3486cdfac (patch)
treeb151598ebc5e888354e491d9d13f35796575a47a /scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-tiny_3.4": }} linux-yocto-tiny_3.4.bbappend
parent8e47a95f7e22ca1f5b10cfde121be1f407be3075 (diff)
downloadpoky-f0f436e0d28605424566bb28ea9171e3486cdfac.tar.gz
yocto-bsp: add support for tiny
(From meta-yocto rev: 61a7cfb5f552586dd13fc553305e334ac53a8ce6) Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-tiny_3.4": }} linux-yocto-tiny_3.4.bbappend')
-rw-r--r--scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-tiny_3.4": }} linux-yocto-tiny_3.4.bbappend28
1 files changed, 28 insertions, 0 deletions
diff --git a/scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-tiny_3.4": }} linux-yocto-tiny_3.4.bbappend b/scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-tiny_3.4": }} linux-yocto-tiny_3.4.bbappend
new file mode 100644
index 0000000000..ceb8928cd1
--- /dev/null
+++ b/scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-tiny_3.4": }} linux-yocto-tiny_3.4.bbappend
@@ -0,0 +1,28 @@
1FILESEXTRAPATHS_prepend_{{=machine}} := "${THISDIR}/files:"
2
3PR := "${PR}.1"
4
5COMPATIBLE_MACHINE_{{=machine}} = "{{=machine}}"
6
7{{ input type:"boolean" name:"need_new_kbranch" prio:"20" msg:"Do you need a new machine branch for this BSP (the alternative is to re-use an existing branch)? [y/n]" default:"y" }}
8
9{{ if need_new_kbranch == "y": }}
10{{ input type:"choicelist" name:"new_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard/tiny" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/tiny/base" }}
11
12{{ if need_new_kbranch == "n": }}
13{{ input type:"choicelist" name:"existing_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard/tiny" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/tiny/base" }}
14
15{{ input type:"boolean" name:"smp" prio:"30" msg:"Do you need SMP support? (y/n)" default:"y"}}
16{{ if smp == "y": }}
17KERNEL_FEATURES_append_{{=machine}} += " cfg/smp.scc"
18
19SRC_URI += "file://{{=machine}}-tiny.scc \
20 file://{{=machine}}-user-config.cfg \
21 file://{{=machine}}-user-patches.scc \
22 "
23
24# uncomment and replace these SRCREVs with the real commit ids once you've had
25# the appropriate changes committed to the upstream linux-yocto repo
26#SRCREV_machine_pn-linux-yocto-tiny_{{=machine}} ?= "840bb8c059418c4753415df56c9aff1c0d5354c8"
27#SRCREV_meta_pn-linux-yocto-tiny_{{=machine}} ?= "4fd76cc4f33e0afd8f906b1e8f231b6d13b6c993"
28#LINUX_VERSION = "3.4.34"