summaryrefslogtreecommitdiffstats
path: root/scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-dev": }} linux-yocto-dev.bbappend
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@linux.intel.com>2013-03-04 10:15:20 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-17 23:10:27 +0000
commit04d15f567d0493654df519f404f564e2591e9453 (patch)
tree578c09979f6555a491b49e7c9cbf1b563e430d81 /scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-dev": }} linux-yocto-dev.bbappend
parentf0f436e0d28605424566bb28ea9171e3486cdfac (diff)
downloadpoky-04d15f567d0493654df519f404f564e2591e9453.tar.gz
yocto-bsp: add support for linux-yocto-dev
(From meta-yocto rev: 637104794a5646869d03ff5851d94199b1584dcf) Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-dev": }} linux-yocto-dev.bbappend')
-rw-r--r--scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-dev": }} linux-yocto-dev.bbappend21
1 files changed, 21 insertions, 0 deletions
diff --git a/scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-dev": }} linux-yocto-dev.bbappend b/scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-dev": }} linux-yocto-dev.bbappend
new file mode 100644
index 0000000000..0d814469fb
--- /dev/null
+++ b/scripts/lib/bsp/substrate/target/arch/powerpc/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-dev": }} linux-yocto-dev.bbappend
@@ -0,0 +1,21 @@
1FILESEXTRAPATHS_prepend_{{=machine}} := "${THISDIR}/files:"
2
3PR := "${PR}.1"
4
5COMPATIBLE_MACHINE_{{=machine}} = "{{=machine}}"
6{{ input type:"boolean" name:"need_new_kbranch" prio:"20" msg:"Do you need a new machine branch for this BSP (the alternative is to re-use an existing branch)? [y/n]" default:"y" }}
7
8{{ if need_new_kbranch == "y": }}
9{{ input type:"choicelist" name:"new_kbranch" nameappend:"i386" gen:"bsp.kernel.all_branches" branches_base:"standard" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/base" }}
10
11{{ if need_new_kbranch == "n": }}
12{{ input type:"choicelist" name:"existing_kbranch" nameappend:"i386" gen:"bsp.kernel.all_branches" branches_base:"standard" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/base" }}
13
14{{ input type:"boolean" name:"smp" prio:"30" msg:"Would you like SMP support? (y/n)" default:"y"}}
15{{ if smp == "y": }}
16KERNEL_FEATURES_append_{{=machine}} += " cfg/smp.scc"
17
18SRC_URI += "file://{{=machine}}-standard.scc \
19 file://{{=machine}}-user-config.cfg \
20 file://{{=machine}}-user-patches.scc \
21 "