summaryrefslogtreecommitdiffstats
path: root/scripts/lib/bsp/substrate/target/arch/mips64/recipes-kernel/linux/linux-yocto_4.12.bbappend
diff options
context:
space:
mode:
authorLeonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com>2017-08-30 12:14:05 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-31 23:37:10 +0100
commit15eac6befb6c4d16bc1b814e040bd7bf006a5bee (patch)
tree392b33fc1c8ca50bb1a967b190f268582e13dcbe /scripts/lib/bsp/substrate/target/arch/mips64/recipes-kernel/linux/linux-yocto_4.12.bbappend
parent49f530c2189c21942814349274539c69e4828d48 (diff)
downloadpoky-15eac6befb6c4d16bc1b814e040bd7bf006a5bee.tar.gz
linux-yocto: add linux-yocto 4.12 bbappends
This allows the yocto-bsp script to pick the 4.12 kernel version when creating a custom BSP. [YOCTO #11995] (From meta-yocto rev: 897c6121404055c4dcb2d9f43f1214d8c99480ea) Signed-off-by: Leonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts/lib/bsp/substrate/target/arch/mips64/recipes-kernel/linux/linux-yocto_4.12.bbappend')
-rw-r--r--scripts/lib/bsp/substrate/target/arch/mips64/recipes-kernel/linux/linux-yocto_4.12.bbappend37
1 files changed, 37 insertions, 0 deletions
diff --git a/scripts/lib/bsp/substrate/target/arch/mips64/recipes-kernel/linux/linux-yocto_4.12.bbappend b/scripts/lib/bsp/substrate/target/arch/mips64/recipes-kernel/linux/linux-yocto_4.12.bbappend
new file mode 100644
index 0000000000..5333c30b85
--- /dev/null
+++ b/scripts/lib/bsp/substrate/target/arch/mips64/recipes-kernel/linux/linux-yocto_4.12.bbappend
@@ -0,0 +1,37 @@
1# yocto-bsp-filename {{ if kernel_choice == "linux-yocto_4.12": }} this
2FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
3
4PR := "${PR}.1"
5
6COMPATIBLE_MACHINE_{{=machine}} = "{{=machine}}"
7
8{{ input type:"boolean" name:"need_new_kbranch" prio:"20" msg:"Do you need a new machine branch for this BSP (the alternative is to re-use an existing branch)? [y/n]" default:"y" }}
9
10{{ if need_new_kbranch == "y": }}
11{{ input type:"choicelist" name:"new_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/edgerouter" }}
12
13{{ if need_new_kbranch == "n": }}
14{{ input type:"choicelist" name:"existing_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/edgerouter" }}
15
16{{ if need_new_kbranch == "n": }}
17KBRANCH_{{=machine}} = "{{=existing_kbranch}}"
18
19{{ input type:"boolean" name:"smp" prio:"30" msg:"Do you need SMP support? (y/n)" default:"y"}}
20{{ if smp == "y": }}
21KERNEL_FEATURES_append_{{=machine}} += " cfg/smp.scc"
22
23SRC_URI += "file://{{=machine}}.scc \
24 file://{{=machine}}.cfg \
25 file://{{=machine}}-standard.scc \
26 file://{{=machine}}-user-config.cfg \
27 file://{{=machine}}-user-features.scc \
28 file://{{=machine}}-user-patches.scc \
29 "
30
31# replace these SRCREVs with the real commit ids once you've had
32# the appropriate changes committed to the upstream linux-yocto repo
33SRCREV_machine_pn-linux-yocto_{{=machine}} ?= "${AUTOREV}"
34SRCREV_meta_pn-linux-yocto_{{=machine}} ?= "${AUTOREV}"
35#LINUX_VERSION = "4.10"
36#Remove the following line once AUTOREV is locked to a certain SRCREV
37KERNEL_VERSION_SANITY_SKIP = "1"