summaryrefslogtreecommitdiffstats
path: root/scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/linux-yocto-dev.bbappend
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@linux.intel.com>2014-12-16 18:41:03 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-18 10:08:56 +0000
commit37a6affc485e729ad4bcb1f1af278f56a0dbbd58 (patch)
tree6e0f55ec59eb4ab9908a4579550a33fcf61c1b22 /scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/linux-yocto-dev.bbappend
parentcac54469898e11ff68f18acef24988446f5cb7cf (diff)
downloadpoky-37a6affc485e729ad4bcb1f1af278f56a0dbbd58.tar.gz
yocto-bsp: Get rid of 'strange' filenames in x86 templates
For the x86 templates, give all the 'strange' yocto-bsp template filenames 'normal' names, adding new yocto-bsp-filename and yocto-bsp-dirname tags for the new filename processing pass where needed. (From meta-yocto rev: 9fa30ad9cf1291a37d365515ec8d969fb4fd4aef) Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/linux-yocto-dev.bbappend')
-rw-r--r--scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/linux-yocto-dev.bbappend26
1 files changed, 26 insertions, 0 deletions
diff --git a/scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/linux-yocto-dev.bbappend b/scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/linux-yocto-dev.bbappend
new file mode 100644
index 0000000000..2fa6231cbf
--- /dev/null
+++ b/scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -0,0 +1,26 @@
1# yocto-bsp-filename {{ if kernel_choice == "linux-yocto-dev": }} this
2FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
3
4PR := "${PR}.1"
5
6COMPATIBLE_MACHINE_{{=machine}} = "{{=machine}}"
7{{ input type:"boolean" name:"need_new_kbranch" prio:"20" msg:"Do you need a new machine branch for this BSP (the alternative is to re-use an existing branch)? [y/n]" default:"y" }}
8
9{{ if need_new_kbranch == "y": }}
10{{ input type:"choicelist" name:"new_kbranch" nameappend:"i386" gen:"bsp.kernel.all_branches" branches_base:"standard" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/base" }}
11
12{{ if need_new_kbranch == "n": }}
13{{ input type:"choicelist" name:"existing_kbranch" nameappend:"i386" gen:"bsp.kernel.all_branches" branches_base:"standard" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/base" }}
14
15{{ if need_new_kbranch == "n": }}
16KBRANCH_{{=machine}} = "{{=existing_kbranch}}"
17
18{{ input type:"boolean" name:"smp" prio:"30" msg:"Would you like SMP support? (y/n)" default:"y"}}
19{{ if smp == "y": }}
20KERNEL_FEATURES_append_{{=machine}} += " cfg/smp.scc"
21
22SRC_URI += "file://{{=machine}}-standard.scc \
23 file://{{=machine}}-user-config.cfg \
24 file://{{=machine}}-user-patches.scc \
25 file://{{=machine}}-user-features.scc \
26 "