summaryrefslogtreecommitdiffstats
path: root/scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.8": }} linux-yocto-rt_3.8.bbappend
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@linux.intel.com>2013-03-26 15:26:38 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-05 22:54:29 +0100
commitfd67cfd1c567294e21485be82f8051379b695fbe (patch)
tree2efbfd7a39570710b228772bebec8501a0ad42af /scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.8": }} linux-yocto-rt_3.8.bbappend
parentfd7077260b1675b21228903cc8b616254926eadf (diff)
downloadpoky-fd67cfd1c567294e21485be82f8051379b695fbe.tar.gz
yocto-bsp: add linux-yocto-3.8-rt to templates
RT support is now available in the linux-yocto-3.8 kernel, so we can also add that as kernel option for users. (From meta-yocto rev: 2e425b5c6c7e685e8a0e0c8cb2cf64040e454cad) Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.8": }} linux-yocto-rt_3.8.bbappend')
-rw-r--r--scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.8": }} linux-yocto-rt_3.8.bbappend32
1 files changed, 32 insertions, 0 deletions
diff --git a/scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.8": }} linux-yocto-rt_3.8.bbappend b/scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.8": }} linux-yocto-rt_3.8.bbappend
new file mode 100644
index 0000000000..fb78cf15a1
--- /dev/null
+++ b/scripts/lib/bsp/substrate/target/arch/i386/recipes-kernel/linux/{{ if kernel_choice == "linux-yocto-rt_3.8": }} linux-yocto-rt_3.8.bbappend
@@ -0,0 +1,32 @@
1FILESEXTRAPATHS_prepend_{{=machine}} := "${THISDIR}/files:"
2
3PR := "${PR}.1"
4
5COMPATIBLE_MACHINE_{{=machine}} = "{{=machine}}"
6
7{{ input type:"boolean" name:"need_new_kbranch" prio:"20" msg:"Do you need a new machine branch for this BSP (the alternative is to re-use an existing branch)? [y/n]" default:"y" }}
8
9{{ if need_new_kbranch == "y": }}
10{{ input type:"choicelist" name:"new_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard/preempt-rt" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/preempt-rt/base" }}
11
12{{ if need_new_kbranch == "n": }}
13{{ input type:"choicelist" name:"existing_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard/preempt-rt" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/preempt-rt/base" }}
14
15{{ if need_new_kbranch == "n": }}
16KBRANCH_{{=machine}} = "{{=existing_kbranch}}"
17
18{{ input type:"boolean" name:"smp" prio:"30" msg:"Do you need SMP support? (y/n)" default:"y"}}
19{{ if smp == "y": }}
20KERNEL_FEATURES_append_{{=machine}} += " cfg/smp.scc"
21
22SRC_URI += "file://{{=machine}}-preempt-rt.scc \
23 file://{{=machine}}-user-config.cfg \
24 file://{{=machine}}-user-patches.scc \
25 file://{{=machine}}-user-features.scc \
26 "
27
28# uncomment and replace these SRCREVs with the real commit ids once you've had
29# the appropriate changes committed to the upstream linux-yocto repo
30#SRCREV_machine_pn-linux-yocto-rt_{{=machine}} ?= "f35992f80c81dc5fa1a97165dfd5cbb84661f7cb"
31#SRCREV_meta_pn-linux-yocto-rt_{{=machine}} ?= "1b534b2f8bbe9b8a773268cfa30a4850346f6f5f"
32#LINUX_VERSION = "3.8.4"