summaryrefslogtreecommitdiffstats
path: root/scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/linux-yocto_3.14.bbappend
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@linux.intel.com>2014-12-16 18:41:02 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-18 10:08:58 +0000
commit4b82dab822ebc33fc2e5228215511cc04b5abfea (patch)
tree0523479aab596839e54fbc0207d058dab93567dc /scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/linux-yocto_3.14.bbappend
parent6a103322f8ad752daf628d72c9334f0bf6145122 (diff)
downloadpoky-4b82dab822ebc33fc2e5228215511cc04b5abfea.tar.gz
yocto-bsp: Get rid of 'strange' filenames in arm templates
For the arm templates, give all the 'strange' yocto-bsp template filenames 'normal' names, adding new yocto-bsp-filename and yocto-bsp-dirname tags for the new filename processing pass where needed. (From meta-yocto rev: fb533fd98678671d319e52fc288783bbd0368218) Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/linux-yocto_3.14.bbappend')
-rw-r--r--scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/linux-yocto_3.14.bbappend33
1 files changed, 33 insertions, 0 deletions
diff --git a/scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/linux-yocto_3.14.bbappend b/scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/linux-yocto_3.14.bbappend
new file mode 100644
index 0000000000..1e1cc51315
--- /dev/null
+++ b/scripts/lib/bsp/substrate/target/arch/arm/recipes-kernel/linux/linux-yocto_3.14.bbappend
@@ -0,0 +1,33 @@
1# yocto-bsp-filename {{ if kernel_choice == "linux-yocto_3.14": }} this
2FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
3
4PR := "${PR}.1"
5
6COMPATIBLE_MACHINE_{{=machine}} = "{{=machine}}"
7
8{{ input type:"boolean" name:"need_new_kbranch" prio:"20" msg:"Do you need a new machine branch for this BSP (the alternative is to re-use an existing branch)? [y/n]" default:"y" }}
9
10{{ if need_new_kbranch == "y": }}
11{{ input type:"choicelist" name:"new_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/base" }}
12
13{{ if need_new_kbranch == "n": }}
14{{ input type:"choicelist" name:"existing_kbranch" gen:"bsp.kernel.all_branches" branches_base:"standard" prio:"20" msg:"Please choose a machine branch to base this BSP on:" default:"standard/base" }}
15
16{{ if need_new_kbranch == "n": }}
17KBRANCH_{{=machine}} = "{{=existing_kbranch}}"
18
19{{ input type:"boolean" name:"smp" prio:"30" msg:"Do you need SMP support? (y/n)" default:"y"}}
20{{ if smp == "y": }}
21KERNEL_FEATURES_append_{{=machine}} += " cfg/smp.scc"
22
23SRC_URI += "file://{{=machine}}-standard.scc \
24 file://{{=machine}}-user-config.cfg \
25 file://{{=machine}}-user-patches.scc \
26 file://{{=machine}}-user-features.scc \
27 "
28
29# uncomment and replace these SRCREVs with the real commit ids once you've had
30# the appropriate changes committed to the upstream linux-yocto repo
31#SRCREV_machine_pn-linux-yocto_{{=machine}} ?= "840bb8c059418c4753415df56c9aff1c0d5354c8"
32#SRCREV_meta_pn-linux-yocto_{{=machine}} ?= "4fd76cc4f33e0afd8f906b1e8f231b6d13b6c993"
33#LINUX_VERSION = "3.14" \ No newline at end of file