summaryrefslogtreecommitdiffstats
path: root/openembedded
diff options
context:
space:
mode:
authorChris Lord <chris@openedhand.com>2006-02-09 14:02:53 +0000
committerChris Lord <chris@openedhand.com>2006-02-09 14:02:53 +0000
commitfad9c3dbe19c96e05dcd8aa8e14590bd6a3a26c1 (patch)
tree355183b1813b4e27e94b6286360d210b5e70c7ba /openembedded
parentf54968cb3920eacbcafb0e94e02340079934faac (diff)
downloadpoky-fad9c3dbe19c96e05dcd8aa8e14590bd6a3a26c1.tar.gz
Fix contacts icons once and for all?
git-svn-id: https://svn.o-hand.com/repos/poky@254 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded')
-rwxr-xr-xopenembedded/packages/contacts/contacts_0.1.bb21
-rwxr-xr-xopenembedded/packages/contacts/contacts_svn.bb22
-rw-r--r--openembedded/packages/contacts/files/index.theme654
3 files changed, 14 insertions, 683 deletions
diff --git a/openembedded/packages/contacts/contacts_0.1.bb b/openembedded/packages/contacts/contacts_0.1.bb
index f2b81cbd8a..cf025259f2 100755
--- a/openembedded/packages/contacts/contacts_0.1.bb
+++ b/openembedded/packages/contacts/contacts_0.1.bb
@@ -3,29 +3,22 @@ SECTION = "x11"
3DEPENDS = "glib-2.0 gtk+ libglade eds-dbus" 3DEPENDS = "glib-2.0 gtk+ libglade eds-dbus"
4MAINTAINER = "Chris Lord <chris@openedhand.com>" 4MAINTAINER = "Chris Lord <chris@openedhand.com>"
5DESCRIPTION = "Contacts is an address-book application." 5DESCRIPTION = "Contacts is an address-book application."
6PR = "r1"
6 7
7SRC_URI = "svn://svn.o-hand.com/repos/${PN}/tags;module=release-0.1;proto=http \ 8SRC_URI = "svn://svn.o-hand.com/repos/${PN}/tags;module=release-0.1;proto=http \
8 file://stock_contact.png \ 9 file://stock_contact.png \
9 file://stock_person.png \ 10 file://stock_person.png"
10 file://index.theme"
11 11
12inherit autotools pkgconfig 12inherit autotools pkgconfig
13 13
14S = "${WORKDIR}/release-0.1" 14S = "${WORKDIR}/release-0.1"
15 15
16do_install_append () { 16do_install_append () {
17 install -d ${D}/${datadir}/icons/hicolor/48x48/stock/net 17 install -d ${D}/${datadir}/pixmaps
18 install -d ${D}/${datadir}/icons/hicolor/48x48/stock/generic 18 install -m 0644 ${WORKDIR}/stock_contact.png ${D}/${datadir}/pixmaps
19 19 install -m 0644 ${WORKDIR}/stock_person.png ${D}/${datadir}/pixmaps
20 install -m 0644 ${WORKDIR}/stock_contact.png ${D}/${datadir}/icons/hicolor/48x48/stock/net
21 install -m 0644 ${WORKDIR}/stock_person.png ${D}/${datadir}/icons/hicolor/48x48/stock/generic
22 install -m 0644 ${WORKDIR}/index.theme ${D}/${datadir}/icons/hicolor
23} 20}
24 21
25FILES_${PN} += "${datadir}/icons/hicolor/48x48/stock/*/*.png \ 22FILES_${PN} += "${datadir}/pixmaps/stock_contact.png \
26 ${datadir}/icons/hicolor/index.theme" 23 ${datadir}/pixmaps/stock_person.png"
27
28pkg_postinst_${PN} () {
29 gtk-update-icon-cache /usr/share/icons/hicolor
30}
31 24
diff --git a/openembedded/packages/contacts/contacts_svn.bb b/openembedded/packages/contacts/contacts_svn.bb
index cf86bffd1f..2783a48b97 100755
--- a/openembedded/packages/contacts/contacts_svn.bb
+++ b/openembedded/packages/contacts/contacts_svn.bb
@@ -5,14 +5,13 @@ RDEPENDS = "gnome-vfs-plugin-file"
5RRECOMMENDS = "gnome-vfs-plugin-http" 5RRECOMMENDS = "gnome-vfs-plugin-http"
6MAINTAINER = "Chris Lord <chris@openedhand.com>" 6MAINTAINER = "Chris Lord <chris@openedhand.com>"
7DESCRIPTION = "Contacts is an address-book application." 7DESCRIPTION = "Contacts is an address-book application."
8PR = "r4" 8PR = "r5"
9 9
10PV = "0.1+svn-${CVSDATE}" 10PV = "0.1+svn-${CVSDATE}"
11 11
12SRC_URI = "svn://svn.o-hand.com/repos/${PN};module=trunk;proto=http \ 12SRC_URI = "svn://svn.o-hand.com/repos/${PN};module=trunk;proto=http \
13 file://stock_contact.png \ 13 file://stock_contact.png \
14 file://stock_person.png \ 14 file://stock_person.png"
15 file://index.theme"
16 15
17inherit autotools pkgconfig 16inherit autotools pkgconfig
18 17
@@ -21,18 +20,11 @@ S = "${WORKDIR}/trunk"
21EXTRA_OECONF = "--enable-gnome-vfs" 20EXTRA_OECONF = "--enable-gnome-vfs"
22 21
23do_install_append () { 22do_install_append () {
24 install -d ${D}/${datadir}/icons/hicolor/48x48/stock/net 23 install -d ${D}/${datadir}/pixmaps
25 install -d ${D}/${datadir}/icons/hicolor/48x48/stock/generic 24 install -m 0644 ${WORKDIR}/stock_contact.png ${D}/${datadir}/pixmaps
26 25 install -m 0644 ${WORKDIR}/stock_person.png ${D}/${datadir}/pixmaps
27 install -m 0644 ${WORKDIR}/stock_contact.png ${D}/${datadir}/icons/hicolor/48x48/stock/net
28 install -m 0644 ${WORKDIR}/stock_person.png ${D}/${datadir}/icons/hicolor/48x48/stock/generic
29 install -m 0644 ${WORKDIR}/index.theme ${D}/${datadir}/icons/hicolor
30} 26}
31 27
32FILES_${PN} += "${datadir}/icons/hicolor/48x48/stock/*/*.png \ 28FILES_${PN} += "${datadir}/pixmaps/stock_contact.png \
33 ${datadir}/icons/hicolor/index.theme" 29 ${datadir}/pixmaps/stock_person.png"
34
35pkg_postinst_${PN} () {
36 gtk-update-icon-cache $D/usr/share/icons/hicolor
37}
38 30
diff --git a/openembedded/packages/contacts/files/index.theme b/openembedded/packages/contacts/files/index.theme
deleted file mode 100644
index 4e9cf67820..0000000000
--- a/openembedded/packages/contacts/files/index.theme
+++ /dev/null
@@ -1,654 +0,0 @@
1[Icon Theme]
2Name=Hicolor
3Comment=Fallback icon theme
4Hidden=true
5Directories=192x192/apps,128x128/actions,128x128/apps,128x128/devices,128x128/filesystems,128x128/mimetypes,96x96/actions,96x96/apps,96x96/devices,96x96/filesystems,96x96/mimetypes,72x72/apps,64x64/actions,64x64/apps,64x64/devices,64x64/filesystems,64x64/mimetypes,48x48/actions,48x48/apps,48x48/devices,48x48/filesystems,48x48/mimetypes,36x36/apps,32x32/actions,32x32/apps,32x32/devices,32x32/filesystems,32x32/mimetypes,22x22/actions,22x22/apps,22x22/devices,22x22/filesystems,22x22/mimetypes,16x16/actions,16x16/apps,16x16/devices,16x16/filesystems,16x16/mimetypes,scalable/actions,scalable/apps,scalable/devices,scalable/filesystems,scalable/mimetypes,16x16/stock/chart,16x16/stock/code,16x16/stock/data,16x16/stock/document,16x16/stock/form,16x16/stock/generic,16x16/stock/image,16x16/stock/io,16x16/stock/media,16x16/stock/navigation,16x16/stock/net,16x16/stock/object,16x16/stock/table,16x16/stock/text,24x24/actions,24x24/apps,24x24/devices,24x24/filesystems,24x24/mimetypes,24x24/stock/chart,24x24/stock/code,24x24/stock/data,24x24/stock/document,24x24/stock/form,24x24/stock/generic,24x24/stock/image,24x24/stock/io,24x24/stock/media,24x24/stock/navigation,24x24/stock/net,24x24/stock/object,24x24/stock/table,24x24/stock/text,32x32/stock/chart,32x32/stock/code,32x32/stock/data,32x32/stock/document,32x32/stock/form,32x32/stock/generic,32x32/stock/image,32x32/stock/io,32x32/stock/media,32x32/stock/navigation,32x32/stock/net,32x32/stock/object,32x32/stock/table,32x32/stock/text,36x36/stock/chart,36x36/stock/code,36x36/stock/data,36x36/stock/document,36x36/stock/form,36x36/stock/generic,36x36/stock/image,36x36/stock/io,36x36/stock/media,36x36/stock/navigation,36x36/stock/net,36x36/stock/object,36x36/stock/table,36x36/stock/text,48x48/stock/chart,48x48/stock/code,48x48/stock/data,48x48/stock/document,48x48/stock/form,48x48/stock/generic,48x48/stock/image,48x48/stock/io,48x48/stock/media,48x48/stock/navigation,48x48/stock/net,48x48/stock/object,48x48/stock/table,48x48/stock/text,scalable/emblems,192x192/emblems,96x96/emblems,72x72/emblems,48x48/emblems,36x36/emblems,24x24/emblems,16x16/emblems,12x12/emblems
6
7[16x16/actions]
8Size=16
9Context=Actions
10Type=Threshold
11
12[16x16/apps]
13Size=16
14Context=Applications
15Type=Threshold
16
17[16x16/devices]
18Size=16
19Context=Devices
20Type=Threshold
21
22[16x16/filesystems]
23Size=16
24Context=FileSystems
25Type=Threshold
26
27[16x16/mimetypes]
28Size=16
29Context=MimeTypes
30Type=Threshold
31
32[22x22/actions]
33Size=22
34Context=Actions
35Type=Threshold
36
37[22x22/apps]
38Size=22
39Context=Applications
40Type=Threshold
41
42[22x22/devices]
43Size=22
44Context=Devices
45Type=Threshold
46
47[22x22/filesystems]
48Size=22
49Context=FileSystems
50Type=Threshold
51
52[22x22/mimetypes]
53Size=22
54Context=MimeTypes
55Type=Threshold
56
57[24x24/actions]
58Size=24
59Context=Actions
60Type=Threshold
61
62[24x24/apps]
63Size=24
64Context=Applications
65Type=Threshold
66
67[24x24/devices]
68Size=24
69Context=Devices
70Type=Threshold
71
72[24x24/filesystems]
73Size=24
74Context=FileSystems
75Type=Threshold
76
77[24x24/mimetypes]
78Size=24
79Context=MimeTypes
80Type=Threshold
81
82[32x32/actions]
83Size=32
84Context=Actions
85Type=Threshold
86
87[32x32/apps]
88Size=32
89Context=Applications
90Type=Threshold
91
92[32x32/devices]
93Size=32
94Context=Devices
95Type=Threshold
96
97[32x32/filesystems]
98Size=32
99Context=FileSystems
100Type=Threshold
101
102[32x32/mimetypes]
103Size=32
104Context=MimeTypes
105Type=Threshold
106
107[36x36/apps]
108Size=36
109Context=Applications
110Type=Threshold
111
112[48x48/actions]
113Size=48
114Context=Actions
115Type=Threshold
116
117[48x48/apps]
118Size=48
119Context=Applications
120Type=Threshold
121
122[48x48/devices]
123Size=48
124Context=Devices
125Type=Threshold
126
127[48x48/filesystems]
128Size=48
129Context=FileSystems
130Type=Threshold
131
132[48x48/mimetypes]
133Size=48
134Context=MimeTypes
135Type=Threshold
136
137[64x64/actions]
138Size=64
139Context=Actions
140Type=Threshold
141
142[64x64/apps]
143Size=64
144Context=Applications
145Type=Threshold
146
147[64x64/devices]
148Size=64
149Context=Devices
150Type=Threshold
151
152[64x64/filesystems]
153Size=64
154Context=FileSystems
155Type=Threshold
156
157[64x64/mimetypes]
158Size=64
159Context=MimeTypes
160Type=Threshold
161
162[72x72/apps]
163Size=72
164Context=Applications
165Type=Threshold
166
167[96x96/actions]
168Size=96
169Context=Actions
170Type=Threshold
171
172[96x96/apps]
173Size=96
174Context=Applications
175Type=Threshold
176
177[96x96/devices]
178Size=96
179Context=Devices
180Type=Threshold
181
182[96x96/filesystems]
183Size=96
184Context=FileSystems
185Type=Threshold
186
187[96x96/mimetypes]
188Size=96
189Context=MimeTypes
190Type=Threshold
191
192[128x128/actions]
193Size=128
194Context=Actions
195Type=Threshold
196
197[128x128/apps]
198Size=128
199Context=Applications
200Type=Threshold
201
202[128x128/devices]
203Size=128
204Context=Devices
205Type=Threshold
206
207[128x128/filesystems]
208Size=128
209Context=FileSystems
210Type=Threshold
211
212[128x128/mimetypes]
213Size=128
214Context=MimeTypes
215Type=Threshold
216
217[192x192/apps]
218Size=192
219Context=Applications
220Type=Threshold
221
222
223[scalable/actions]
224MinSize=1
225Size=128
226MaxSize=256
227Context=Actions
228Type=Scalable
229
230[scalable/apps]
231MinSize=1
232Size=128
233MaxSize=256
234Context=Applications
235Type=Scalable
236
237[scalable/devices]
238MinSize=1
239Size=128
240MaxSize=256
241Context=Devices
242Type=Scalable
243
244[scalable/filesystems]
245MinSize=1
246Size=128
247MaxSize=256
248Context=FileSystems
249Type=Scalable
250
251[scalable/mimetypes]
252MinSize=1
253Size=128
254MaxSize=256
255Context=MimeTypes
256Type=Scalable
257
258[16x16/stock/chart]
259Size=16
260Context=Stock
261Type=Threshold
262
263[16x16/stock/code]
264Size=16
265Context=Stock
266Type=Threshold
267
268[16x16/stock/data]
269Size=16
270Context=Stock
271Type=Threshold
272
273[16x16/stock/document]
274Size=16
275Context=Stock
276Type=Threshold
277
278[16x16/stock/form]
279Size=16
280Context=Stock
281Type=Threshold
282
283[16x16/stock/generic]
284Size=16
285Context=Stock
286Type=Threshold
287
288[16x16/stock/image]
289Size=16
290Context=Stock
291Type=Threshold
292
293[16x16/stock/io]
294Size=16
295Context=Stock
296Type=Threshold
297
298[16x16/stock/media]
299Size=16
300Context=Stock
301Type=Threshold
302
303[16x16/stock/navigation]
304Size=16
305Context=Stock
306Type=Threshold
307
308[16x16/stock/net]
309Size=16
310Context=Stock
311Type=Threshold
312
313[16x16/stock/object]
314Size=16
315Context=Stock
316Type=Threshold
317
318[16x16/stock/table]
319Size=16
320Context=Stock
321Type=Threshold
322
323[16x16/stock/text]
324Size=16
325Context=Stock
326Type=Threshold
327
328[24x24/stock/chart]
329Size=24
330Context=Stock
331Type=Threshold
332
333[24x24/stock/code]
334Size=24
335Context=Stock
336Type=Threshold
337
338[24x24/stock/data]
339Size=24
340Context=Stock
341Type=Threshold
342
343[24x24/stock/document]
344Size=24
345Context=Stock
346Type=Threshold
347
348[24x24/stock/form]
349Size=24
350Context=Stock
351Type=Threshold
352
353[24x24/stock/generic]
354Size=24
355Context=Stock
356Type=Threshold
357
358[24x24/stock/image]
359Size=24
360Context=Stock
361Type=Threshold
362
363[24x24/stock/io]
364Size=24
365Context=Stock
366Type=Threshold
367
368[24x24/stock/media]
369Size=24
370Context=Stock
371Type=Threshold
372
373[24x24/stock/navigation]
374Size=24
375Context=Stock
376Type=Threshold
377
378[24x24/stock/net]
379Size=24
380Context=Stock
381Type=Threshold
382
383[24x24/stock/object]
384Size=24
385Context=Stock
386Type=Threshold
387
388[24x24/stock/table]
389Size=24
390Context=Stock
391Type=Threshold
392
393[24x24/stock/text]
394Size=24
395Context=Stock
396Type=Threshold
397
398[32x32/stock/chart]
399Size=32
400Context=Stock
401Type=Threshold
402
403[32x32/stock/code]
404Size=32
405Context=Stock
406Type=Threshold
407
408[32x32/stock/data]
409Size=32
410Context=Stock
411Type=Threshold
412
413[32x32/stock/document]
414Size=32
415Context=Stock
416Type=Threshold
417
418[32x32/stock/form]
419Size=32
420Context=Stock
421Type=Threshold
422
423[32x32/stock/generic]
424Size=32
425Context=Stock
426Type=Threshold
427
428[32x32/stock/image]
429Size=32
430Context=Stock
431Type=Threshold
432
433[32x32/stock/io]
434Size=32
435Context=Stock
436Type=Threshold
437
438[32x32/stock/media]
439Size=32
440Context=Stock
441Type=Threshold
442
443[32x32/stock/navigation]
444Size=32
445Context=Stock
446Type=Threshold
447
448[32x32/stock/net]
449Size=32
450Context=Stock
451Type=Threshold
452
453[32x32/stock/object]
454Size=32
455Context=Stock
456Type=Threshold
457
458[32x32/stock/table]
459Size=32
460Context=Stock
461Type=Threshold
462
463[32x32/stock/text]
464Size=32
465Context=Stock
466Type=Threshold
467
468[36x36/stock/chart]
469Size=36
470Context=Stock
471Type=Threshold
472
473[36x36/stock/code]
474Size=36
475Context=Stock
476Type=Threshold
477
478[36x36/stock/data]
479Size=36
480Context=Stock
481Type=Threshold
482
483[36x36/stock/document]
484Size=36
485Context=Stock
486Type=Threshold
487
488[36x36/stock/form]
489Size=36
490Context=Stock
491Type=Threshold
492
493[36x36/stock/generic]
494Size=36
495Context=Stock
496Type=Threshold
497
498[36x36/stock/image]
499Size=36
500Context=Stock
501Type=Threshold
502
503[36x36/stock/io]
504Size=36
505Context=Stock
506Type=Threshold
507
508[36x36/stock/media]
509Size=36
510Context=Stock
511Type=Threshold
512
513[36x36/stock/navigation]
514Size=36
515Context=Stock
516Type=Threshold
517
518[36x36/stock/net]
519Size=36
520Context=Stock
521Type=Threshold
522
523[36x36/stock/object]
524Size=36
525Context=Stock
526Type=Threshold
527
528[36x36/stock/table]
529Size=36
530Context=Stock
531Type=Threshold
532
533[36x36/stock/text]
534Size=36
535Context=Stock
536Type=Threshold
537
538[48x48/stock/chart]
539Size=48
540Context=Stock
541Type=Threshold
542
543[48x48/stock/code]
544Size=48
545Context=Stock
546Type=Threshold
547
548[48x48/stock/data]
549Size=48
550Context=Stock
551Type=Threshold
552
553[48x48/stock/document]
554Size=48
555Context=Stock
556Type=Threshold
557
558[48x48/stock/form]
559Size=48
560Context=Stock
561Type=Threshold
562
563[48x48/stock/generic]
564Size=48
565Context=Stock
566Type=Threshold
567
568[48x48/stock/image]
569Size=48
570Context=Stock
571Type=Threshold
572
573[48x48/stock/io]
574Size=48
575Context=Stock
576Type=Threshold
577
578[48x48/stock/media]
579Size=48
580Context=Stock
581Type=Threshold
582
583[48x48/stock/navigation]
584Size=48
585Context=Stock
586Type=Threshold
587
588[48x48/stock/net]
589Size=48
590Context=Stock
591Type=Threshold
592
593[48x48/stock/object]
594Size=48
595Context=Stock
596Type=Threshold
597
598[48x48/stock/table]
599Size=48
600Context=Stock
601Type=Threshold
602
603[48x48/stock/text]
604Size=48
605Context=Stock
606Type=Threshold
607
608[scalable/emblems]
609MinSize=1
610Size=128
611MaxSize=256
612Context=Emblems
613Type=Scalable
614
615[192x192/emblems]
616Size=192
617Context=Emblems
618Type=Threshold
619
620[96x96/emblems]
621Size=96
622Context=Emblems
623Type=Threshold
624
625[72x72/emblems]
626Size=72
627Context=Emblems
628Type=Threshold
629
630[48x48/emblems]
631Size=48
632Context=Emblems
633Type=Threshold
634
635[36x36/emblems]
636Size=36
637Context=Emblems
638Type=Threshold
639
640[24x24/emblems]
641Size=24
642Context=Emblems
643Type=Threshold
644
645[16x16/emblems]
646Size=16
647Context=Emblems
648Type=Threshold
649
650[12x12/emblems]
651Size=12
652Context=Emblems
653Type=Threshold
654