summaryrefslogtreecommitdiffstats
path: root/openembedded
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-01-18 19:08:01 +0000
committerRichard Purdie <richard@openedhand.com>2006-01-18 19:08:01 +0000
commiteeb0244d2b1f6f62b2bbc95f7b22146bb3698312 (patch)
tree9f02e904c3fcda0df5a18fb3afe9c04ba4b25680 /openembedded
parent3f4950c6c70a519c8a2ef4ce17b13188200f939f (diff)
downloadpoky-eeb0244d2b1f6f62b2bbc95f7b22146bb3698312.tar.gz
Add gconf-vfs_svn and gnome-vfs-dbus_2.8.4.4.bb from OE and add gconf-lossage patch.
git-svn-id: https://svn.o-hand.com/repos/poky@223 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded')
-rwxr-xr-xopenembedded/packages/gnome/gconf-dbus_cvs.bb14
-rw-r--r--openembedded/packages/gnome/gconf-dbus_svn.bb38
-rw-r--r--openembedded/packages/gnome/gnome-vfs-dbus/gconftool-lossage.patch11
-rw-r--r--openembedded/packages/gnome/gnome-vfs-dbus_2.8.4.4.bb91
-rwxr-xr-xopenembedded/packages/gnome/gnome-vfs-dbus_cvs.bb1
5 files changed, 147 insertions, 8 deletions
diff --git a/openembedded/packages/gnome/gconf-dbus_cvs.bb b/openembedded/packages/gnome/gconf-dbus_cvs.bb
index 39908692ec..13241bdc21 100755
--- a/openembedded/packages/gnome/gconf-dbus_cvs.bb
+++ b/openembedded/packages/gnome/gconf-dbus_cvs.bb
@@ -1,5 +1,3 @@
1DEFAULT_PREFERENCE = "-1"
2
3SECTION = "x11/utils" 1SECTION = "x11/utils"
4DEPENDS = "gtk+ glib-2.0 dbus libxml2 popt" 2DEPENDS = "gtk+ glib-2.0 dbus libxml2 popt"
5DESCRIPTION = "Settings daemon using DBUS for communication." 3DESCRIPTION = "Settings daemon using DBUS for communication."
@@ -9,19 +7,17 @@ PROVIDES = "gconf"
9RPROVIDES_${PN} = "gconf" 7RPROVIDES_${PN} = "gconf"
10RPROVIDES_${PN}-dev = "gconf-dev" 8RPROVIDES_${PN}-dev = "gconf-dev"
11 9
12PV = "0.0cvs${CVSDATE}" 10PV = "0.0+cvs${CVSDATE}"
13PR = "r6" 11PR = "r8"
14 12
15SRC_URI = "cvs://anonymous@anoncvs.gnome.org/cvs/gnome;module=gconf;tag=gconf-dbus-2-6 \ 13SRC_URI = "cvs://anonymous@anoncvs.gnome.org/cvs/gnome;module=gconf;tag=gconf-dbus-2-6 \
16 file://gconf-dbus-update.patch;patch=1;pnum=0 \ 14 file://gconf-dbus-update.patch;patch=1;pnum=0 \
17 file://69gconfd-dbus" 15 file://69gconfd-dbus"
18 16
19FILES_${PN} += " ${libdir}/GConf/2/*.so ${libdir}/dbus-1.0 ${sysconfdir}" 17inherit pkgconfig autotools
20
21S = "${WORKDIR}/gconf" 18S = "${WORKDIR}/gconf"
22 19
23 20FILES_${PN} += " ${libdir}/GConf/2/*.so ${libdir}/dbus-1.0 ${sysconfdir} ${datadir}/dbus*"
24inherit pkgconfig autotools
25 21
26EXTRA_OECONF = " --with-ipc=dbus --disable-gtk-doc --enable-gtk --host=${HOST_SYS} --enable-shared --disable-static" 22EXTRA_OECONF = " --with-ipc=dbus --disable-gtk-doc --enable-gtk --host=${HOST_SYS} --enable-shared --disable-static"
27 23
@@ -37,4 +33,6 @@ do_stage() {
37do_install_append () { 33do_install_append () {
38 install -d ${D}/${sysconfdir}/X11/Xsession.d 34 install -d ${D}/${sysconfdir}/X11/Xsession.d
39 install -m 755 ${WORKDIR}/69gconfd-dbus ${D}/${sysconfdir}/X11/Xsession.d/ 35 install -m 755 ${WORKDIR}/69gconfd-dbus ${D}/${sysconfdir}/X11/Xsession.d/
36 install -d ${D}/${datadir}/dbus-1.0/services/
37 install -m 644 gconf/gconf.service ${D}${datadir}/dbus-1.0/services/
40} 38}
diff --git a/openembedded/packages/gnome/gconf-dbus_svn.bb b/openembedded/packages/gnome/gconf-dbus_svn.bb
new file mode 100644
index 0000000000..675b655412
--- /dev/null
+++ b/openembedded/packages/gnome/gconf-dbus_svn.bb
@@ -0,0 +1,38 @@
1SECTION = "x11/utils"
2DEPENDS = "gtk+ glib-2.0 dbus libxml2 popt"
3DESCRIPTION = "Settings daemon using DBUS for communication."
4LICENSE = "GPL"
5MAINTAINER = "Florian Boor <florian@kernelconcepts.de>"
6PROVIDES = "gconf"
7RPROVIDES_${PN} = "gconf"
8RPROVIDES_${PN}-dev = "gconf-dev"
9
10PV = "0.0+svn${CVSDATE}"
11PR = "r0"
12
13SRC_URI = "svn://developer.imendio.com/svn/gconf-dbus;module=trunk;proto=http \
14 file://gconf-dbus-update.patch;patch=1;pnum=0 \
15 file://69gconfd-dbus"
16
17inherit pkgconfig autotools
18S = "${WORKDIR}/trunk"
19
20FILES_${PN} += " ${libdir}/GConf/2/*.so ${libdir}/dbus-1.0 ${sysconfdir} ${datadir}/dbus*"
21
22EXTRA_OECONF = " --with-ipc=dbus --disable-gtk-doc --enable-gtk --host=${HOST_SYS} --enable-shared --disable-static"
23
24HEADERS = "gconf.h gconf-changeset.h gconf-listeners.h gconf-schema.h gconf-value.h gconf-error.h gconf-engine.h gconf-client.h gconf-enum-types.h"
25
26do_stage() {
27 oe_libinstall -so -C gconf libgconf-2 ${STAGING_LIBDIR}
28 install -d ${STAGING_INCDIR}/gconf/2/gconf/
29 ( cd gconf; for i in ${HEADERS}; do install -m 0644 $i ${STAGING_INCDIR}/gconf/2/gconf/$i; done )
30 install -m 0644 gconf.m4 ${STAGING_DATADIR}/aclocal/gconf-2.m4
31}
32
33do_install_append () {
34 install -d ${D}/${sysconfdir}/X11/Xsession.d
35 install -m 755 ${WORKDIR}/69gconfd-dbus ${D}/${sysconfdir}/X11/Xsession.d/
36 install -d ${D}/${datadir}/dbus-1.0/services/
37 install -m 644 gconf/gconf.service ${D}${datadir}/dbus-1.0/services/
38}
diff --git a/openembedded/packages/gnome/gnome-vfs-dbus/gconftool-lossage.patch b/openembedded/packages/gnome/gnome-vfs-dbus/gconftool-lossage.patch
new file mode 100644
index 0000000000..3dbc130ddc
--- /dev/null
+++ b/openembedded/packages/gnome/gnome-vfs-dbus/gconftool-lossage.patch
@@ -0,0 +1,11 @@
1--- gnome-vfs-2.6.0/configure.in~ 2004-03-22 12:36:23.000000000 +0000
2+++ gnome-vfs-2.6.0/configure.in 2004-06-07 16:04:34.000000000 +0100
3@@ -154,7 +154,7 @@
4 AC_PATH_PROG(GCONFTOOL, gconftool-2, no)
5
6 if test x"$GCONFTOOL" = xno; then
7- AC_MSG_ERROR([gconftool-2 executable not found in your path - should be installed with GConf])
8+ AC_MSG_WARN([gconftool-2 executable not found in your path - should be installed with GConf])
9 fi
10
11 AM_GCONF_SOURCE_2
diff --git a/openembedded/packages/gnome/gnome-vfs-dbus_2.8.4.4.bb b/openembedded/packages/gnome/gnome-vfs-dbus_2.8.4.4.bb
new file mode 100644
index 0000000000..4f2a861eb2
--- /dev/null
+++ b/openembedded/packages/gnome/gnome-vfs-dbus_2.8.4.4.bb
@@ -0,0 +1,91 @@
1LICENSE = "GPL"
2SECTION = "x11/gnome"
3PR = "r1"
4PROVIDES = "gnome-vfs"
5RPROVIDES = "gnome-vfs"
6
7inherit gnome pkgconfig
8
9DEPENDS = "libxml2 gconf-dbus dbus bzip2 gnome-mime-data zlib samba-3.0.14a"
10RRECOMMENDS = "gnome-vfs-plugin-file shared-mime-info"
11
12
13SRC_URI = "http://ftp.imendio.com/pub/extra/${PN}/${PN}-${PV}.tar.gz \
14 file://gssapi.patch;patch=1;pnum=1 \
15 file://gconftool-lossage.patch;patch=1;pnum=1"
16
17EXTRA_OECONF = "--with-ipc=dbus"
18
19FILES_${PN} += " ${libdir}/vfs"
20FILES_${PN}-dev += " ${libdir}/gnome-vfs-2.0/modules/*.a ${libdir}/gnome-vfs-2.0/modules/*.la ${libdir}/gnome-vfs-2.0/include"
21FILES_${PN}-doc += " ${datadir}/gtk-doc"
22
23GNOME_VFS_HEADERS = " \
24gnome-vfs-utils.h \
25gnome-vfs-application-registry.h \
26gnome-vfs-async-ops.h \
27gnome-vfs-ops.h \
28gnome-vfs-uri.h \
29gnome-vfs-standard-callbacks.h \
30gnome-vfs-module-callback.h \
31gnome-vfs-context.h \
32gnome-vfs-file-info.h \
33gnome-vfs-directory.h \
34gnome-vfs-mime-monitor.h \
35gnome-vfs-mime-handlers.h \
36gnome-vfs-result.h \
37gnome-vfs-job-limit.h \
38gnome-vfs-file-size.h \
39gnome-vfs-mime-utils.h \
40gnome-vfs-find-directory.h \
41gnome-vfs-init.h \
42gnome-vfs-handle.h \
43gnome-vfs.h \
44gnome-vfs-cancellation.h \
45gnome-vfs-xfer.h \
46gnome-vfs-monitor.h \
47gnome-vfs-types.h \
48gnome-vfs-volume-monitor.h \
49gnome-vfs-drive.h \
50gnome-vfs-volume.h \
51gnome-vfs-enum-types.h \
52gnome-vfs-address.h \
53gnome-vfs-dns-sd.h \
54gnome-vfs-mime-info-cache.h \
55gnome-vfs-resolve.h"
56
57GNOME_VFS_MODULE_HEADERS = " \
58gnome-vfs-mime-info.h \
59gnome-vfs-transform.h \
60gnome-vfs-ssl.h \
61gnome-vfs-inet-connection.h \
62gnome-vfs-socket.h \
63gnome-vfs-parse-ls.h \
64gnome-vfs-method.h \
65gnome-vfs-cancellable-ops.h \
66gnome-vfs-module.h \
67gnome-vfs-module-shared.h \
68gnome-vfs-module-callback-module-api.h \
69gnome-vfs-mime.h \
70gnome-vfs-socket-buffer.h"
71
72do_stage() {
73 oe_libinstall -so -C libgnomevfs libgnomevfs-2 ${STAGING_LIBDIR}
74 install -d ${STAGING_INCDIR}/gnome-vfs-2.0/libgnomevfs
75 for i in ${GNOME_VFS_HEADERS}; do install -m 0644 libgnomevfs/$i ${STAGING_INCDIR}/gnome-vfs-2.0/libgnomevfs/; done
76 install -d ${STAGING_INCDIR}/gnome-vfs-module-2.0/libgnomevfs
77 for i in ${GNOME_VFS_MODULE_HEADERS}; do install -m 0644 libgnomevfs/$i ${STAGING_INCDIR}/gnome-vfs-module-2.0/libgnomevfs/; done
78}
79
80do_install() {
81 oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}" DESTDIR="${D}" install
82}
83
84PACKAGES_DYNAMIC = "gnome=vfs-plugin-*"
85
86python populate_packages_prepend () {
87 print bb.data.getVar('FILES_gnome-vfs', d, 1)
88
89 plugindir = bb.data.expand('${libdir}/gnome-vfs-2.0/modules/', d)
90 do_split_packages(d, plugindir, '^lib(.*)\.so$', 'gnome-vfs-plugin-%s', 'GNOME VFS plugin for %s')
91}
diff --git a/openembedded/packages/gnome/gnome-vfs-dbus_cvs.bb b/openembedded/packages/gnome/gnome-vfs-dbus_cvs.bb
index 244f6516f2..87def47a2d 100755
--- a/openembedded/packages/gnome/gnome-vfs-dbus_cvs.bb
+++ b/openembedded/packages/gnome/gnome-vfs-dbus_cvs.bb
@@ -15,6 +15,7 @@ PR = "r4"
15 15
16SRC_URI = "svn://anonymous@developer.imendio.com/svn/gnome-vfs-dbus;module=trunk;proto=http \ 16SRC_URI = "svn://anonymous@developer.imendio.com/svn/gnome-vfs-dbus;module=trunk;proto=http \
17 file://no-gtk-doc.patch;patch=1 \ 17 file://no-gtk-doc.patch;patch=1 \
18 file://gconftool-lossage.patch;patch=1 \
18 file://gssapi.patch;patch=1" 19 file://gssapi.patch;patch=1"
19S = "${WORKDIR}/trunk" 20S = "${WORKDIR}/trunk"
20 21