summaryrefslogtreecommitdiffstats
path: root/openembedded
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-02-07 11:06:51 +0000
committerRichard Purdie <richard@openedhand.com>2006-02-07 11:06:51 +0000
commitd452ba2aa0d7f404dcbc725bca91914a9db2d438 (patch)
treec0293c4af37e0c1748fb9a4f3e315a0297698c79 /openembedded
parent4fbba6350edd17d9272a668b5ba564f558974a94 (diff)
downloadpoky-d452ba2aa0d7f404dcbc725bca91914a9db2d438.tar.gz
Add lsof
git-svn-id: https://svn.o-hand.com/repos/poky@252 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded')
-rw-r--r--openembedded/packages/lsof/lsof_4.75.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/openembedded/packages/lsof/lsof_4.75.bb b/openembedded/packages/lsof/lsof_4.75.bb
new file mode 100644
index 0000000000..7c1bba3b6c
--- /dev/null
+++ b/openembedded/packages/lsof/lsof_4.75.bb
@@ -0,0 +1,38 @@
1SECTION = "console/utils"
2DESCRIPTION = "Lsof is a Unix-specific diagnostic \
3tool. Its name stands for LiSt Open Files, and it \
4does just that."
5LICENSE = "BSD"
6
7SRC_URI = "ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/lsof_${PV}.tar.bz2"
8LOCALSRC = "file://${WORKDIR}/lsof_${PV}/lsof_${PV}_src.tar"
9S = "${WORKDIR}/lsof_${PV}_src"
10
11python do_unpack () {
12 bb.build.exec_func('base_do_unpack', d)
13 src_uri = bb.data.getVar('SRC_URI', d)
14 bb.data.setVar('SRC_URI', '${LOCALSRC}', d)
15 bb.build.exec_func('base_do_unpack', d)
16 bb.data.setVar('SRC_URI', src_uri, d)
17}
18
19LSOF_OS = "${TARGET_OS}"
20LSOF_OS_linux-uclibc = "linux"
21
22do_configure () {
23 ./Configure ${LSOF_OS}
24}
25
26export I = "${STAGING_INCDIR}"
27export L = "${STAGING_INCDIR}"
28export EXTRA_OEMAKE = ""
29
30do_compile () {
31 oe_runmake 'CC=${CC}' 'CFGL=${LDFLAGS} -L./lib -llsof' 'DEBUG=' 'INCL=${CFLAGS}'
32}
33
34do_install () {
35 install -d ${D}${sbindir} ${D}${mandir}/man8
36 install -m 4755 lsof ${D}${sbindir}/lsof
37 install -m 0644 lsof.8 ${D}${mandir}/man8/lsof.8
38}