summaryrefslogtreecommitdiffstats
path: root/openembedded
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2006-01-26 15:17:51 +0000
committerRoss Burton <ross@openedhand.com>2006-01-26 15:17:51 +0000
commit6c96daa682afd66d1c18f7107821f0a1825cd4f8 (patch)
treeb44bf936355cd4a5e28fa59eda3a26125fe2a925 /openembedded
parent88565a78e152fe96cafaf1173ffbfb23fde07e35 (diff)
downloadpoky-6c96daa682afd66d1c18f7107821f0a1825cd4f8.tar.gz
Take patch from upstream to check Xlib instead of Xt for X presence
git-svn-id: https://svn.o-hand.com/repos/poky@239 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded')
-rw-r--r--openembedded/packages/autoconf/autoconf-2.59/autoconf-x.patch35
-rw-r--r--openembedded/packages/autoconf/autoconf_2.59.bb3
2 files changed, 37 insertions, 1 deletions
diff --git a/openembedded/packages/autoconf/autoconf-2.59/autoconf-x.patch b/openembedded/packages/autoconf/autoconf-2.59/autoconf-x.patch
new file mode 100644
index 0000000000..983869320d
--- /dev/null
+++ b/openembedded/packages/autoconf/autoconf-2.59/autoconf-x.patch
@@ -0,0 +1,35 @@
1Index: lib/autoconf/libs.m4
2===================================================================
3RCS file: /cvsroot/autoconf/autoconf/lib/autoconf/libs.m4,v
4retrieving revision 1.13
5diff -p -u -r1.13 libs.m4
6--- autoconf-2.59/lib/autoconf/libs.m4 6 Sep 2005 15:34:06 -0000 1.13
7+++ autoconf-2.59/lib/autoconf/libs.m4 18 Sep 2005 17:09:58 -0000
8@@ -265,13 +265,13 @@ ac_x_header_dirs='
9 /usr/openwin/share/include'
10
11 if test "$ac_x_includes" = no; then
12- # Guess where to find include files, by looking for Intrinsic.h.
13+ # Guess where to find include files, by looking for Xlib.h.
14 # First, try using that file with no special directory specified.
15- AC_PREPROC_IFELSE([AC_LANG_SOURCE([@%:@include <X11/Intrinsic.h>])],
16+ AC_PREPROC_IFELSE([AC_LANG_SOURCE([@%:@include <X11/Xlib.h>])],
17 [# We can compile using X headers with no special include directory.
18 ac_x_includes=],
19 [for ac_dir in $ac_x_header_dirs; do
20- if test -r "$ac_dir/X11/Intrinsic.h"; then
21+ if test -r "$ac_dir/X11/Xlib.h"; then
22 ac_x_includes=$ac_dir
23 break
24 fi
25@@ -284,7 +284,7 @@ if test "$ac_x_libraries" = no; then
26 # Don't add to $LIBS permanently.
27 ac_save_LIBS=$LIBS
28 LIBS="-lXt $LIBS"
29- AC_LINK_IFELSE([AC_LANG_PROGRAM([@%:@include <X11/Intrinsic.h>],
30- [XtMalloc (0)])],
31+ AC_LINK_IFELSE([AC_LANG_PROGRAM([@%:@include <X11/Xlib.h>],
32+ [XrmInitialize ()])],
33 [LIBS=$ac_save_LIBS
34 # We can link X programs with no special library path.
35 ac_x_libraries=], \ No newline at end of file
diff --git a/openembedded/packages/autoconf/autoconf_2.59.bb b/openembedded/packages/autoconf/autoconf_2.59.bb
index 8636a77787..3cc962da01 100644
--- a/openembedded/packages/autoconf/autoconf_2.59.bb
+++ b/openembedded/packages/autoconf/autoconf_2.59.bb
@@ -6,7 +6,7 @@ SECTION = "devel"
6DEPENDS += "m4-native" 6DEPENDS += "m4-native"
7RDEPENDS_${PN} = "m4 gnu-config" 7RDEPENDS_${PN} = "m4 gnu-config"
8RRECOMMENDS_${PN} = "automake" 8RRECOMMENDS_${PN} = "automake"
9PR = "r3" 9PR = "r4"
10 10
11SRC_URI = "${GNU_MIRROR}/autoconf/autoconf-${PV}.tar.bz2 \ 11SRC_URI = "${GNU_MIRROR}/autoconf/autoconf-${PV}.tar.bz2 \
12 file://program_prefix.patch;patch=1 \ 12 file://program_prefix.patch;patch=1 \
@@ -17,5 +17,6 @@ SRC_URI = "${GNU_MIRROR}/autoconf/autoconf-${PV}.tar.bz2 \
17 file://autoconf259-update-configscripts.patch;patch=1 \ 17 file://autoconf259-update-configscripts.patch;patch=1 \
18 file://autoheader-nonfatal-warnings.patch;patch=1 \ 18 file://autoheader-nonfatal-warnings.patch;patch=1 \
19 file://sizeof_types.patch;patch=1 \ 19 file://sizeof_types.patch;patch=1 \
20 file://autoconf-x.patch;patch=1 \
20 ${@['file://path_prog_fixes.patch;patch=1', ''][bb.data.inherits_class('native', d)]}" 21 ${@['file://path_prog_fixes.patch;patch=1', ''][bb.data.inherits_class('native', d)]}"
21inherit autotools 22inherit autotools