summaryrefslogtreecommitdiffstats
path: root/openembedded
diff options
context:
space:
mode:
authorChris Lord <chris@openedhand.com>2006-01-31 22:12:56 +0000
committerChris Lord <chris@openedhand.com>2006-01-31 22:12:56 +0000
commit27700c91dd31d47332e6533241982d856772e08b (patch)
tree78f4d0cefb8d81089ffb8b09040fd91e433a9763 /openembedded
parent96c29fa222fa7ca6d530fb636d1477325f39d4b5 (diff)
downloadpoky-27700c91dd31d47332e6533241982d856772e08b.tar.gz
Fix db 4.1.25 building with eds-dbus, breaks db3/db4 co-existence
git-svn-id: https://svn.o-hand.com/repos/poky@244 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded')
-rw-r--r--openembedded/packages/db/db_4.1.25.bb20
1 files changed, 5 insertions, 15 deletions
diff --git a/openembedded/packages/db/db_4.1.25.bb b/openembedded/packages/db/db_4.1.25.bb
index 168dde478d..381c69a616 100644
--- a/openembedded/packages/db/db_4.1.25.bb
+++ b/openembedded/packages/db/db_4.1.25.bb
@@ -12,7 +12,7 @@ SECTION = "libs"
12DESCRIPTION = "Berkeley DB v4." 12DESCRIPTION = "Berkeley DB v4."
13HOMEPAGE = "http://www.sleepycat.com" 13HOMEPAGE = "http://www.sleepycat.com"
14LICENSE = "BSD Sleepycat" 14LICENSE = "BSD Sleepycat"
15PR = "r1" 15PR = "r2"
16 16
17SRC_URI = "http://downloads.sleepycat.com/${P}.tar.gz" 17SRC_URI = "http://downloads.sleepycat.com/${P}.tar.gz"
18 18
@@ -36,7 +36,7 @@ S = "${WORKDIR}/${P}/build_unix"
36PACKAGES += " ${PN}-bin" 36PACKAGES += " ${PN}-bin"
37 37
38# Package contents 38# Package contents
39FILES_${PN} = "${libdir}/libdb-4*so*" 39FILES_${PN} = "${libdir}/libdb*so*"
40FILES_${PN}-bin = "${bindir}" 40FILES_${PN}-bin = "${bindir}"
41# The dev package has the .so link (as in db3) and the .a's - 41# The dev package has the .so link (as in db3) and the .a's -
42# it is therefore incompatible (cannot be installed at the 42# it is therefore incompatible (cannot be installed at the
@@ -68,20 +68,10 @@ do_configure() {
68} 68}
69 69
70do_stage() { 70do_stage() {
71 # The .h files get installed read-only, the autostage 71 oe_runmake DESTDIR="${STAGING_DIR}/${BUILD_SYS}" includedir="${STAGING_INCDIR}" install_include
72 # function just uses cp -pPR, so do this by hand
73 # Install, for the moment, into include/db4 to avoid
74 # interfering with the db3 headers (which have the same
75 # name). -I${STAGING_INCDIR}/db4 to use db4, as opposed
76 # to db3
77
78 rm -rf ${STAGE_TEMP}
79 mkdir -p ${STAGE_TEMP}
80 oe_runmake DESTDIR="${STAGE_TEMP}" includedir="${STAGE_TEMP}${includedir}" install_include
81 mkdir -p ${STAGING_INCDIR}/db4
82 cp -pPRf ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}/db4
83 rm -rf ${STAGE_TEMP}
84 oe_libinstall -so -C .libs libdb-4.1 ${STAGING_LIBDIR} 72 oe_libinstall -so -C .libs libdb-4.1 ${STAGING_LIBDIR}
73 ln -s ${STAGING_LIBDIR}/libdb-4.1.so ${STAGING_LIBDIR}/libdb-4.so
74 ln -s ${STAGING_LIBDIR}/libdb-4.so ${STAGING_LIBDIR}/libdb.so
85} 75}
86 76
87do_install() { 77do_install() {