summaryrefslogtreecommitdiffstats
path: root/openembedded
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-07-06 07:42:46 +0000
committerRichard Purdie <richard@openedhand.com>2006-07-06 07:42:46 +0000
commit0c5090c9bb40379698e6d54396442034155861c6 (patch)
tree31a393a61bcd393dd8979c0c6addb783c3fa11ea /openembedded
parente1e63224d9bd7b25a18b435ee5b7e543368fe117 (diff)
downloadpoky-0c5090c9bb40379698e6d54396442034155861c6.tar.gz
glib 2.10: Init gatomic before gconvert, fixing crashes on ARM
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@505 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded')
-rw-r--r--openembedded/packages/glib-2.0/files/atomic_fix.patch16
-rw-r--r--openembedded/packages/glib-2.0/glib-2.0-native_2.10.3.bb4
-rw-r--r--openembedded/packages/glib-2.0/glib-2.0_2.10.3.bb3
3 files changed, 21 insertions, 2 deletions
diff --git a/openembedded/packages/glib-2.0/files/atomic_fix.patch b/openembedded/packages/glib-2.0/files/atomic_fix.patch
new file mode 100644
index 0000000000..ddc7ada778
--- /dev/null
+++ b/openembedded/packages/glib-2.0/files/atomic_fix.patch
@@ -0,0 +1,16 @@
1Index: glib-2.10.3/glib/gthread.c
2===================================================================
3--- glib-2.10.3.orig/glib/gthread.c 2005-12-01 16:34:26.000000000 +0000
4+++ glib-2.10.3/glib/gthread.c 2006-07-06 08:17:18.000000000 +0100
5@@ -164,10 +164,10 @@
6 _g_messages_thread_init_nomessage ();
7
8 /* we may run full-fledged initializers from here */
9+ _g_atomic_thread_init ();
10 _g_convert_thread_init ();
11 _g_rand_thread_init ();
12 _g_main_thread_init ();
13- _g_atomic_thread_init ();
14 _g_utils_thread_init ();
15 #ifdef G_OS_WIN32
16 _g_win32_thread_init ();
diff --git a/openembedded/packages/glib-2.0/glib-2.0-native_2.10.3.bb b/openembedded/packages/glib-2.0/glib-2.0-native_2.10.3.bb
index d0a442eeef..402ec2d390 100644
--- a/openembedded/packages/glib-2.0/glib-2.0-native_2.10.3.bb
+++ b/openembedded/packages/glib-2.0/glib-2.0-native_2.10.3.bb
@@ -7,11 +7,13 @@ LICENSE = "LGPL"
7SECTION = "libs" 7SECTION = "libs"
8PRIORITY = "optional" 8PRIORITY = "optional"
9DEPENDS += "gtk-doc-native" 9DEPENDS += "gtk-doc-native"
10PR="r1"
10 11
11EXTRA_OECONF = "--disable-debug" 12EXTRA_OECONF = "--disable-debug"
12 13
13SRC_URI = "http://download.gnome.org/sources/glib/2.10//glib-${PV}.tar.bz2 \ 14SRC_URI = "http://download.gnome.org/sources/glib/2.10//glib-${PV}.tar.bz2 \
14 file://glib-gettextize-dir.patch;patch=1 \ 15 file://glib-gettextize-dir.patch;patch=1 \
16 file://atomic_fix.patch;patch=1 \
15 file://glibconfig-sysdefs.h" 17 file://glibconfig-sysdefs.h"
16 18
17S = "${WORKDIR}/glib-${PV}" 19S = "${WORKDIR}/glib-${PV}"
diff --git a/openembedded/packages/glib-2.0/glib-2.0_2.10.3.bb b/openembedded/packages/glib-2.0/glib-2.0_2.10.3.bb
index 1c887e0206..df0f3bd82c 100644
--- a/openembedded/packages/glib-2.0/glib-2.0_2.10.3.bb
+++ b/openembedded/packages/glib-2.0/glib-2.0_2.10.3.bb
@@ -9,7 +9,7 @@ PRIORITY = "optional"
9DEPENDS += "glib-2.0-native gtk-doc" 9DEPENDS += "glib-2.0-native gtk-doc"
10DEPENDS += "virtual/libiconv virtual/libintl" 10DEPENDS += "virtual/libiconv virtual/libintl"
11PACKAGES =+ "glib-2.0-utils " 11PACKAGES =+ "glib-2.0-utils "
12PR = "r1" 12PR = "r3"
13 13
14LEAD_SONAME = "libglib-2.0.*" 14LEAD_SONAME = "libglib-2.0.*"
15FILES_glib-2.0-utils = "${bindir}/*" 15FILES_glib-2.0-utils = "${bindir}/*"
@@ -17,6 +17,7 @@ FILES_glib-2.0-utils = "${bindir}/*"
17EXTRA_OECONF = "--disable-debug" 17EXTRA_OECONF = "--disable-debug"
18 18
19SRC_URI = "http://download.gnome.org/sources/glib/2.10//glib-${PV}.tar.bz2 \ 19SRC_URI = "http://download.gnome.org/sources/glib/2.10//glib-${PV}.tar.bz2 \
20 file://atomic_fix.patch;patch=1 \
20 file://glibconfig-sysdefs.h" 21 file://glibconfig-sysdefs.h"
21 22
22S = "${WORKDIR}/glib-${PV}" 23S = "${WORKDIR}/glib-${PV}"