summaryrefslogtreecommitdiffstats
path: root/openembedded
diff options
context:
space:
mode:
authorJorn Baayen <jorn@openedhand.com>2006-07-20 10:52:14 +0000
committerJorn Baayen <jorn@openedhand.com>2006-07-20 10:52:14 +0000
commit36a71a9c620e4a9510725af3a9e731e6529f744c (patch)
treef3ce138e2cf816162683f132f0b3e6542c800799 /openembedded
parent8d907891ad89863d2d2c2b2081d394e536ebbfd5 (diff)
downloadpoky-36a71a9c620e4a9510725af3a9e731e6529f744c.tar.gz
added pango 1.13.3
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@518 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded')
-rw-r--r--openembedded/packages/pango/pango_1.13.3.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/openembedded/packages/pango/pango_1.13.3.bb b/openembedded/packages/pango/pango_1.13.3.bb
new file mode 100644
index 0000000000..de6346b1cb
--- /dev/null
+++ b/openembedded/packages/pango/pango_1.13.3.bb
@@ -0,0 +1,49 @@
1LICENSE = "LGPL"
2SECTION = "x11/libs"
3# Xt needed to keep autoconf's check for X11 happy
4DEPENDS = "glib-2.0 fontconfig freetype zlib libx11 libxft libxt gtk-doc cairo"
5DESCRIPTION = "The goal of the Pango project is to provide an \
6Open Source framework for the layout and rendering of \
7internationalized text."
8PR = "r0"
9
10# seems to go wrong with default cflags
11FULL_OPTIMIZATION_arm = "-O2"
12
13SRC_URI = "http://download.gnome.org/sources/pango/1.13/pango-${PV}.tar.bz2 \
14 file://no-tests.patch;patch=1"
15
16inherit autotools pkgconfig
17
18EXTRA_OECONF = "--disable-glibtest \
19 --enable-explicit-deps=no \
20 --disable-debug"
21
22FILES_${PN} = "/etc ${bindir} ${libdir}/libpango*.so.*"
23
24LIBV = "1.5.0"
25
26do_stage () {
27 for lib in pango pangox pangoft2 pangoxft pangocairo; do
28 oe_libinstall -so -C pango lib$lib-1.0 ${STAGING_LIBDIR}/
29 done
30 install -d ${STAGING_INCDIR}/pango
31 install -m 0644 ${S}/pango/pango*.h ${STAGING_INCDIR}/pango/
32}
33
34postinst_prologue() {
35if [ "x$D" != "x" ]; then
36 exit 1
37fi
38
39}
40
41PACKAGES_DYNAMIC = "pango-module-*"
42
43python populate_packages_prepend () {
44 prologue = bb.data.getVar("postinst_prologue", d, 1)
45
46 modules_root = bb.data.expand('${libdir}/pango/${LIBV}/modules', d)
47
48 do_split_packages(d, modules_root, '^pango-(.*)\.so$', 'pango-module-%s', 'Pango module %s', prologue + 'pango-querymodules > /etc/pango/pango.modules')
49}