summaryrefslogtreecommitdiffstats
path: root/openembedded/packages
diff options
context:
space:
mode:
authorChris Lord <chris@openedhand.com>2005-10-03 23:40:20 +0000
committerChris Lord <chris@openedhand.com>2005-10-03 23:40:20 +0000
commitc9b9b5bbbd5a8081740d319c15f3f1cebd0c4921 (patch)
tree48329440a7a496062fc2a38b862d37b0c5f7a7ab /openembedded/packages
parent2b873fefd4be7229e44ca7d55c5ebbea2d0feb76 (diff)
downloadpoky-c9b9b5bbbd5a8081740d319c15f3f1cebd0c4921.tar.gz
Add leafpad, a simple gtk text-editor
git-svn-id: https://svn.o-hand.com/repos/poky@112 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages')
-rw-r--r--openembedded/packages/leafpad/files/leafpad.desktop11
-rw-r--r--openembedded/packages/leafpad/files/leafpad.pngbin0 -> 1950 bytes
-rw-r--r--openembedded/packages/leafpad/leafpad_0.8.4.bb20
3 files changed, 31 insertions, 0 deletions
diff --git a/openembedded/packages/leafpad/files/leafpad.desktop b/openembedded/packages/leafpad/files/leafpad.desktop
new file mode 100644
index 0000000000..7c75817128
--- /dev/null
+++ b/openembedded/packages/leafpad/files/leafpad.desktop
@@ -0,0 +1,11 @@
1[Desktop Entry]
2Encoding=UTF-8
3Name=Leafpad
4Exec=/usr/bin/leafpad
5Icon=leafpad.png
6Terminal=false
7Type=Application
8Categories=Utility;PIM;
9SingleInstance=true
10StartupNotify=true
11
diff --git a/openembedded/packages/leafpad/files/leafpad.png b/openembedded/packages/leafpad/files/leafpad.png
new file mode 100644
index 0000000000..c5ee0cff85
--- /dev/null
+++ b/openembedded/packages/leafpad/files/leafpad.png
Binary files differ
diff --git a/openembedded/packages/leafpad/leafpad_0.8.4.bb b/openembedded/packages/leafpad/leafpad_0.8.4.bb
new file mode 100644
index 0000000000..6faabec514
--- /dev/null
+++ b/openembedded/packages/leafpad/leafpad_0.8.4.bb
@@ -0,0 +1,20 @@
1LICENSE = "GPLv2"
2DEPENDS = "gtk+"
3SRC_URI = "http://savannah.nongnu.org/download/${PN}/${PN}-${PV}.tar.gz \
4 file://leafpad.desktop \
5 file://leafpad.png"
6
7inherit autotools pkgconfig
8
9EXTRA_OECONF = " --enable-chooser --disable-gtktest --disable-print"
10
11do_install_append () {
12 install -d ${D}/${datadir}
13 install -d ${D}/${datadir}/applications
14 install -d ${D}/${datadir}/pixmaps/
15
16 install -m 0644 ${WORKDIR}/leafpad.png ${D}/${datadir}/pixmaps
17 install -m 0644 ${WORKDIR}/leafpad.desktop ${D}/${datadir}/applications
18}
19
20FILES_${PN} += "${datadir}/applications/leafpad.desktop ${datadir}/pixmaps/leafpad.png"