summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/mpfr
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-11-16 16:23:23 +0000
committerRichard Purdie <richard@openedhand.com>2005-11-16 16:23:23 +0000
commite5ba6f2e4424ea4b8baa39bfaec6ab01b7b66861 (patch)
tree9a1703625d50df42136931ab7a5cb042cd5760b3 /openembedded/packages/mpfr
parent1a5f0fedce5084690bb478a302d7dd326198afee (diff)
downloadpoky-e5ba6f2e4424ea4b8baa39bfaec6ab01b7b66861.tar.gz
Add gmp and mpfr (needed by gcc 4.0.2)
git-svn-id: https://svn.o-hand.com/repos/poky@183 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/mpfr')
-rw-r--r--openembedded/packages/mpfr/mpfr-native_2.1.1.bb4
-rw-r--r--openembedded/packages/mpfr/mpfr_2.1.1.bb19
2 files changed, 23 insertions, 0 deletions
diff --git a/openembedded/packages/mpfr/mpfr-native_2.1.1.bb b/openembedded/packages/mpfr/mpfr-native_2.1.1.bb
new file mode 100644
index 0000000000..119249895d
--- /dev/null
+++ b/openembedded/packages/mpfr/mpfr-native_2.1.1.bb
@@ -0,0 +1,4 @@
1include mpfr_${PV}.bb
2inherit native
3DEPENDS = "gmp-native"
4
diff --git a/openembedded/packages/mpfr/mpfr_2.1.1.bb b/openembedded/packages/mpfr/mpfr_2.1.1.bb
new file mode 100644
index 0000000000..8b739c0803
--- /dev/null
+++ b/openembedded/packages/mpfr/mpfr_2.1.1.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "A C library for multiple-precision floating-point computations with exact rounding"
2LICENSE = "LGPL"
3MAINTAINER = "Rene Wagner <rw@handhelds.org>"
4SECTION = "libs"
5DEPENDS = "gmp"
6PR = "r1"
7
8SRC_URI = "http://www.mpfr.org/mpfr-${PV}/mpfr-${PV}.tar.bz2"
9S = "${WORKDIR}/mpfr-${PV}"
10
11inherit autotools
12
13do_stage() {
14 oe_runmake install prefix=${STAGING_DIR} \
15 bindir=${STAGING_BINDIR} \
16 includedir=${STAGING_INCDIR} \
17 libdir=${STAGING_LIBDIR} \
18 datadir=${STAGING_DATADIR}
19}