diff options
author | Richard Purdie <richard@openedhand.com> | 2005-08-31 10:45:47 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2005-08-31 10:45:47 +0000 |
commit | 4b46c1f6e891b1ddd5968536440b888661fade3e (patch) | |
tree | e0ba2c1f56f61b868bf746da5c4feabb25b800b2 /openembedded/packages/flex | |
download | poky-4b46c1f6e891b1ddd5968536440b888661fade3e.tar.gz |
Initial population
git-svn-id: https://svn.o-hand.com/repos/poky@1 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/flex')
-rw-r--r-- | openembedded/packages/flex/files/fix-gen.patch | 17 | ||||
-rw-r--r-- | openembedded/packages/flex/flex-2.5.31/include.patch | 27 | ||||
-rw-r--r-- | openembedded/packages/flex/flex-native_2.5.31.bb | 10 | ||||
-rw-r--r-- | openembedded/packages/flex/flex.inc | 10 | ||||
-rw-r--r-- | openembedded/packages/flex/flex_2.5.31.bb | 9 |
5 files changed, 73 insertions, 0 deletions
diff --git a/openembedded/packages/flex/files/fix-gen.patch b/openembedded/packages/flex/files/fix-gen.patch new file mode 100644 index 0000000000..55f4f6fdf5 --- /dev/null +++ b/openembedded/packages/flex/files/fix-gen.patch | |||
@@ -0,0 +1,17 @@ | |||
1 | |||
2 | # | ||
3 | # Patch managed by http://www.holgerschurig.de/patcher.html | ||
4 | # | ||
5 | |||
6 | --- flex-2.5.31/gen.c~fix-gen | ||
7 | +++ flex-2.5.31/gen.c | ||
8 | @@ -1812,8 +1812,7 @@ | ||
9 | if (yytext_is_array) { | ||
10 | if (!reentrant){ | ||
11 | indent_puts ("static int yy_more_offset = 0;"); | ||
12 | - }else{ | ||
13 | - indent_puts ("static int yy_prev_more_offset = 0;"); | ||
14 | + indent_puts ("static int yy_prev_more_offset = 0;"); | ||
15 | } | ||
16 | } | ||
17 | else if (!reentrant) { | ||
diff --git a/openembedded/packages/flex/flex-2.5.31/include.patch b/openembedded/packages/flex/flex-2.5.31/include.patch new file mode 100644 index 0000000000..b60dcb29de --- /dev/null +++ b/openembedded/packages/flex/flex-2.5.31/include.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | |||
2 | # | ||
3 | # Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher | ||
4 | # | ||
5 | |||
6 | --- flex-2.5.31/Makefile.am~include | ||
7 | +++ flex-2.5.31/Makefile.am | ||
8 | @@ -141,7 +141,7 @@ | ||
9 | tests | ||
10 | |||
11 | localedir = $(datadir)/locale | ||
12 | -AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I@includedir@ -I$(top_srcdir)/intl | ||
13 | +AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I$(top_srcdir)/intl | ||
14 | LIBS = @LIBINTL@ @LIBS@ | ||
15 | |||
16 | skel.c: flex.skl mkskel.sh flexint.h tables_shared.h | ||
17 | --- flex-2.5.31/Makefile.in~include | ||
18 | +++ flex-2.5.31/Makefile.in | ||
19 | @@ -292,7 +292,7 @@ | ||
20 | |||
21 | |||
22 | localedir = $(datadir)/locale | ||
23 | -AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I@includedir@ -I$(top_srcdir)/intl | ||
24 | +AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I$(top_srcdir)/intl | ||
25 | |||
26 | # Run GNU indent on sources. Don't run this unless all the sources compile cleanly. | ||
27 | # | ||
diff --git a/openembedded/packages/flex/flex-native_2.5.31.bb b/openembedded/packages/flex/flex-native_2.5.31.bb new file mode 100644 index 0000000000..ff8a42772b --- /dev/null +++ b/openembedded/packages/flex/flex-native_2.5.31.bb | |||
@@ -0,0 +1,10 @@ | |||
1 | include flex.inc | ||
2 | inherit native | ||
3 | PR = "r2" | ||
4 | |||
5 | do_stage () { | ||
6 | install -m 0755 flex ${STAGING_BINDIR} | ||
7 | oe_libinstall -a libfl ${STAGING_LIBDIR} | ||
8 | ln -sf ./flex ${STAGING_BINDIR}/flex++ | ||
9 | ln -sf ./flex ${STAGING_BINDIR}/lex | ||
10 | } | ||
diff --git a/openembedded/packages/flex/flex.inc b/openembedded/packages/flex/flex.inc new file mode 100644 index 0000000000..6e605ac9be --- /dev/null +++ b/openembedded/packages/flex/flex.inc | |||
@@ -0,0 +1,10 @@ | |||
1 | DESCRIPTION = "Flex is a tool for generating programs that recognize lexical patterns in text." | ||
2 | SECTION = "devel" | ||
3 | LICENSE = "BSD" | ||
4 | |||
5 | SRC_URI = "${SOURCEFORGE_MIRROR}/lex/flex-2.5.31.tar.bz2 \ | ||
6 | file://fix-gen.patch;patch=1" | ||
7 | S = "${WORKDIR}/flex-${PV}" | ||
8 | |||
9 | inherit autotools | ||
10 | |||
diff --git a/openembedded/packages/flex/flex_2.5.31.bb b/openembedded/packages/flex/flex_2.5.31.bb new file mode 100644 index 0000000000..b96c645136 --- /dev/null +++ b/openembedded/packages/flex/flex_2.5.31.bb | |||
@@ -0,0 +1,9 @@ | |||
1 | include flex.inc | ||
2 | PR = "r4" | ||
3 | |||
4 | SRC_URI += "file://include.patch;patch=1" | ||
5 | |||
6 | do_stage() { | ||
7 | oe_libinstall -a libfl ${STAGING_LIBDIR} | ||
8 | } | ||
9 | |||