diff options
author | Chris Lord <chris@openedhand.com> | 2006-02-07 04:22:50 +0000 |
---|---|---|
committer | Chris Lord <chris@openedhand.com> | 2006-02-07 04:22:50 +0000 |
commit | 4fbba6350edd17d9272a668b5ba564f558974a94 (patch) | |
tree | dafc821fd7b7d4ec5e08966b6ac479f50f94e5df /openembedded/packages/curl/curl_7.14.0.bb | |
parent | ef60244cc4a28777efdaed9260e8c7ae4872e2b1 (diff) | |
download | poky-4fbba6350edd17d9272a668b5ba564f558974a94.tar.gz |
Add curl (new dependency of Web), fix a fontconfig-native build issue,
update gtkhtml2 patches and update to a newer more functional Web
snapshot
git-svn-id: https://svn.o-hand.com/repos/poky@251 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/curl/curl_7.14.0.bb')
-rw-r--r-- | openembedded/packages/curl/curl_7.14.0.bb | 37 |
1 files changed, 37 insertions, 0 deletions
diff --git a/openembedded/packages/curl/curl_7.14.0.bb b/openembedded/packages/curl/curl_7.14.0.bb new file mode 100644 index 0000000000..a0ad4d14d7 --- /dev/null +++ b/openembedded/packages/curl/curl_7.14.0.bb | |||
@@ -0,0 +1,37 @@ | |||
1 | DESCRIPTION = "Command line tool and library for client-side URL transfers." | ||
2 | LICENSE = "MIT" | ||
3 | DEPENDS = "zlib" | ||
4 | SECTION = "console/network" | ||
5 | |||
6 | SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2" | ||
7 | S = "${WORKDIR}/curl-${PV}" | ||
8 | |||
9 | inherit autotools pkgconfig binconfig | ||
10 | |||
11 | EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \ | ||
12 | --without-ssl \ | ||
13 | --with-random=/dev/urandom \ | ||
14 | --without-idn \ | ||
15 | --enable-http \ | ||
16 | --enable-file" | ||
17 | |||
18 | do_stage () { | ||
19 | install -d ${STAGING_INCDIR}/curl | ||
20 | install -m 0644 ${S}/include/curl/*.h ${STAGING_INCDIR}/curl/ | ||
21 | oe_libinstall -so -a -C lib libcurl ${STAGING_LIBDIR} | ||
22 | } | ||
23 | |||
24 | PACKAGES = "curl curl-doc libcurl libcurl-dev libcurl-doc" | ||
25 | FILES_${PN} = "${bindir}/curl" | ||
26 | FILES_${PN}-doc = "${mandir}/man1/curl.1" | ||
27 | FILES_lib${PN} = "${libdir}/lib*.so.*" | ||
28 | FILES_lib${PN}-dev = "${includedir} \ | ||
29 | ${libdir}/lib*.so \ | ||
30 | ${libdir}/lib*.a \ | ||
31 | ${libdir}/lib*.la \ | ||
32 | ${libdir}/pkgconfig \ | ||
33 | ${datadir}/aclocal \ | ||
34 | ${bindir}/*-config" | ||
35 | FILES_lib${PN}-doc = "${mandir}/man3 \ | ||
36 | ${mandir}/man1/curl-config.1" | ||
37 | |||