summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/avahi
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2005-09-02 11:50:01 +0000
committerRichard Purdie <richard@openedhand.com>2005-09-02 11:50:01 +0000
commit95efeafc86f47592b37c44f2f7314324cc04250d (patch)
treee60fe38e88d8e6cf42cf1311c5ada752b79a59c7 /openembedded/packages/avahi
parent7755d9d194b42ea859096f805f2e22ae5b6e6281 (diff)
downloadpoky-95efeafc86f47592b37c44f2f7314324cc04250d.tar.gz
Add gtk+, avahi, dbus-0.34 (.36 coming soon) and dependencies. Fix x11-common breakage.
git-svn-id: https://svn.o-hand.com/repos/poky@13 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/avahi')
-rw-r--r--openembedded/packages/avahi/avahi_0.2.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/openembedded/packages/avahi/avahi_0.2.bb b/openembedded/packages/avahi/avahi_0.2.bb
new file mode 100644
index 0000000000..00c4dbd599
--- /dev/null
+++ b/openembedded/packages/avahi/avahi_0.2.bb
@@ -0,0 +1,47 @@
1DESCRIPTION = "Avahi implements the DNS-SD over Multicast DNS"
2HOMEPAGE = "http://www.freedesktop.org/Software/Avahi"
3LICENCE= "GPL"
4DEPENDS = "expat libdaemon dbus-0.34"
5RRECOMMENDS = "libnss-mdns"
6SECTION = "net"
7PRIORITY = "optional"
8
9SRC_URI = "http://www.freedesktop.org/~lennart/avahi-${PV}.tar.gz"
10
11# file://no-strict-ansi.patch;patch=1"
12
13PACKAGES = "avahi-daemon libavahi-common libavahi-core libavahi-client avahi-dnsconfd libavahi-glib avahi-dev avahi-doc"
14
15FILES_libavahi-common = "${libdir}/libavahi-common.so.*"
16FILES_libavahi-core= "${libdir}/libavahi-core.so.*"
17FILES_avahi-daemon = "${sbindir}/avahi-daemon \
18 ${sysconfdir}/avahi/avahi-daemon.conf \
19 ${sysconfdir}/avahi/services \
20 ${sysconfdir}/dbus-1 \
21 ${sysconfdir}/init.d/avahi-daemon \
22 ${datadir}/avahi/introspection/*.introspect \
23 ${datadir}/avahi/avahi-service.dtd"
24FILES_libavahi-client = "${libdir}/libavahi-client.so.*"
25FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
26 ${sysconfdir}/avahi/avahi-dnsconfd.action \
27 ${sysconfdir}/init.d/avahi-dnsconfd"
28FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
29
30CONFFILES_avahi-daemon = "${sysconfdir}/avahi/avahi-daemon.conf"
31
32EXTRA_OECONF = "--with-distro=debian --disable-gtk --disable-python"
33inherit autotools
34inherit update-rc.d
35
36INITSCRIPT_PACKAGES = "avahi-daemon avahi-dnsconfd"
37INITSCRIPT_NAME_avahi-daemon = "avahi-daemon"
38INITSCRIPT_NAME_avahi-dnsconfd = "avahi-dnsconfd"
39
40pkg_postinst_avahi-daemon () {
41 grep avahi /etc/passwd || adduser --disabled-password --system --home /var/run/avahi-daemon avahi
42}
43
44pkg_postrm_avahi-daemon () {
45 deluser avahi || true
46}
47