summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/apmd/apmd_3.2.2.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-02-10 11:40:32 +0000
committerRichard Purdie <richard@openedhand.com>2006-02-10 11:40:32 +0000
commitb236090192c018bf8efe8c72019d3d1567b6d158 (patch)
tree5d76931d8d80fb6a9b77d6b040bf3140da57f7eb /openembedded/packages/apmd/apmd_3.2.2.bb
parent6be98eee9dd8f8dfb6a90b3386defc54321497cc (diff)
downloadpoky-b236090192c018bf8efe8c72019d3d1567b6d158.tar.gz
Convert packages CVSDATE -> SRCDATE and standardise some PV fields
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@268 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded/packages/apmd/apmd_3.2.2.bb')
-rw-r--r--openembedded/packages/apmd/apmd_3.2.2.bb25
1 files changed, 3 insertions, 22 deletions
diff --git a/openembedded/packages/apmd/apmd_3.2.2.bb b/openembedded/packages/apmd/apmd_3.2.2.bb
index 0e8b364458..4a23f39590 100644
--- a/openembedded/packages/apmd/apmd_3.2.2.bb
+++ b/openembedded/packages/apmd/apmd_3.2.2.bb
@@ -3,12 +3,12 @@ SECTION = "base"
3PRIORITY = "required" 3PRIORITY = "required"
4DEPENDS = "libtool-cross" 4DEPENDS = "libtool-cross"
5LICENSE = "GPL" 5LICENSE = "GPL"
6PR = "r5" 6PR = "r7"
7 7
8SRC_URI = "${DEBIAN_MIRROR}/main/a/apmd/apmd_${PV}.orig.tar.gz; \ 8SRC_URI = "${DEBIAN_MIRROR}/main/a/apmd/apmd_${PV}.orig.tar.gz; \
9 file://debian.patch;patch=1 \ 9 file://debian.patch;patch=1 \
10 file://workaround.patch;patch=1 \ 10 file://workaround.patch;patch=1 \
11 file://apmwrapper \ 11 file://zaurus24.patch;patch=1 \
12 file://init \ 12 file://init \
13 file://default \ 13 file://default \
14 file://apmd_proxy \ 14 file://apmd_proxy \
@@ -44,25 +44,8 @@ do_install() {
44 install -d ${D}${bindir} 44 install -d ${D}${bindir}
45 install -d ${D}${libdir} 45 install -d ${D}${libdir}
46 install -d ${D}${datadir}/apmd 46 install -d ${D}${datadir}/apmd
47#
48# only Zaurus 2.4-embedix kernels need a breadead apm hack
49#
50#
51 case ${MACHINE} in
52 collie | poodle | tosa | c7x0 | akita | spitz | borzoi)
53 if [ "${KERNEL_VERSION}" == "2.6" ]
54 then
55 install -m 4577 ${S}/.libs/apm ${D}${bindir}/apm
56 else
57 install -m 4755 ${S}/.libs/apm ${D}${bindir}/apm.orig
58 install -m 0755 ${WORKDIR}/apmwrapper ${D}${bindir}/apm
59 fi
60 ;;
61 *)
62 install -m 4577 ${S}/.libs/apm ${D}${bindir}/apm
63 ;;
64 esac
65 47
48 install -m 4755 ${S}/.libs/apm ${D}${bindir}/apm
66 install -m 0755 ${S}/.libs/apmd ${D}${sbindir}/apmd 49 install -m 0755 ${S}/.libs/apmd ${D}${sbindir}/apmd
67 install -m 0755 ${WORKDIR}/apmd_proxy ${D}${sysconfdir}/apm/ 50 install -m 0755 ${WORKDIR}/apmd_proxy ${D}${sysconfdir}/apm/
68 install -m 0644 ${WORKDIR}/apmd_proxy.conf ${D}${datadir}/apmd/ 51 install -m 0644 ${WORKDIR}/apmd_proxy.conf ${D}${datadir}/apmd/
@@ -79,5 +62,3 @@ PACKAGES =+ "libapm libapm-dev apm"
79FILES_libapm = "${libdir}/libapm.so.*" 62FILES_libapm = "${libdir}/libapm.so.*"
80FILES_libapm-dev = "${libdir}/libapm.* ${includedir}" 63FILES_libapm-dev = "${libdir}/libapm.* ${includedir}"
81FILES_apm = "${bindir}/apm*" 64FILES_apm = "${bindir}/apm*"
82
83