summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/ptest-runner/ptest-runner_2.3.bb
diff options
context:
space:
mode:
authorAníbal Limón <anibal.limon@linaro.org>2019-01-09 12:35:41 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-11 10:39:09 +0000
commitb1c2ef099cdb49655f4ae0d9cf9c5baef997e833 (patch)
treef8d50c38b35a7605886e4a56c0f6e8c19aae2256 /meta/recipes-support/ptest-runner/ptest-runner_2.3.bb
parent8ac5e492baf0531a92a81ea06a9cdcf3acbcee69 (diff)
downloadpoky-b1c2ef099cdb49655f4ae0d9cf9c5baef997e833.tar.gz
ptest-runner: Upgrade to 2.3
Addes support to report timeout in XML file and duration in stdout and XML file. See, http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/commit/?id=a16f2c137b http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/commit/?id=8071258373 (From OE-Core rev: c2e069a7f8396d0fe62ad75b76202c29ea84d21c) Signed-off-by: Aníbal Limón <anibal.limon@linaro.org> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/ptest-runner/ptest-runner_2.3.bb')
-rw-r--r--meta/recipes-support/ptest-runner/ptest-runner_2.3.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_2.3.bb b/meta/recipes-support/ptest-runner/ptest-runner_2.3.bb
new file mode 100644
index 0000000000..26add9b0a0
--- /dev/null
+++ b/meta/recipes-support/ptest-runner/ptest-runner_2.3.bb
@@ -0,0 +1,26 @@
1SUMMARY = "A C program to run all installed ptests"
2DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \
3program which loops through all installed ptest test suites and \
4runs them in sequence."
5HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
9
10SRCREV = "80712583732b4a809532f644fb09e7d2e812d7ba"
11PV = "2.3+git${SRCPV}"
12
13SRC_URI = "git://git.yoctoproject.org/ptest-runner2"
14S = "${WORKDIR}/git"
15
16FILES_${PN} = "${bindir}/ptest-runner"
17
18EXTRA_OEMAKE = "-e MAKEFLAGS="
19
20do_compile () {
21 oe_runmake
22}
23
24do_install () {
25 install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner
26}