summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/ptest-runner/ptest-runner_2.1.bb
diff options
context:
space:
mode:
authorAníbal Limón <anibal.limon@linux.intel.com>2017-05-01 13:08:07 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-18 14:01:47 +0100
commitc4a5fb4e81f96a87d3ac307b8ef5d012f7b90ee8 (patch)
treef1ddd37c77e63c61dc20152e48f435ccd0a7e17d /meta/recipes-support/ptest-runner/ptest-runner_2.1.bb
parentc9043894b8c855000b21b32c1a5133e13aa97aa9 (diff)
downloadpoky-c4a5fb4e81f96a87d3ac307b8ef5d012f7b90ee8.tar.gz
ptest-runner: Upgrade to to 2.1+gitAUTOINC+78afe246fb
The new 2.1 version supports creating XML results specifying the -x option. The xml output format can be see here [1]. [1] https://wiki.yoctoproject.org/wiki/QA/xUnit_XML_Template (From OE-Core rev: 93742e37797ef0659bb030cee23a6e3c35e92479) Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/ptest-runner/ptest-runner_2.1.bb')
-rw-r--r--meta/recipes-support/ptest-runner/ptest-runner_2.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_2.1.bb b/meta/recipes-support/ptest-runner/ptest-runner_2.1.bb
new file mode 100644
index 0000000000..89d709a7c0
--- /dev/null
+++ b/meta/recipes-support/ptest-runner/ptest-runner_2.1.bb
@@ -0,0 +1,26 @@
1SUMMARY = "A C program to run all installed ptests"
2DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \
3program which loops through all installed ptest test suites and \
4runs them in sequence."
5HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
9
10SRCREV = "78afe246fb8cb864656c16dd5d1cfa5721ccc8b7"
11PV = "2.1+git${SRCPV}"
12
13SRC_URI = "git://git.yoctoproject.org/ptest-runner2"
14S = "${WORKDIR}/git"
15
16FILES_${PN} = "${bindir}/ptest-runner"
17
18EXTRA_OEMAKE = "-e MAKEFLAGS="
19
20do_compile () {
21 oe_runmake
22}
23
24do_install () {
25 install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner
26}