summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/ptest-runner/ptest-runner_2.0.bb
diff options
context:
space:
mode:
authorAníbal Limón <anibal.limon@linux.intel.com>2016-01-25 17:29:37 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-30 11:36:58 +0000
commit209066ccce1f211b7982372dcb9b9795493aaece (patch)
treed82ac8c672eae6d795bfb4cc7bddb1d72acddbbd /meta/recipes-support/ptest-runner/ptest-runner_2.0.bb
parent4953e2699ede7c8a3b3654fdefc4dd1268e39e09 (diff)
downloadpoky-209066ccce1f211b7982372dcb9b9795493aaece.tar.gz
ptest-runner: Add ptest-runner_2.0 recipe.
The ptest-runner 2.0 is C written program for run ptests of Yocto/Openembedded, is fully compatible with previous version of ptest-runner that was a shell script that runs ptests sequencially. The mainly reason for the new ptest-runner in C is because is designed for run in tiny systems also the old shell script version have problems when certain ptest hang it becomes blocked indefinitely. Now the ptest-runner 2.0 support the next features: - Specify the directory for search ptests. - List available ptests. - Specify the timeout for avoid blocking indefinetly. - Only run certain ptests. Proposed features: - Adds support for per ptest output file. - Adds support for run ptests in parallel (review possible colisions in ptests). [YOCTO #8021] (From OE-Core rev: 2a6746cb5e60c9c5477d1df062bb2657d2fe4780) Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/ptest-runner/ptest-runner_2.0.bb')
-rw-r--r--meta/recipes-support/ptest-runner/ptest-runner_2.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_2.0.bb b/meta/recipes-support/ptest-runner/ptest-runner_2.0.bb
new file mode 100644
index 0000000000..221cf6c287
--- /dev/null
+++ b/meta/recipes-support/ptest-runner/ptest-runner_2.0.bb
@@ -0,0 +1,24 @@
1SUMMARY = "A C program to run all installed ptests"
2DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \
3program which loops through all installed ptest test suites and \
4runs them in sequence."
5HOMEPAGE = "https://github.com/alimon/ptest-runner2"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
9
10SRCREV = "8bfdf946e784f4d5757bebee1fbc4b4a3d7a95c4"
11PV = "2.0+git${SRCPV}"
12
13SRC_URI = "git://github.com/alimon/ptest-runner2.git;protocol=https"
14S = "${WORKDIR}/git"
15
16FILES_${PN} = "${bindir}/ptest-runner"
17
18do_compile () {
19 oe_runmake
20}
21
22do_install () {
23 install -D -m 0755 ${WORKDIR}/git/ptest-runner ${D}${bindir}/ptest-runner
24}