summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/p11-kit/p11-kit_0.23.22.bb
diff options
context:
space:
mode:
authorLee Chee Yang <chee.yang.lee@intel.com>2021-01-18 17:37:31 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-01-20 00:45:05 +0000
commit59b07a71f32c84e592d66595a2a7e1ae9c7ebef8 (patch)
tree01372a5522ca24af637101a6200e518ad6e23c3d /meta/recipes-support/p11-kit/p11-kit_0.23.22.bb
parent0955777d5fdd9cbfae87e2a1695c611624afe717 (diff)
downloadpoky-59b07a71f32c84e592d66595a2a7e1ae9c7ebef8.tar.gz
p11-kit: upgrade 0.23.21 -> 0.23.22
https://github.com/p11-glue/p11-kit/releases/tag/0.23.22 Release notes: Fix memory-safety issues that affect the RPC protocol (CVE-2020-29361, CVE-2020-29362, and CVE-2020-29363), discovered and fixed by David Cook anchor: Prefer persistent format when storing anchor [#329] common: Fix infloop in p11_path_build [#326, #327] proxy: C_CloseAllSessions: Make sure that calloc args are non-zero [#325] common: Check for a NULL locale before freeing it [#321] Build and test fixes [#313, #315, #317, #318, #319, #323, #330, #333, #334, #335, #338, #339] https://github.com/p11-glue/p11-kit/commit/c4e75e10021ce86ab42682ea4936dce94ced2f77 patch to fix trailing newline using custom_target() caused error with DISTRO_FEATURES api-documentation due to meson bugs, enable manpages PACKAGECONFIG should prevent this error. | warning: failed to load external entity "../version.xml" | ../p11-kit-docs.xml:11: parser error : Failure to process entity version | <releaseinfo>for p11-kit &version;</releaseinfo> | ^ | ../p11-kit-docs.xml:11: parser error : Entity 'version' not defined | <releaseinfo>for p11-kit &version;</releaseinfo> | ^ | unable to parse ../p11-kit-docs.xml (From OE-Core rev: b112ba291835061640123c13784e2b33cc73f17d) Signed-off-by: Lee Chee Yang <chee.yang.lee@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/p11-kit/p11-kit_0.23.22.bb')
-rw-r--r--meta/recipes-support/p11-kit/p11-kit_0.23.22.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-support/p11-kit/p11-kit_0.23.22.bb b/meta/recipes-support/p11-kit/p11-kit_0.23.22.bb
new file mode 100644
index 0000000000..c539ecdbc6
--- /dev/null
+++ b/meta/recipes-support/p11-kit/p11-kit_0.23.22.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Provides a way to load and enumerate PKCS#11 modules"
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://COPYING;md5=02933887f609807fbb57aa4237d14a50"
4
5inherit meson gettext pkgconfig gtk-doc bash-completion manpages
6
7DEPENDS = "libtasn1 libtasn1-native libffi"
8
9DEPENDS_append = "${@' glib-2.0' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}"
10
11SRC_URI = "git://github.com/p11-glue/p11-kit;branch=0.23"
12SRCREV = "bd97afbfe28d5fbbde95ce36ff7a8834fc0291ee"
13S = "${WORKDIR}/git"
14
15PACKAGECONFIG ??= ""
16PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxslt-native"
17PACKAGECONFIG[trust-paths] = "-Dtrust_paths=/etc/ssl/certs/ca-certificates.crt,,,ca-certificates"
18
19GTKDOC_MESON_OPTION = 'gtk_doc'
20
21FILES_${PN} += " \
22 ${libdir}/p11-kit-proxy.so \
23 ${libdir}/pkcs11/*.so \
24 ${libdir}/pkcs11/*.la \
25 ${systemd_user_unitdir}/*"
26
27# PN contains p11-kit-proxy.so, a symlink to a loadable module
28INSANE_SKIP_${PN} = "dev-so"
29
30BBCLASSEXTEND = "nativesdk"