summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/p11-kit/p11-kit_0.23.16.1.bb
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2019-05-28 18:28:07 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-29 12:54:12 +0100
commit05eb9a66958bcae3b8519a601a74d23483018357 (patch)
tree261a85092352e75e613b9bfdb804939706dc5e1c /meta/recipes-support/p11-kit/p11-kit_0.23.16.1.bb
parent66030644e0cfa1ceff66b3d880bb828127c45d1d (diff)
downloadpoky-05eb9a66958bcae3b8519a601a74d23483018357.tar.gz
p11-kit: update to 0.23.16.1
(From OE-Core rev: 8e8771228cce595ccf3626e601faa3caa5735353) Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/p11-kit/p11-kit_0.23.16.1.bb')
-rw-r--r--meta/recipes-support/p11-kit/p11-kit_0.23.16.1.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-support/p11-kit/p11-kit_0.23.16.1.bb b/meta/recipes-support/p11-kit/p11-kit_0.23.16.1.bb
new file mode 100644
index 0000000000..54455da1bb
--- /dev/null
+++ b/meta/recipes-support/p11-kit/p11-kit_0.23.16.1.bb
@@ -0,0 +1,46 @@
1SUMMARY = "Provides a way to load and enumerate PKCS#11 modules"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://COPYING;md5=02933887f609807fbb57aa4237d14a50"
4
5inherit autotools gettext pkgconfig gtk-doc
6
7DEPENDS = "libtasn1 libffi"
8
9SRC_URI = "git://github.com/p11-glue/p11-kit \
10 file://0001-LINGUAS-drop-the-languages-for-which-upstream-does-n.patch \
11 "
12SRCREV = "c689917b393379d288b868f70b2f7b7f6aafe430"
13S = "${WORKDIR}/git"
14
15AUTOTOOLS_AUXDIR = "${S}/build/litter"
16
17PACKAGECONFIG ??= ""
18PACKAGECONFIG[trust-paths] = "--with-trust-paths=/etc/ssl/certs/ca-certificates.crt,--without-trust-paths,,ca-certificates"
19
20# This recipe does not use the standard gtk-doc m4 macros, and so the ./configure flags
21# that control gtk-doc build are non-standard
22EXTRA_OECONF_prepend_class-target = "${@bb.utils.contains('GTKDOC_ENABLED', 'True', '--enable-doc --enable-doc-html --disable-doc-pdf', \
23 '--disable-doc', d)} "
24
25# When building native recipes, disable gtkdoc, as it is not necessary,
26# pulls in additional dependencies, and makes build times longer
27EXTRA_OECONF_prepend_class-native = "--disable-doc "
28EXTRA_OECONF_prepend_class-nativesdk = "--disable-doc "
29
30UNKNOWN_CONFIGURE_WHITELIST_append = " --enable-gtk-doc-html --disable-gtk-doc-pdf --enable-gtk-doc --disable-gtk-doc"
31
32# p11-kit relies on these two being copied from source tree
33# instead of being regenerated by gtkdoc-scan, but doesn't setup
34# dependencies correctly when there is a parallel build. Let's pre-copy
35# them instead.
36do_compile_prepend () {
37 cp ${S}/doc/manual/p11-kit-overrides.txt ${S}/doc/manual/p11-kit-sections.txt ${B}/doc/manual/
38}
39
40FILES_${PN} += " \
41 ${libdir}/p11-kit-proxy.so \
42 ${libdir}/pkcs11/*.so \
43 ${libdir}/pkcs11/*.la"
44
45# PN contains p11-kit-proxy.so, a symlink to a loadable module
46INSANE_SKIP_${PN} = "dev-so"