summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/p11-kit/p11-kit_0.22.1.bb
diff options
context:
space:
mode:
authorAlex Kiernan <alex.kiernan@gmail.com>2018-09-20 15:06:05 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-09-21 18:45:47 -0700
commite7e081aa2ade429ad28e4c488ee62153aa7839eb (patch)
tree6821b0f432daae79308b9e117128790139cb2ee9 /meta/recipes-support/p11-kit/p11-kit_0.22.1.bb
parent631b3edebd1acc963aecdfffa066c78dc9bf98ef (diff)
downloadpoky-e7e081aa2ade429ad28e4c488ee62153aa7839eb.tar.gz
p11-kit: Upgrade from 0.22.1 -> 0.23.14
p11-kit is no longer doing odd/even for development/stable releases, so drop the custom UPSTREAM_CHECK_GITTAGREGEX. (From OE-Core rev: 1a38f27342c5a40f81e579b2d0feb7b6e9880ac7) Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/p11-kit/p11-kit_0.22.1.bb')
-rw-r--r--meta/recipes-support/p11-kit/p11-kit_0.22.1.bb46
1 files changed, 0 insertions, 46 deletions
diff --git a/meta/recipes-support/p11-kit/p11-kit_0.22.1.bb b/meta/recipes-support/p11-kit/p11-kit_0.22.1.bb
deleted file mode 100644
index 57798f4020..0000000000
--- a/meta/recipes-support/p11-kit/p11-kit_0.22.1.bb
+++ /dev/null
@@ -1,46 +0,0 @@
1SUMMARY = "Provides a way to load and enumerate PKCS#11 modules"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://COPYING;md5=02933887f609807fbb57aa4237d14a50"
4
5inherit autotools gettext pkgconfig gtk-doc
6
7DEPENDS = "libtasn1 libffi"
8
9SRC_URI = "git://github.com/p11-glue/p11-kit \
10 file://0001-LINGUAS-drop-the-languages-for-which-upstream-does-n.patch \
11 "
12SRCREV = "bfb3bd47aa48983f5349479bca598403097ff81c"
13S = "${WORKDIR}/git"
14# exclude odd minor versions, which are development releases
15UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+\.(\d*[02468])+(\.\d+)+)"
16
17AUTOTOOLS_AUXDIR = "${S}/build/litter"
18EXTRA_OECONF = "--without-trust-paths"
19
20# This recipe does not use the standard gtk-doc m4 macros, and so the ./configure flags
21# that control gtk-doc build are non-standard
22EXTRA_OECONF_prepend_class-target = "${@bb.utils.contains('GTKDOC_ENABLED', 'True', '--enable-doc --enable-doc-html --disable-doc-pdf', \
23 '--disable-doc', d)} "
24
25# When building native recipes, disable gtkdoc, as it is not necessary,
26# pulls in additional dependencies, and makes build times longer
27EXTRA_OECONF_prepend_class-native = "--disable-doc "
28EXTRA_OECONF_prepend_class-nativesdk = "--disable-doc "
29
30UNKNOWN_CONFIGURE_WHITELIST_append = " --enable-gtk-doc-html --disable-gtk-doc-pdf --enable-gtk-doc --disable-gtk-doc"
31
32# p11-kit relies on these two being copied from source tree
33# instead of being regenerated by gtkdoc-scan, but doesn't setup
34# dependencies correctly when there is a parallel build. Let's pre-copy
35# them instead.
36do_compile_prepend () {
37 cp ${S}/doc/manual/p11-kit-overrides.txt ${S}/doc/manual/p11-kit-sections.txt ${B}/doc/manual/
38}
39
40FILES_${PN} += " \
41 ${libdir}/p11-kit-proxy.so \
42 ${libdir}/pkcs11/*.so \
43 ${libdir}/pkcs11/*.la"
44
45# PN contains p11-kit-proxy.so, a symlink to a loadable module
46INSANE_SKIP_${PN} = "dev-so"