summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/numactl/numactl_git.bb
diff options
context:
space:
mode:
authorRandy Witt <randy.e.witt@intel.com>2020-10-19 14:42:11 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-10-30 13:22:47 +0000
commit595d57bd460faae80ce6b443b136b1e60594fd3f (patch)
treec19714cc3e8b9e3a1bd57d935deff02f17690244 /meta/recipes-support/numactl/numactl_git.bb
parente547cfcd906e57ac88431ac97df4c8f250d85749 (diff)
downloadpoky-595d57bd460faae80ce6b443b136b1e60594fd3f.tar.gz
numactl: Add the recipe for numactl
This is a direct copy of numactl from meta-openembedded. numactl is being moved to oe-core since the latest versions of rt-tests(which is in oe-core) require libnuma. (From OE-Core rev: dda815792b0939b2f233aa3ec7c140fc114a37d1) Signed-off-by: Randy Witt <randy.e.witt@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/numactl/numactl_git.bb')
-rw-r--r--meta/recipes-support/numactl/numactl_git.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/meta/recipes-support/numactl/numactl_git.bb b/meta/recipes-support/numactl/numactl_git.bb
new file mode 100644
index 0000000000..20b7fed862
--- /dev/null
+++ b/meta/recipes-support/numactl/numactl_git.bb
@@ -0,0 +1,60 @@
1SUMMARY = "Development package for building Applications that use numa"
2HOMEPAGE = "http://oss.sgi.com/projects/libnuma/"
3DESCRIPTION = "Simple NUMA policy support. It consists of a numactl program \
4to run other programs with a specific NUMA policy and a libnuma to do \
5allocations with NUMA policy in applications."
6LICENSE = "GPL-2.0 & LGPL-2.1"
7SECTION = "apps"
8
9inherit autotools-brokensep ptest
10
11LIC_FILES_CHKSUM = "file://README.md;beginline=19;endline=32;md5=f8ff2391624f28e481299f3f677b21bb"
12
13SRCREV = "5d9f16722e3df49dc618a9f361bd482559695db7"
14PV = "2.0.13+git${SRCPV}"
15
16SRC_URI = "git://github.com/numactl/numactl \
17 file://Fix-the-test-output-format.patch \
18 file://Makefile \
19 file://run-ptest \
20 file://0001-define-run-test-target.patch \
21 file://0001-numademo-fix-error-on-32bit-system.patch \
22"
23
24S = "${WORKDIR}/git"
25
26# ARM does not currently support NUMA
27COMPATIBLE_HOST = "^((?!arm).*)$"
28
29do_install() {
30 oe_runmake DESTDIR=${D} prefix=${D}/usr install
31 #remove the empty man2 directory
32 rm -r ${D}${mandir}/man2
33}
34
35do_compile_ptest() {
36 oe_runmake test
37}
38
39do_install_ptest() {
40 #install tests binaries
41 local test_binaries="distance ftok mbind_mig_pages migrate_pages move_pages \
42 mynode nodemap node-parse pagesize prefered randmap realloc_test \
43 tbitmap tshared"
44
45 [ ! -d ${D}/${PTEST_PATH}/test ] && mkdir -p ${D}/${PTEST_PATH}/test
46 for i in $test_binaries; do
47 install -m 0755 ${B}/test/.libs/$i ${D}${PTEST_PATH}/test
48 done
49
50 local test_scripts="checktopology checkaffinity printcpu regress regress2 \
51 shmtest runltp bind_range"
52 for i in $test_scripts; do
53 install -m 0755 ${B}/test/$i ${D}${PTEST_PATH}/test
54 done
55
56 install -m 0755 ${WORKDIR}/Makefile ${D}${PTEST_PATH}/
57 install -m 0755 ${B}/.libs/numactl ${D}${PTEST_PATH}/
58}
59
60RDEPENDS_${PN}-ptest = "bash"