summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/npth/npth_1.7.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2024-03-13 18:33:27 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-16 08:07:01 +0100
commit9ac975fc8a47d77e9efbdcffd33221a2c53f6afe (patch)
tree4eb01c1357edd0831e83b673279f674043fc1a30 /meta/recipes-support/npth/npth_1.7.bb
parent8d2b914b509d5633cb27f42a8df0b4e4ca64915f (diff)
downloadpoky-9ac975fc8a47d77e9efbdcffd33221a2c53f6afe.tar.gz
npth: update 1.6 -> 1.7
Drop 0001-Revert-Fix-problem-with-regression-tests-on-recent-g.patch (upstream resolved the issue) npth-config is no longer installed. (From OE-Core rev: 21cd99cd96fd8a06d007fe00570ebac98fedbdad) Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/npth/npth_1.7.bb')
-rw-r--r--meta/recipes-support/npth/npth_1.7.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-support/npth/npth_1.7.bb b/meta/recipes-support/npth/npth_1.7.bb
new file mode 100644
index 0000000000..f02a731f85
--- /dev/null
+++ b/meta/recipes-support/npth/npth_1.7.bb
@@ -0,0 +1,25 @@
1SUMMARY = "New GNU Portable Threads library"
2DESCRIPTION = "nPth is a library to provide the GNU Pth API and thus a non-preemptive threads implementation. "
3HOMEPAGE = "https://www.gnu.org/software/pth/"
4SECTION = "libs"
5LICENSE = "LGPL-2.0-or-later"
6LIC_FILES_CHKSUM = "\
7 file://COPYING.LIB;md5=2caced0b25dfefd4c601d92bd15116de\
8 "
9UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
10SRC_URI = "${GNUPG_MIRROR}/npth/npth-${PV}.tar.bz2 \
11 file://pkgconfig.patch \
12 file://musl-fix.patch \
13 "
14
15SRC_URI[sha256sum] = "8589f56937b75ce33b28d312fccbf302b3b71ec3f3945fde6aaa74027914ad05"
16
17inherit autotools binconfig-disabled multilib_header
18
19FILES:${PN} = "${libdir}/libnpth.so.*"
20
21do_install:append() {
22 oe_multilib_header npth.h
23}
24
25BBCLASSEXTEND = "native nativesdk"