summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/nghttp2/nghttp2_1.60.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2024-03-06 07:42:18 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-03-07 17:25:02 +0000
commit4c7e012637cf8bc7072cfe19c4c5fba4fe7a6861 (patch)
treeaf0cbf873c6ee0a52678fb1ba5f9429931818eaa /meta/recipes-support/nghttp2/nghttp2_1.60.0.bb
parentd339047b836d9d54df1006814f47f72d9d40db38 (diff)
downloadpoky-4c7e012637cf8bc7072cfe19c4c5fba4fe7a6861.tar.gz
nghttp2: upgrade 1.59.0 -> 1.60.0
Drop patch as issue addressed upstream. (From OE-Core rev: b6b337c68fa27a359db6efbedf492ca0cb9d9234) Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/nghttp2/nghttp2_1.60.0.bb')
-rw-r--r--meta/recipes-support/nghttp2/nghttp2_1.60.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-support/nghttp2/nghttp2_1.60.0.bb b/meta/recipes-support/nghttp2/nghttp2_1.60.0.bb
new file mode 100644
index 0000000000..cf62c32d8b
--- /dev/null
+++ b/meta/recipes-support/nghttp2/nghttp2_1.60.0.bb
@@ -0,0 +1,28 @@
1SUMMARY = "HTTP/2 C Library and tools"
2HOMEPAGE = "https://nghttp2.org/"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=764abdf30b2eadd37ce47dcbce0ea1ec"
6
7SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/nghttp2-${PV}.tar.xz"
8SRC_URI[sha256sum] = "625d6c3da1d9ca4fd643a638256431ae68fd1901653b2a61a245eea7b261bf4e"
9
10inherit cmake manpages python3native github-releases
11PACKAGECONFIG[manpages] = ""
12
13# examples are never installed, and don't need to be built in the
14# first place
15EXTRA_OECMAKE = "-DENABLE_EXAMPLES=OFF -DENABLE_APP=OFF -DENABLE_HPACK_TOOLS=OFF -DENABLE_PYTHON_BINDINGS=OFF"
16
17PACKAGES =+ "lib${BPN} ${PN}-proxy "
18
19RDEPENDS:${PN} = "${PN}-proxy (>= ${PV})"
20RDEPENDS:${PN}:class-native = ""
21RDEPENDS:${PN}-proxy = "openssl python3-core python3-io python3-shell"
22
23ALLOW_EMPTY:${PN} = "1"
24FILES:${PN} = ""
25FILES:lib${BPN} = "${libdir}/*${SOLIBS}"
26FILES:${PN}-proxy = "${bindir}/nghttpx ${datadir}/${BPN}/fetch-ocsp-response"
27
28BBCLASSEXTEND = "native nativesdk"