summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/nettle/nettle_3.9.1.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-06-27 15:17:09 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-06-28 07:56:33 +0100
commite614c7822d18f4add9005a9429f4a585b0ed91e3 (patch)
treeb7890a2bea285a28191abff4dcc71632944101f2 /meta/recipes-support/nettle/nettle_3.9.1.bb
parent96d1cfca0c55f7e2ac8a4fc0321e3aff93c1e98a (diff)
downloadpoky-e614c7822d18f4add9005a9429f4a585b0ed91e3.tar.gz
nettle: upgrade 3.9 -> 3.9.1
Bug fixes: ========== * Fix OCB loop for processing messages of size 272 bytes or larger. * Fix alignment bug in the new x86_64 non-pclmul assembly implementation of ghash. * Fix build-time memory leak in eccdata. (From OE-Core rev: 7595367022b2a0226a3996bf2e6152a452e92715) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/nettle/nettle_3.9.1.bb')
-rw-r--r--meta/recipes-support/nettle/nettle_3.9.1.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-support/nettle/nettle_3.9.1.bb b/meta/recipes-support/nettle/nettle_3.9.1.bb
new file mode 100644
index 0000000000..6bb76a6217
--- /dev/null
+++ b/meta/recipes-support/nettle/nettle_3.9.1.bb
@@ -0,0 +1,58 @@
1SUMMARY = "A low level cryptographic library"
2DESCRIPTION = "Nettle is a cryptographic library that is designed to fit easily in more or less any context: In crypto toolkits for object-oriented languages (C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in kernel space."
3HOMEPAGE = "http://www.lysator.liu.se/~nisse/nettle/"
4DESCRIPTION = "It tries to solve a problem of providing a common set of \
5cryptographic algorithms for higher-level applications by implementing a \
6context-independent set of cryptographic algorithms"
7SECTION = "libs"
8LICENSE = "LGPL-3.0-or-later | GPL-2.0-or-later"
9
10LIC_FILES_CHKSUM = "file://COPYING.LESSERv3;md5=6a6a8e020838b23406c81b19c1d46df6 \
11 file://COPYINGv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
12 file://serpent-decrypt.c;beginline=14;endline=36;md5=ca0d220bc413e1842ecc507690ce416e \
13 file://serpent-set-key.c;beginline=14;endline=36;md5=ca0d220bc413e1842ecc507690ce416e"
14
15DEPENDS += "gmp"
16
17SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \
18 file://Add-target-to-only-build-tests-not-run-them.patch \
19 file://run-ptest \
20 file://check-header-files-of-openssl-only-if-enable_.patch \
21 "
22
23SRC_URI[sha256sum] = "ccfeff981b0ca71bbd6fbcb054f407c60ffb644389a5be80d6716d5b550c6ce3"
24
25UPSTREAM_CHECK_REGEX = "nettle-(?P<pver>\d+(\.\d+)+)\.tar"
26
27inherit autotools ptest multilib_header lib_package
28
29EXTRA_AUTORECONF += "--exclude=aclocal"
30
31EXTRA_OECONF = "--disable-openssl"
32
33do_compile_ptest() {
34 oe_runmake buildtest
35}
36
37do_install:append() {
38 oe_multilib_header nettle/version.h
39}
40
41do_install_ptest() {
42 install -d ${D}${PTEST_PATH}/testsuite/
43 install ${B}/testsuite/*-test ${D}${PTEST_PATH}/testsuite/
44 install ${S}/testsuite/*-test ${D}${PTEST_PATH}/testsuite/
45 install ${S}/testsuite/gold-bug.txt ${D}${PTEST_PATH}/testsuite/
46
47 # Install a symlink for dlopen-test
48 ln -sr ${D}${libdir}/libnettle.so.*.* ${D}${PTEST_PATH}/libnettle.so
49 # These examples are needed for pkcs1-conv-test
50 install ${B}/examples/rsa-sign ${B}/examples/rsa-verify ${D}${PTEST_PATH}/testsuite/
51 # Fix build-time relative paths
52 sed -i -e 's|../tools/|${bindir}/|g' ${D}${PTEST_PATH}/testsuite/*-test
53 sed -i -e 's|../examples/|./|g' ${D}${PTEST_PATH}/testsuite/*-test
54}
55
56RDEPENDS:${PN}-ptest += "${PN}-bin"
57
58BBCLASSEXTEND = "native nativesdk"