summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/lzo/lzo_2.10.bb
diff options
context:
space:
mode:
authorFan Xin <fan.xin@jp.fujitsu.com>2017-06-02 13:49:05 +0900
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-06 19:52:26 +0100
commitfff42bb44faf03fcb8e69d9a1c5809af81493fbc (patch)
tree6b2b09be40b8602d1b5d4c26a3df0a6cfc8cda6d /meta/recipes-support/lzo/lzo_2.10.bb
parent591b6623ebcb66bafa775fbdfb090b1e9a6b517f (diff)
downloadpoky-fff42bb44faf03fcb8e69d9a1c5809af81493fbc.tar.gz
lzo: Upgrade 2.09 -> 2.10
1. Upgrade lzo from 2.09 to 2.10 2. Update the license checksum due to the date change, not license change. 3. Add a patch to fix the undefined error. (From OE-Core rev: 874cf9e9ec72eb7235ef1997fdfea9c33b3628f6) Signed-off-by: Fan Xin <fan.xin@jp.fujitsu.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/lzo/lzo_2.10.bb')
-rw-r--r--meta/recipes-support/lzo/lzo_2.10.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-support/lzo/lzo_2.10.bb b/meta/recipes-support/lzo/lzo_2.10.bb
new file mode 100644
index 0000000000..490d2307ac
--- /dev/null
+++ b/meta/recipes-support/lzo/lzo_2.10.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Lossless data compression library"
2HOMEPAGE = "http://www.oberhumer.com/opensource/lzo/"
3SECTION = "libs"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
6 file://src/lzo_init.c;beginline=5;endline=25;md5=9ae697ca01829b0a383c5d2d163e0108"
7
8SRC_URI = "http://www.oberhumer.com/opensource/lzo/download/lzo-${PV}.tar.gz \
9 file://0001-Use-memcpy-instead-of-reinventing-it.patch \
10 file://0001-Add-pkgconfigdir-to-solve-the-undefine-error.patch \
11 file://acinclude.m4 \
12 file://run-ptest \
13 "
14
15SRC_URI[md5sum] = "39d3f3f9c55c87b1e5d6888e1420f4b5"
16SRC_URI[sha256sum] = "c0f892943208266f9b6543b3ae308fab6284c5c90e627931446fb49b4221a072"
17
18inherit autotools ptest
19
20EXTRA_OECONF = "--enable-shared"
21
22do_configure_prepend () {
23 cp ${WORKDIR}/acinclude.m4 ${S}/
24}
25
26do_install_ptest() {
27 t=${D}${PTEST_PATH}
28 cp ${S}/util/check.sh $t
29 cp ${B}/minilzo/testmini $t
30 for i in tests/align tests/chksum lzotest/lzotest examples/simple
31 do cp ${B}/`dirname $i`/.libs/`basename $i` $t; \
32 done
33}
34
35
36BBCLASSEXTEND = "native nativesdk"