summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/lz4/lz4_1.8.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2018-05-21 19:17:42 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-29 21:07:15 +0100
commit03e0a1f196196e28bf9af36115e937492ce6d4bc (patch)
treed0094b10d1e6fa25b8780563f38421ac30a2cb8f /meta/recipes-support/lz4/lz4_1.8.2.bb
parent75d8f81ff37584327b51c6422fe830b603f42e10 (diff)
downloadpoky-03e0a1f196196e28bf9af36115e937492ce6d4bc.tar.gz
lz4: upgrade 1.8.1.2 -> 1.8.2
(From OE-Core rev: 235afa344423188af2a24aa2664c628d5809699b) Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/lz4/lz4_1.8.2.bb')
-rw-r--r--meta/recipes-support/lz4/lz4_1.8.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-support/lz4/lz4_1.8.2.bb b/meta/recipes-support/lz4/lz4_1.8.2.bb
new file mode 100644
index 0000000000..5ad17e1f79
--- /dev/null
+++ b/meta/recipes-support/lz4/lz4_1.8.2.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Extremely Fast Compression algorithm"
2DESCRIPTION = "LZ4 is a very fast lossless compression algorithm, providing compression speed at 400 MB/s per core, scalable with multi-cores CPU. It also features an extremely fast decoder, with speed in multiple GB/s per core, typically reaching RAM speed limits on multi-core systems."
3
4LICENSE = "BSD | BSD-2-Clause | GPL-2.0"
5LIC_FILES_CHKSUM = "file://lib/LICENSE;md5=ebc2ea4814a64de7708f1571904b32cc \
6 file://programs/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://LICENSE;md5=d57c0d21cb917fb4e0af2454aa48b956 \
8 "
9
10PE = "1"
11
12SRCREV = "b3692db46d2b23a7c0af2d5e69988c94f126e10a"
13
14SRC_URI = "git://github.com/lz4/lz4.git \
15 file://run-ptest \
16 "
17UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)"
18
19S = "${WORKDIR}/git"
20
21EXTRA_OEMAKE = "PREFIX=${prefix} CC='${CC}' DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir}"
22
23do_install() {
24 oe_runmake install
25}
26
27BBCLASSEXTEND = "native nativesdk"